Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: Album List filtered results not showing all in 2.0, works right in 1.6.16 (Read 390 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Album List filtered results not showing all in 2.0, works right in 1.6.16

I have not migrated to version 2.0 yet, but am verifying all the components I use work as expected.  This is unrelated to components.  If I search on something, in this case BSBWABRW, in the album tag I get different results in version 2 versus version 1.  In this case, version 1 is correct.  The libraries in both are configured the same.  See the screen shots below.




To all that make Foobar2000 possible, THANK YOU!  What a fantastic program.

Re: Album List filtered results not showing all in 2.0, works right in 1.6.16

Reply #1
It's almost certainly not a filtering issue. You missing the tracks from the media library in 2.0 is way more likely.

Do you have the same number of tracks in the media library in 1.6.x and in 2.x? Probably fastest way to check is to right click on the top "All Music" line in the album list when there are no filters active and select Properties. The title of the properties dialog will show how many track there are.

I'm going to assume the files are somehow special and need a non-bundled component to show and that is why they are missing from 2.0. You could easily confirm this by right clicking a missing track in foobar2000 v1.x, open its properties and shows a screenshot of the contents of the Details tab.

Also you should be using the latest foobar2000 v2.1 preview over the now ancient 2.0 release version. There have been countless fixes since that build.

Re: Album List filtered results not showing all in 2.0, works right in 1.6.16

Reply #2
I am using, or rather migrating to the 64 bit version, using the now ancient 2.0.  I generally stick with non-beta versions unless there's a compelling reason to switch.

As it happens, the number of items is different in the two versions even though the library each is configured for is exactly the same.  Same drive and directory structure, as shown in the screenshot above that was taken on one computer at the same time.  There are 478,422 in 2.0 and 485,066 in 1.6.  Interestingly, the Bruckner albums that don't show up in the filtered view shown above do show up in the album list, one of them is playing right now.  It is a DSF file.  However, when I just tried the same filter again in 2.0 four of the five albums do show up.  Could it have something to do with me opening Bruckner in the album list and playing one of the albums?  I have not changed anything at this point.

04 under Wagner still did not show up and it doesn't in the unfiltered album list either.  I can drag it from Windows Exploder into the playlist and it plays fine.  I couldn't detect any special characters in the album folder name, but renamed it anyway and it now does show up in the Album List view and the filtered results are correct.  The number of tracks increased by five as well in the All Music properties dialog. I'm guessing this is also why the number of tracks is different - 2.0 doesn't like something in the album folder name for some number of albums.

I downloaded and installed 2.1.  It still shows the same number of tracks, plus the five it now sees on the renamed folder.  6,639 tracks is a lot of tracks and albums to chase down.  Is there some automated way to find which folders are excluded from the album list?

Thanks for your help, I really appreciate it.

By the way, the screen shots in my first post are on the same computer

Re: Album List filtered results not showing all in 2.0, works right in 1.6.16

Reply #3
The deal with beta vs non-beta is not so clear cut with foobar2000. The alpha tester group is super tiny, beta testers are often enthusiasts who are quite familiar with all the quirks. There are way too many "normal" users who are afraid of installing something not labeled as stable so not every scenario comes up during development. A lot of issues are only found when the program is exposed to more people and their way of running it.

Anyway, foobar2000 v2.0 had a bug that it refused to add files to media library if it saw them during initial scan but had no decoder for them. Your DSF files are such files. The bug is fixed in 2.1 but unfortunately you need to remove the affected directories from the media library and re-add them back to trigger a rescan.

Re: Album List filtered results not showing all in 2.0, works right in 1.6.16

Reply #4
That took care of it, thanks!  I generally subscribe to the 'if it ain't broke don't fix it' philosophy, but in this case with the evolution to 64 bit and taking into account your description of how new releases are released I'll be more willing to update as new releases show up with Foobar2000.

Again, thanks for your help.