Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: foo_midi (foobar2000 v2.0) (Read 35150 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: foo_midi (foobar2000 v2.0)

Reply #175
There's a problem in Secret Sauce. When i play some midis, they cuts in the beginning, and just sounds pianos, with weak pitch bends, and the map resets to SC-8820 (even if i have the flavor in GS SC-55), most of them sounds fine if i set the flavor in GM, GM2 and XG, but the problem is in GS and Default, however, some of them, aren't fix with any flavor. I leave you one of the midis that Secret Sauce plays wrongly, try it.
Is this a general problem or do you think it was introduced in a particular version?
Is a general problem, it was always there.

Re: foo_midi (foobar2000 v2.0)

Reply #176
I'd like to be able to route the MIDI messages to external MIDI ports to use it with different software or hardware synths. I already have a system-wide software setup using LoopMIDI and FalcoSoft MIDI Player with Yamaha S-YXG50 VST as my main synth. Will such functionality be ever considered and implemented in foo_midi?
Random digital audio nerd girl

Re: foo_midi (foobar2000 v2.0)

Reply #177
I'd like to be able to route the MIDI messages to external MIDI ports to use it with different software or hardware synths. I already have a system-wide software setup using LoopMIDI and FalcoSoft MIDI Player with Yamaha S-YXG50 VST as my main synth. Will such functionality be ever considered and implemented in foo_midi?

Yamaha S-YXG50 VST is my favorite VST too..
Kode54 setup Foo-Midi so it can use it..
you just need VST .dll file(s) and the wave-tables..
he gave me a copy of those a long time ago..
If you want a copy I could PM you?


you just need to extract the VST to a folder and point Foo_midi in the advanced settings of Foobar2000 to look for VSTs in that location.

Re: foo_midi (foobar2000 v2.0)

Reply #178
I'd like to be able to route the MIDI messages to external MIDI ports to use it with different software or hardware synths. I already have a system-wide software setup using LoopMIDI and FalcoSoft MIDI Player with Yamaha S-YXG50 VST as my main synth. Will such functionality be ever considered and implemented in foo_midi?
That has already been requested on GitHub. I don't say "no" but don't hold your breath: foo_midi sees and processes each individual MIDI message and hands it over to the selected synthesizer but the Windows external MIDI API expects buffers with the messages ordered differently. It would require a major redesign of the plugin.

Re: foo_midi (foobar2000 v2.0)

Reply #179
I'd like to be able to route the MIDI messages to external MIDI ports to use it with different software or hardware synths. I already have a system-wide software setup using LoopMIDI and FalcoSoft MIDI Player with Yamaha S-YXG50 VST as my main synth. Will such functionality be ever considered and implemented in foo_midi?

Yamaha S-YXG50 VST is my favorite VST too..
Kode54 setup Foo-Midi so it can use it..
you just need VST .dll file(s) and the wave-tables..
he gave me a copy of those a long time ago..
If you want a copy I could PM you?


you just need to extract the VST to a folder and point Foo_midi in the advanced settings of Foobar2000 to look for VSTs in that location.
I think you misunderstood me. I don't need the copy of S-YXG50 because i already have it (and it's still available from the webpage of its unofficial maintainer (https://veg.by/en/projects/syxg50/), so i don't undestand why you'd need to DM it to me instead of linking the website).

I'd like to be able to route the MIDI messages to external MIDI ports to use it with different software or hardware synths. I already have a system-wide software setup using LoopMIDI and FalcoSoft MIDI Player with Yamaha S-YXG50 VST as my main synth. Will such functionality be ever considered and implemented in foo_midi?
That has already been requested on GitHub. I don't say "no" but don't hold your breath: foo_midi sees and processes each individual MIDI message and hands it over to the selected synthesizer but the Windows external MIDI API expects buffers with the messages ordered differently. It would require a major redesign of the plugin.
Oh, i see, I'm glad that at least I'm not the only one who'd love to see it, will keep my fingers crossed.

In the meantime, how am i supposed to use a VST directly with the foo_midi plugin? I only see the VST path in advanced settings, but no way to select the desired VST synth in the main foo_midi configuration window.
Random digital audio nerd girl

Re: foo_midi (foobar2000 v2.0)

Reply #180
In the meantime, how am i supposed to use a VST directly with the foo_midi plugin? I only see the VST path in advanced settings, but no way to select the desired VST synth in the main foo_midi configuration window.
Am I missing something, or did you not read the instructions on the page you linked? Once VSTi path is configured you can pick potential instruments from the Player dropdown menu.

Re: foo_midi (foobar2000 v2.0)

Reply #181
Omg i'm blind, thank you. I haven't visited that site in a long time, and typed it from memory. It's been a long time since i needed to download that synth. It does work as intended now.
Random digital audio nerd girl

Re: foo_midi (foobar2000 v2.0)

Reply #182
Quote
I think you misunderstood me. I don't need the copy of S-YXG50 because i already have it (and it's still available from the webpage of its unofficial maintainer (https://veg.by/en/projects/syxg50/), so i don't understand why you'd need to DM it to me instead of linking the website).

Meowdori,
ooh I didn't know such a website existed or that you already had a copy of the files..
I was just trying to be helpful.I was gifted a copy of the files I need by Kode54 years ago.

Re: foo_midi (foobar2000 v2.0)

Reply #183
Bug report. I noticed that many files with Shift JIS text are no longer displaying properly.  Here are a few examples from my collection. These files first broke with foo_midi 2.8.2.0, likely caused by the copyright sign fix.
@Slender,

I did some investigation. The meta data is still recognized as Shift-JIS. What you see is the output of Windows conversion routine: code page 932 to UTF-8.

However:

- Mixed ANSI and Shift-JIS encoding wasn't detected (anymore?). That has been fixed in the next version.
- Some metadata events were EUC-JP encoded. I added support for that encoding.
- And while at it, I also added Shift-JIS and EUC-JP detection and conversion for lyrics.

Re: foo_midi (foobar2000 v2.0)

Reply #184
There's a problem in Secret Sauce. When i play some midis, they cuts in the beginning, and just sounds pianos, with weak pitch bends, and the map resets to SC-8820 (even if i have the flavor in GS SC-55), most of them sounds fine if i set the flavor in GM, GM2 and XG, but the problem is in GS and Default, however, some of them, aren't fix with any flavor. I leave you one of the midis that Secret Sauce plays wrongly, try it.
Is this a general problem or do you think it was introduced in a particular version?
Is a general problem, it was always there.
I'm absolutely no MIDI expert but isn't that logical? You tell the emulator to follow the GS MIDI standard. It just interprets what is in the file. AFAIK there's nothing in the file that indicates it needs GS.

Re: foo_midi (foobar2000 v2.0)

Reply #185
And i have a question, there will be Nuked SC-55 support in the future, like Super Munt?
Ain't gonna happen because I don't have the ROMs to run the emulator. So I can't test the integration.

Re: foo_midi (foobar2000 v2.0)

Reply #186
There's a problem in Secret Sauce. When i play some midis, they cuts in the beginning, and just sounds pianos, with weak pitch bends, and the map resets to SC-8820 (even if i have the flavor in GS SC-55), most of them sounds fine if i set the flavor in GM, GM2 and XG, but the problem is in GS and Default, however, some of them, aren't fix with any flavor. I leave you one of the midis that Secret Sauce plays wrongly, try it.
Is this a general problem or do you think it was introduced in a particular version?
Is a general problem, it was always there.
I'm absolutely no MIDI expert but isn't that logical? You tell the emulator to follow the GS MIDI standard. It just interprets what is in the file. AFAIK there's nothing in the file that indicates it needs GS.
That's no reason to have that behavior. The midi was made in GM/GS standard (especifically with the MSGS synth), but it doesn't matter if it have or not GS data, even i can put a GS Reset message and still so the synth will reply with that bug. Apparenty, SCVA can't handle midis with much data.

Besides, i already said; In some midis, the synth reply with the same bug in any flavor.


Re: foo_midi (foobar2000 v2.0)

Reply #188
There's a problem in Secret Sauce. When i play some midis, they cuts in the beginning, and just sounds pianos, with weak pitch bends, and the map resets to SC-8820 (even if i have the flavor in GS SC-55), most of them sounds fine if i set the flavor in GM, GM2 and XG, but the problem is in GS and Default, however, some of them, aren't fix with any flavor. I leave you one of the midis that Secret Sauce plays wrongly, try it.
Is this a general problem or do you think it was introduced in a particular version?
Is a general problem, it was always there.
I'm absolutely no MIDI expert but isn't that logical? You tell the emulator to follow the GS MIDI standard. It just interprets what is in the file. AFAIK there's nothing in the file that indicates it needs GS.
That's no reason to have that behavior. The midi was made in GM/GS standard (especifically with the MSGS synth), but it doesn't matter if it have or not GS data, even i can put a GS Reset message and still so the synth will reply with that bug. Apparenty, SCVA can't handle midis with much data.

Besides, i already said; In some midis, the synth reply with the same bug in any flavor.
Anyway, there's nothing I can do about it. All the events are correctly sent to the emulator. I have no impact on what it does with it.

Re: foo_midi (foobar2000 v2.0)

Reply #189
There's a problem in Secret Sauce. When i play some midis, they cuts in the beginning, and just sounds pianos, with weak pitch bends, and the map resets to SC-8820 (even if i have the flavor in GS SC-55), most of them sounds fine if i set the flavor in GM, GM2 and XG, but the problem is in GS and Default, however, some of them, aren't fix with any flavor. I leave you one of the midis that Secret Sauce plays wrongly, try it.
Is this a general problem or do you think it was introduced in a particular version?
Is a general problem, it was always there.
I'm absolutely no MIDI expert but isn't that logical? You tell the emulator to follow the GS MIDI standard. It just interprets what is in the file. AFAIK there's nothing in the file that indicates it needs GS.
That's no reason to have that behavior. The midi was made in GM/GS standard (especifically with the MSGS synth), but it doesn't matter if it have or not GS data, even i can put a GS Reset message and still so the synth will reply with that bug. Apparenty, SCVA can't handle midis with much data.

Besides, i already said; In some midis, the synth reply with the same bug in any flavor.
Anyway, there's nothing I can do about it. All the events are correctly sent to the emulator. I have no impact on what it does with it.
So, the problem is the synth, and not the emulator (Secret Sauce). Anyway, i discovered a way to fix that. Simply by reducing the amount of data... it isn't the definitive solution, but it helps somewhat.

Re: foo_midi (foobar2000 v2.0)

Reply #190
v2.10.0.0, 2024-05-07, It's been a while

* New: The volume of BASS MIDI can be tweaked independently of the overall volume. Defaults to 0.15, determined experimentally to align with the other players.
* Improved: Added detection of EUC-JP encoded meta data.
* Improved: Added Shift-JIS and EUC-JP detection and conversion for lyrics.
* Fixed: Mixed ANSI and Shift-JIS wasn't detected (anymore?).
* Fixed: The BASS MIDI voice count was not initialized correctly when using a preset.
* Fixed: Emu de MIDI sysex recognition.
* Fixed: Emu de MIDI potential buffer overflow during rendering.

Download from GitHub or the foobar2000 Components Repository.
Automatic update from within foobar2000 does not work.

Because it's been a while and the bigger new features will take some work I release this small update.

Re: foo_midi (foobar2000 v2.0)

Reply #191
v2.11.0.0-alpha1, 2024-05-11

* New: Recomposer support (.RCP, .R36, .G18, .G36)
* Fixed: RPG Maker loops should work again.

Only available from GitHub during testing.

This is release contains very early support for Recomposer files. Expect things to go wrong. Also, no options to configure yet.

Re: foo_midi (foobar2000 v2.0)

Reply #192
v2.11.0.0-alpha1, 2024-05-11
foobar2000 v2.1.5/foobar2000 v2.2 preview 2024-05-01 x64

Unable to install. This message is appearing.

> Information
> Failed to load DLL: foo_midi.dll
> Reason: This component is missing a required dependency, or was made for different version of foobar2000.
SHURE SRH1840, SENNHEISER HD660S2, SENNHEISER HD620S, SENNHEISER HD 490 Pro Plus, beyerdynamic DT 1990 PRO, HiFiMAN Edition XS, Bowers & Wilkins P7, FiiO FT5, 水月雨 (MOONDROP) 空鳴 - VOID, Nakamichi Elite FIVE ANC, SONY WH-ULT900N (ULT WEAR) (made a Upgrade/Balanced Cable by myself)

Re: foo_midi (foobar2000 v2.0)

Reply #193
v2.11.0.0-alpha1, 2024-05-11
foobar2000 v2.1.5/foobar2000 v2.2 preview 2024-05-01 x64

Unable to install. This message is appearing.

> Information
> Failed to load DLL: foo_midi.dll
> Reason: This component is missing a required dependency, or was made for different version of foobar2000.
Are you sure you have not mixed up the x86 and x64 version? Both versions work correctly as has been confirmed by other users.

Re: foo_midi (foobar2000 v2.0)

Reply #194
The 64-bit foo_midi.dll is compiled in debug mode. It depends on debug runtime DLLs which non-developers don't have on their machines.

Re: foo_midi (foobar2000 v2.0)

Reply #195
v2.11.0.0-alpha1, 2024-05-11
foobar2000 v2.1.5/foobar2000 v2.2 preview 2024-05-01 x64

Unable to install. This message is appearing.

> Information
> Failed to load DLL: foo_midi.dll
> Reason: This component is missing a required dependency, or was made for different version of foobar2000.
Are you sure you have not mixed up the x86 and x64 version? Both versions work correctly as has been confirmed by other users.

@pqyt

Only this version (v2.11.0.0-alpha1, 2024-05-11).
There is no problem with earlier versions.
Confirmed on 3 PCs.

Thanks.
SHURE SRH1840, SENNHEISER HD660S2, SENNHEISER HD620S, SENNHEISER HD 490 Pro Plus, beyerdynamic DT 1990 PRO, HiFiMAN Edition XS, Bowers & Wilkins P7, FiiO FT5, 水月雨 (MOONDROP) 空鳴 - VOID, Nakamichi Elite FIVE ANC, SONY WH-ULT900N (ULT WEAR) (made a Upgrade/Balanced Cable by myself)

Re: foo_midi (foobar2000 v2.0)

Reply #196
The 64-bit foo_midi.dll is compiled in debug mode. It depends on debug runtime DLLs which non-developers don't have on their machines.
That was absolutely not the intention. Must be caused by lack of sleep... AFAICT alpha2 is a Release build.

Re: foo_midi (foobar2000 v2.0)

Reply #197
Hello, I'm a MIDI lover.

I have a request, but I would like you to implement WRD, which was created a long time ago as a lyrics display system for the PC-9800 series. (Although it was also used for other purposes)
Is it possible to implement MIDI OUT at the same time?
I want to use the nostalgic SC-88Pro.
Is there some documentation about WRD?

MIDI OUT has been requested on GitHub. I am intrigued by the idea but when I started prototyping I ran into a design problem: the Windows API to talk to the MIDI interface requires a different way of receiving the messages. It will require a lot of rework and I don't have the time for that right now.

It was originally a unique lyrics display system for NEC-DOS software called MIMPI, but due to its excellence, it has been implemented in other freeware.
(There are also other extended WRDs such as SherryWRD (extended for Windows) and "演出くんメカ" (extended for MS-DOS))

Since the WRD file itself is a text file, it is probably possible to implement it if it follows the text file specifications.
WRD also requires decompression of reversible image compression used in Japan called MAG.

WRD
https://hp.vector.co.jp/authors/VA011751/WHATSWRD.HTM
http://www6.plala.or.jp/kalkal/crystal/wrd/wrd.htm
http://www6.plala.or.jp/kalkal/crystal/wrd/wrdma.html

MAG
http://metanest.jp/mag/mag.xhtml#spec

I think it may be difficult, but it is part of the history of MIDI, so I would appreciate it if you could implement it.

I had a long look at the format and what little documentation I could find. Implementing the whole spec is beyond the scope of foo_midi. It is not a sequencer. I'll see if I can convert the lyrics to a LYRICS tag but that's as far as I would like to go.

 

Re: foo_midi (foobar2000 v2.0)

Reply #198
v2.11.0.0-alpha7, 2024-05-19

* New: Recomposer support (.RCP, .R36, .G18, .G36) (#37)
* New: Preferences page to configure Recomposer and HMI/HMP settings. (alpha7)
* New: HMI/HMP default tempo can be configured. (#40) (alpha7)
* Improved: Added support for Unicode paths to RCP converter (alpha3)
* Improved: Detection of mixed-encoding text in metadata (alpha5)
* Fixed: RPG Maker loops should work again.
* Fixed: Recomposer files with strange tempo changes crashed the component. (alpha4)
* Fixed: HMI conversion added a second Note On event after every note instead of a Note Off event.(alpha7)
* Fixed: Apply button remained active even if nothing was changed. (#18) (alpha7)

Only available from GitHub during testing.