Skip to main content
Topic: UPnP MediaRenderer output | discussion (Read 133760 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: UPnP MediaRenderer output | discussion

Reply #275

[UPnP] UPnP begin enum devices
[UPnP] UPnP device: JPLAY FEMTO :: http://192.168.219.101:48167/JPLAY192.168.219.101-MediaRenderer/Upnp/device.xml
[UPnP] UPnP device: foobar2000 Renderer (Administrator) [WIN-0ASUB5QOJCE] :: http://192.168.1.100:1090/
[UPnP] UPnP end enum devices

Unrecoverable playback error: proxy_output::proxy_output() => DSD output device is not defined


Please excuse me if I am overly speculative. I was more keen on the red lettered portion. Whenever the music does not play right after the play button click, I am presented with the dialog box (preference: output) where a drop list is present containing all the available output devices (hence the red-lettered log events, which enumerats the output devices). "Unrecoverable ... DSD output device is not defined" is rather a consequence of the cause, which, I think, is that there is no output device available because not one is set (or lost). I hope I am making myself clear.

Re: UPnP MediaRenderer output | discussion

Reply #276
New beta: 1.3 beta 2
https://www.foobar2000.org/temp/foo_out_upnp-1.3b2.fb2k-component
Changes:
With supports-pause=false, new stream URL is generated per cycle, to mitigate apparent bugs with some devices.

This will hopefully fix remaining devices where pausing breaks.

Re: UPnP MediaRenderer output | discussion

Reply #277
Hello,

First of all THANK YOU for this component.

I'm testing your component to stream mainly FLAC files (16–24 bit 44.1–176.4 kHz) to my PerfectWave Network Bridge II on the PerfectWave DAC by PS Audio.

Name: BridgeII
Manufacturer: PS Audio
Model: DirectStream DAC

With version 1.2.1:
Whatever the bit depth of the FLAC files (16 or 24) being played, the playback counter doesn't move and the sound playback stops after few seconds when using these settings:
Output data format: 24-bit or 16-bit
Stream format: Prefer FLAC

Console:
Code: [Select]
Opening track for playback: "S:\DATA\AUDIO\Music\CDRip\Peter BJÄRGÖ\2017 - Animus Retinentia\05 - Where Night Is Eternal.flac"
[UPnP] Device protocol info:
[UPnP] http-get:*:audio/mpeg:DLNA.ORG_PN=MP3,http-get:*:audio/mp4:DLNA.ORG_PN=MP4,http-get:*:audio/vnd.dlna.adts:DLNA.ORG_PN=AAC_ADTS,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMABASE,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMAFULL,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMAPRO,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMALSL,http-get:*:audio/x-sony-oma:DLNA.ORG_PN=ATRAC3plus,http-get:*:audio/aiff:*,http-get:*:audio/wav:*,http-get:*:audio/flac:*,http-get:*:audio/aac:*,http-get:*:audio/m4a:*,http-get:*:audio/ac3:*,http-get:*:audio/x-dsf:*,http-get:*:audio/mp4:*,http-get:*:audio/vnd.dlna.adts:*
[UPnP] Listening on: 192.168.1.10:57391
[UPnP] Stream address: http://192.168.1.10:57027/9/stream.flac
[UPnP] transport op: Play
[UPnP] HTTP request #9: HTTP/1.1 GET /9/stream.flac
[UPnP] HTTP concurrency: 1
[UPnP] Source: 192.168.1.100:51436
[UPnP] Accept: */*
[UPnP] Connection: close
[UPnP] Host: 192.168.1.10:57027
[UPnP] Icy-MetaData: 1
[UPnP] Range: bytes=0-
[UPnP] User-Agent: Lavf/56.25.101
[UPnP] transport op OK, took 0:00.026027
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: STOPPED
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: STOPPED
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: STOPPED

When I change the settings as follows, its plays flawlessly.
Output data format: 32-bit
Stream format: Prefer FLAC (not changed)

However, I notice stream.wav instead of stream.flac in the console, even if the stream format setting is set to FLAC.

Console:
Code: [Select]
Opening track for playback: "S:\DATA\AUDIO\Music\CDRip\Peter BJÄRGÖ\2017 - Animus Retinentia\05 - Where Night Is Eternal.flac"
[UPnP] Device protocol info:
[UPnP] http-get:*:audio/mpeg:DLNA.ORG_PN=MP3,http-get:*:audio/mp4:DLNA.ORG_PN=MP4,http-get:*:audio/vnd.dlna.adts:DLNA.ORG_PN=AAC_ADTS,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMABASE,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMAFULL,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMAPRO,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMALSL,http-get:*:audio/x-sony-oma:DLNA.ORG_PN=ATRAC3plus,http-get:*:audio/aiff:*,http-get:*:audio/wav:*,http-get:*:audio/flac:*,http-get:*:audio/aac:*,http-get:*:audio/m4a:*,http-get:*:audio/ac3:*,http-get:*:audio/x-dsf:*,http-get:*:audio/mp4:*,http-get:*:audio/vnd.dlna.adts:*
[UPnP] Listening on: 192.168.1.10:57607
[UPnP] Stream address: http://192.168.1.10:57027/10/stream.wav
[UPnP] transport op: Play
[UPnP] transport op OK, took 0:00.024333
[UPnP] HTTP request #10: HTTP/1.1 GET /10/stream.wav
[UPnP] HTTP concurrency: 1
[UPnP] Source: 192.168.1.100:51439
[UPnP] Accept: */*
[UPnP] Connection: close
[UPnP] Host: 192.168.1.10:57027
[UPnP] Icy-MetaData: 1
[UPnP] Range: bytes=0-
[UPnP] User-Agent: Lavf/56.25.101
[UPnP] Serving WAV
[UPnP] Accept-Ranges: none
[UPnP] Connection: close
[UPnP] Content-Type: audio/wav
[UPnP] Server: Windows, UPnP/1.0 DLNADOC/1.50, foobar2000/1.x
[UPnP] TransferMode.dlna.org: Streaming
[UPnP] Returned time: 0:00:02
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 0:00:04
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 0:00:06
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 0:00:08
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 0:00:10
[UPnP] Transport state: PLAYING

It plays correctly with these settings as well:
Output data format: any bit depths
Stream format: Prefer WAV (not FLAC nor LPCM)

Using version 1.3 beta 2:
Same issue with default settings:

Console:
Code: [Select]
Opening track for playback: "S:\DATA\AUDIO\Music\CDRip\Kokomo\2016 - Monochrome Noise Love\02 - Kill the Captain, Feed the Fishes.flac"
[UPnP] Device protocol info:
[UPnP] http-get:*:audio/mpeg:DLNA.ORG_PN=MP3,http-get:*:audio/mp4:DLNA.ORG_PN=MP4,http-get:*:audio/vnd.dlna.adts:DLNA.ORG_PN=AAC_ADTS,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMABASE,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMAFULL,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMAPRO,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMALSL,http-get:*:audio/x-sony-oma:DLNA.ORG_PN=ATRAC3plus,http-get:*:audio/aiff:*,http-get:*:audio/wav:*,http-get:*:audio/flac:*,http-get:*:audio/aac:*,http-get:*:audio/m4a:*,http-get:*:audio/ac3:*,http-get:*:audio/x-dsf:*,http-get:*:audio/mp4:*,http-get:*:audio/vnd.dlna.adts:*
[UPnP] Listening on: 192.168.1.10
[UPnP] Stream address: http://192.168.1.10:58618/16/stream.flac
[UPnP] transport op: Play
[UPnP] transport op OK, took 0:00.022713
[UPnP] HTTP request #16: HTTP/1.1 GET /16/stream.flac
[UPnP] HTTP concurrency: 1
[UPnP] Source: 192.168.1.100:37328
[UPnP] Accept: */*
[UPnP] Connection: close
[UPnP] Host: 192.168.1.10:58618
[UPnP] Icy-MetaData: 1
[UPnP] Range: bytes=0-
[UPnP] User-Agent: Lavf/56.25.101
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: STOPPED

And works like a charm when I add these custom settings (using right-click "Copy manufacturer+model"):

Code: [Select]
manufacturer=PS Audio
model=DirectStream DAC
supports-pause=true
supports-FLAC=false

Console:
Code: [Select]
Opening track for playback: "S:\DATA\AUDIO\Music\CDRip\Kokomo\2016 - Monochrome Noise Love\02 - Kill the Captain, Feed the Fishes.flac"
[UPnP] Device protocol info:
[UPnP] http-get:*:audio/mpeg:DLNA.ORG_PN=MP3,http-get:*:audio/mp4:DLNA.ORG_PN=MP4,http-get:*:audio/vnd.dlna.adts:DLNA.ORG_PN=AAC_ADTS,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMABASE,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMAFULL,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMAPRO,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMALSL,http-get:*:audio/x-sony-oma:DLNA.ORG_PN=ATRAC3plus,http-get:*:audio/aiff:*,http-get:*:audio/wav:*,http-get:*:audio/flac:*,http-get:*:audio/aac:*,http-get:*:audio/m4a:*,http-get:*:audio/ac3:*,http-get:*:audio/x-dsf:*,http-get:*:audio/mp4:*,http-get:*:audio/vnd.dlna.adts:*
[UPnP] Listening on: 192.168.1.10
[UPnP] Stream address: http://192.168.1.10:58618/18/stream.wav
[UPnP] transport op: Play
[UPnP] transport op OK, took 0:00.023503
[UPnP] HTTP request #18: HTTP/1.1 GET /18/stream.wav
[UPnP] HTTP concurrency: 1
[UPnP] Source: 192.168.1.100:47342
[UPnP] Accept: */*
[UPnP] Connection: close
[UPnP] Host: 192.168.1.10:58618
[UPnP] Icy-MetaData: 1
[UPnP] Range: bytes=0-
[UPnP] User-Agent: Lavf/56.25.101
[UPnP] Serving WAV
[UPnP] Accept-Ranges: none
[UPnP] Connection: close
[UPnP] Content-Type: audio/wav
[UPnP] Server: UPnP/1.0 DLNADOC/1.50, foobar2000/1.x
[UPnP] TransferMode.dlna.org: Streaming
[UPnP] Returned time: 0:00:02
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 0:00:07
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 0:00:12
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 0:00:17
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 0:00:22
[UPnP] Transport state: PLAYING

Of course, the issue reappears when I change the supports-FLAC setting to true:
Code: [Select]
manufacturer=PS Audio
model=DirectStream DAC
supports-pause=true
supports-FLAC=true

Additional notes:
The PerfectWave Bridge II can handle any sample rate and bit depth from 44.1kHz 16 bit all the way up to 192kHz 32 bit (…) and natively supports the FLAC format.
When I use Synology NAS Audio Station instead of Foobar to stream exactly the same FLAC files to the Bridge II (using UPnP), these files are correctly played as FLAC (not WAV) without transcoding. And the PerfectWave Bridge II displays “FLAC” (or “MP3”, “WAV” according to the file being streamed from Synology's Audio Station).
When I use the UPnP MediaRenderer component in Foobar, the PerfectWave Bridge II always displays "WAV" when straming FLAC files whatever the settings used, even if the Foobar console displays "stream.flac".

Another question: How can I "force" the output data format to 32-bit in version 1.3 beta 2 ?

Thanks in advance for your feedback and advice  ;)

Re: UPnP MediaRenderer output | discussion

Reply #278
New beta: 1.3 beta 2
https://www.foobar2000.org/temp/foo_out_upnp-1.3b2.fb2k-component
Changes:
With supports-pause=false, new stream URL is generated per cycle, to mitigate apparent bugs with some devices.

This will hopefully fix remaining devices where pausing breaks.
Pausing and resuming now seems to be working fine with Teufel Raumfeld. Cheers!

Re: UPnP MediaRenderer output | discussion

Reply #279
I did some more testing and while pausing and resuming is working fine, it turns out that playback stops within 10 seconds with the new betas. The official version works fine for that matter. I've included the log. Note that these lines with Nonsensical timestamp also appear in the official version. I tried it with various settings, but none of them worked.

From the console:
Code: [Select]
Opening track for playback: "sample.flac"
[UPnP] Device protocol info:
[UPnP] http-get:*:audio/iLBC-sh:*,http-get:*:audio/midi:*,http-get:*:audio/mobile-xmf:*,http-get:*:audio/x-xmf:*,http-get:*:audio/mpeg:*,http-get:*:audio/qcelp:*,http-get:*:audio/riff-midi:*,http-get:*:audio/x-ac3:*,http-get:*:audio/x-amr-nb-sh:*,http-get:*:audio/x-amr-wb-sh:*,http-get:*:audio/x-celt:*,http-get:*:audio/x-flac:*,http-get:*:audio/flac:*,http-get:*:audio/x-gsm:*,http-get:*:audio/x-imelody:*,http-get:*:audio/x-m4a:*,http-get:*:audio/mp4:*,http-get:*:audio/x-musepack:*,http-get:*:audio/x-rf64:*,http-get:*:audio/x-speex:*,http-get:*:audio/x-ttafile:*,http-get:*:audio/x-vorbis:*,http-get:*:audio/x-vorbis+ogg:*,http-get:*:audio/x-wav:*,http-get:*:audio/mpeg:*,http-get:*:audio/x-aiff:*,http-get:*:audio/x-ay:*,http-get:*:audio/x-caf:*,http-get:*:audio/x-dts:*,http-get:*:audio/vnd.dts:*,http-get:*:audio/x-gbs:*,http-get:*:audio/x-gym:*,http-get:*:audio/x-ircam:*,http-get:*:audio/x-kss:*,http-get:*:audio/x-mod:*,http-get:*:audio/x-nist:*,http-get:*:audio/x-nsf:*,http-get:*:audio/x-paris:*,http-get:*:audio/x-sap:*,http-get:*:audio/x-sds:*,http-get:*:audio/x-shorten:*,http-get:*:audio/x-spc:*,http-get:*:audio/x-svx:*,http-get:*:audio/x-vgm:*,http-get:*:audio/x-voc:*,http-get:*:audio/x-w64:*,http-get:*:audio/x-wavpack:*,http-get:*:audio/x-wavpack-correction:*,http-get:*:audio/x-xi:*,http-get:*:audio/x-audible:*,http-get:*:audio/x-au:*,http-get:*:audio/x-sbc:*,http-get:*:audio/x-sid:*,http-get:*:audio/x-ms-wma:*
[UPnP] Listening on: 192.168.178.20
[UPnP] Stream address: http://192.168.178.20:63437/19/stream.flac
[UPnP] transport op: Play
[UPnP] transport op OK, took 0:00.020416
[UPnP] HTTP request #45: HTTP/1.1 GET /19/stream.flac
[UPnP] HTTP concurrency: 1
[UPnP] Source: 192.168.178.37:59081
[UPnP] Connection: close
[UPnP] Host: 192.168.178.20:63437
[UPnP] icy-metadata: 1
[UPnP] User-Agent: GStreamer souphttpsrc libsoup/2.56.1
[UPnP] Returned time: 1193:02:47
[UPnP] Nonsensical timestamp - 7wk 0d 17:02:47.000000 while maximum possible is 0:08.881633
[UPnP] Transport state: PLAYING
[UPnP] HTTP request #45 finished
[UPnP] HTTP concurrency: 0
[UPnP] Returned time: 1193:02:47
[UPnP] Nonsensical timestamp - 7wk 0d 17:02:47.000000 while maximum possible is 0:09.900000
[UPnP] Transport state: PLAYING
[UPnP] Returned time: NOT_IMPLEMENTED
[UPnP] time query fail: invalid input
[UPnP] Returned time: NOT_IMPLEMENTED
[UPnP] time query fail: invalid input
[UPnP] Returned time: NOT_IMPLEMENTED
[UPnP] time query fail: invalid input
[UPnP] Returned time: NOT_IMPLEMENTED
[UPnP] time query fail: invalid input

Hope this helpful. Cheers.

 

Re: UPnP MediaRenderer output | discussion

Reply #280
Thanks for the feedback.

Regarding playback stopping after 10 seconds-
As shown in the log, the device does not report playback position so foobar2000 thinks that playback isn't progressing and isn't sending any new data to the device... I'll try to come up with a workaround for this.

Re: UPnP MediaRenderer output | discussion

Reply #281
New beta version:
https://www.foobar2000.org/temp/foo_out_upnp-1.3b3.fb2k-component
Changes:
  • supports-FLAC=false by default - many devices claim to support it, few work right
  • New option: reports-time - use to work around devices which cannot report playback time
  • New device-specific config sections added (reload default settings to apply)

Re: UPnP MediaRenderer output | discussion

Reply #282
1.3b3 no longer stops after a few seconds. Pausing and resuming are still fine.

I did some additional testing and it seems that changing sample rate is disturbing something. See log:

Code: [Select]
Opening track for playback: "x.wv"
[UPnP] Device protocol info:
[UPnP] http-get:*:audio/iLBC-sh:*,http-get:*:audio/midi:*,http-get:*:audio/mobile-xmf:*,http-get:*:audio/x-xmf:*,http-get:*:audio/mpeg:*,http-get:*:audio/qcelp:*,http-get:*:audio/riff-midi:*,http-get:*:audio/x-ac3:*,http-get:*:audio/x-amr-nb-sh:*,http-get:*:audio/x-amr-wb-sh:*,http-get:*:audio/x-celt:*,http-get:*:audio/x-flac:*,http-get:*:audio/flac:*,http-get:*:audio/x-gsm:*,http-get:*:audio/x-imelody:*,http-get:*:audio/x-m4a:*,http-get:*:audio/mp4:*,http-get:*:audio/x-musepack:*,http-get:*:audio/x-rf64:*,http-get:*:audio/x-speex:*,http-get:*:audio/x-ttafile:*,http-get:*:audio/x-vorbis:*,http-get:*:audio/x-vorbis+ogg:*,http-get:*:audio/x-wav:*,http-get:*:audio/mpeg:*,http-get:*:audio/x-aiff:*,http-get:*:audio/x-ay:*,http-get:*:audio/x-caf:*,http-get:*:audio/x-dts:*,http-get:*:audio/vnd.dts:*,http-get:*:audio/x-gbs:*,http-get:*:audio/x-gym:*,http-get:*:audio/x-ircam:*,http-get:*:audio/x-kss:*,http-get:*:audio/x-mod:*,http-get:*:audio/x-nist:*,http-get:*:audio/x-nsf:*,http-get:*:audio/x-paris:*,http-get:*:audio/x-sap:*,http-get:*:audio/x-sds:*,http-get:*:audio/x-shorten:*,http-get:*:audio/x-spc:*,http-get:*:audio/x-svx:*,http-get:*:audio/x-vgm:*,http-get:*:audio/x-voc:*,http-get:*:audio/x-w64:*,http-get:*:audio/x-wavpack:*,http-get:*:audio/x-wavpack-correction:*,http-get:*:audio/x-xi:*,http-get:*:audio/x-audible:*,http-get:*:audio/x-au:*,http-get:*:audio/x-sbc:*,http-get:*:audio/x-sid:*,http-get:*:audio/x-ms-wma:*
[UPnP] Listening on: 192.168.178.20
[UPnP] Stream address: http://192.168.178.20:63124/35/stream.wav
[UPnP] transport op: Play
[UPnP] transport op OK, took 0:00.032939
[UPnP] HTTP request #35: HTTP/1.1 GET /35/stream.wav
[UPnP] HTTP concurrency: 1
[UPnP] Source: 192.168.178.37:57924
[UPnP] Connection: close
[UPnP] Host: 192.168.178.20:63124
[UPnP] icy-metadata: 1
[UPnP] User-Agent: GStreamer souphttpsrc libsoup/2.56.1
[UPnP] Serving WAV
[UPnP] Accept-Ranges: none
[UPnP] Connection: close
[UPnP] Content-Type: audio/wav
[UPnP] Server: UPnP/1.0 DLNADOC/1.50, foobar2000/1.x
[UPnP] TransferMode.dlna.org: Streaming
[UPnP] Transport state: PLAYING
[UPnP] Transport state: PLAYING
[UPnP] Transport state: PLAYING
[UPnP] Transport state: PLAYING
[UPnP] Transport state: PLAYING
Opening track for playback: "y.wv"
[UPnP] HTTP request #35 finished
[UPnP] HTTP concurrency: 0
[UPnP] Device protocol info:
[UPnP] http-get:*:audio/iLBC-sh:*,http-get:*:audio/midi:*,http-get:*:audio/mobile-xmf:*,http-get:*:audio/x-xmf:*,http-get:*:audio/mpeg:*,http-get:*:audio/qcelp:*,http-get:*:audio/riff-midi:*,http-get:*:audio/x-ac3:*,http-get:*:audio/x-amr-nb-sh:*,http-get:*:audio/x-amr-wb-sh:*,http-get:*:audio/x-celt:*,http-get:*:audio/x-flac:*,http-get:*:audio/flac:*,http-get:*:audio/x-gsm:*,http-get:*:audio/x-imelody:*,http-get:*:audio/x-m4a:*,http-get:*:audio/mp4:*,http-get:*:audio/x-musepack:*,http-get:*:audio/x-rf64:*,http-get:*:audio/x-speex:*,http-get:*:audio/x-ttafile:*,http-get:*:audio/x-vorbis:*,http-get:*:audio/x-vorbis+ogg:*,http-get:*:audio/x-wav:*,http-get:*:audio/mpeg:*,http-get:*:audio/x-aiff:*,http-get:*:audio/x-ay:*,http-get:*:audio/x-caf:*,http-get:*:audio/x-dts:*,http-get:*:audio/vnd.dts:*,http-get:*:audio/x-gbs:*,http-get:*:audio/x-gym:*,http-get:*:audio/x-ircam:*,http-get:*:audio/x-kss:*,http-get:*:audio/x-mod:*,http-get:*:audio/x-nist:*,http-get:*:audio/x-nsf:*,http-get:*:audio/x-paris:*,http-get:*:audio/x-sap:*,http-get:*:audio/x-sds:*,http-get:*:audio/x-shorten:*,http-get:*:audio/x-spc:*,http-get:*:audio/x-svx:*,http-get:*:audio/x-vgm:*,http-get:*:audio/x-voc:*,http-get:*:audio/x-w64:*,http-get:*:audio/x-wavpack:*,http-get:*:audio/x-wavpack-correction:*,http-get:*:audio/x-xi:*,http-get:*:audio/x-audible:*,http-get:*:audio/x-au:*,http-get:*:audio/x-sbc:*,http-get:*:audio/x-sid:*,http-get:*:audio/x-ms-wma:*
[UPnP] Listening on: 192.168.178.20
[UPnP] Stream address: http://192.168.178.20:63124/36/stream.wav
[UPnP] transport op: Play
[UPnP] HTTP request #36: HTTP/1.1 GET /36/stream.wav
[UPnP] HTTP concurrency: 1
[UPnP] Source: 192.168.178.37:57936
[UPnP] Connection: close
[UPnP] Host: 192.168.178.20:63124
[UPnP] icy-metadata: 1
[UPnP] User-Agent: GStreamer souphttpsrc libsoup/2.56.1
[UPnP] Serving WAV
[UPnP] Accept-Ranges: none
[UPnP] Connection: close
[UPnP] Content-Type: audio/wav
[UPnP] Server: UPnP/1.0 DLNADOC/1.50, foobar2000/1.x
[UPnP] TransferMode.dlna.org: Streaming
[UPnP] transport op OK, took 0:00.054658
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] HTTP request #36 finished
[UPnP] HTTP concurrency: 0
Opening track for playback: "y.wv"
[UPnP] Device protocol info:
[UPnP] http-get:*:audio/iLBC-sh:*,http-get:*:audio/midi:*,http-get:*:audio/mobile-xmf:*,http-get:*:audio/x-xmf:*,http-get:*:audio/mpeg:*,http-get:*:audio/qcelp:*,http-get:*:audio/riff-midi:*,http-get:*:audio/x-ac3:*,http-get:*:audio/x-amr-nb-sh:*,http-get:*:audio/x-amr-wb-sh:*,http-get:*:audio/x-celt:*,http-get:*:audio/x-flac:*,http-get:*:audio/flac:*,http-get:*:audio/x-gsm:*,http-get:*:audio/x-imelody:*,http-get:*:audio/x-m4a:*,http-get:*:audio/mp4:*,http-get:*:audio/x-musepack:*,http-get:*:audio/x-rf64:*,http-get:*:audio/x-speex:*,http-get:*:audio/x-ttafile:*,http-get:*:audio/x-vorbis:*,http-get:*:audio/x-vorbis+ogg:*,http-get:*:audio/x-wav:*,http-get:*:audio/mpeg:*,http-get:*:audio/x-aiff:*,http-get:*:audio/x-ay:*,http-get:*:audio/x-caf:*,http-get:*:audio/x-dts:*,http-get:*:audio/vnd.dts:*,http-get:*:audio/x-gbs:*,http-get:*:audio/x-gym:*,http-get:*:audio/x-ircam:*,http-get:*:audio/x-kss:*,http-get:*:audio/x-mod:*,http-get:*:audio/x-nist:*,http-get:*:audio/x-nsf:*,http-get:*:audio/x-paris:*,http-get:*:audio/x-sap:*,http-get:*:audio/x-sds:*,http-get:*:audio/x-shorten:*,http-get:*:audio/x-spc:*,http-get:*:audio/x-svx:*,http-get:*:audio/x-vgm:*,http-get:*:audio/x-voc:*,http-get:*:audio/x-w64:*,http-get:*:audio/x-wavpack:*,http-get:*:audio/x-wavpack-correction:*,http-get:*:audio/x-xi:*,http-get:*:audio/x-audible:*,http-get:*:audio/x-au:*,http-get:*:audio/x-sbc:*,http-get:*:audio/x-sid:*,http-get:*:audio/x-ms-wma:*
[UPnP] Listening on: 192.168.178.20
[UPnP] Stream address: http://192.168.178.20:63124/37/stream.wav
[UPnP] transport op: Play
[UPnP] HTTP request #37: HTTP/1.1 GET /37/stream.wav
[UPnP] HTTP concurrency: 1
[UPnP] Source: 192.168.178.37:57944
[UPnP] Connection: close
[UPnP] Host: 192.168.178.20:63124
[UPnP] icy-metadata: 1
[UPnP] User-Agent: GStreamer souphttpsrc libsoup/2.56.1
[UPnP] Serving WAV
[UPnP] Accept-Ranges: none
[UPnP] Connection: close
[UPnP] Content-Type: audio/wav
[UPnP] Server: UPnP/1.0 DLNADOC/1.50, foobar2000/1.x
[UPnP] TransferMode.dlna.org: Streaming
[UPnP] transport op OK, took 0:00.082402
[UPnP] Transport state: PLAYING
[UPnP] Transport state: PLAYING
[UPnP] HTTP request #37 finished
[UPnP] HTTP concurrency: 0

File x.wv is 44.1kHz and file y.wv is 48kHz. (Both files are being down-sampled using the SOX re-sampler plug-in.) At first, playback for x.wv is started. Then after a while y.wv is being started. Then playback hangs with [UPnP] Transport state: TRANSITIONING, but after hitting Play again, it starts. This is not new for the beta. It happens with 1.2.1 too, using the same Raumfeld device.

Cheers.

Re: UPnP MediaRenderer output | discussion

Reply #283
It seems the Teufel Raumfeld actually is capable of returning times. And it doesn't even stop after a couple of seconds.

Code: [Select]
[UPnP] UPnP begin enum devices
[UPnP] UPnP device: Connector Study :: http://192.168.178.37:50537/9a00d7f1-d1a7-473c-a1f7-c81723a1acdd.xml
[UPnP] UPnP device: Study :: http://192.168.178.37:54752/C952CF6B-A40B-426A-A6ED-9D91E223FB4D.xml
[UPnP] UPnP end enum devices
Opening track for playback: "a.flac"
[UPnP] Device protocol info:
[UPnP] dlna-playcontainer:*:application/xml:*,http-get:*:application/ogg:*,http-get:*:application/vnd.ms-asf:*,http-get:*:application/x-mms-framed:*,http-get:*:application/x-ogg:*,http-get:*:application/xspf+xml:*,http-get:*:audio/aac:*,http-get:*:audio/alac:*,http-get:*:audio/flac:*,http-get:*:audio/m4a:*,http-get:*:audio/m4b:*,http-get:*:audio/mp3:*,http-get:*:audio/mp4:*,http-get:*:audio/mpeg3:*,http-get:*:audio/mpeg:*,http-get:*:audio/ogg:*,http-get:*:audio/vorbis:*,http-get:*:audio/wav:*,http-get:*:audio/x-aac:*,http-get:*:audio/x-ac3:*,http-get:*:audio/x-flac:*,http-get:*:audio/x-m4b:*,http-get:*:audio/x-mp3:*,http-get:*:audio/x-mpeg3:*,http-get:*:audio/x-mpeg:*,http-get:*:audio/x-mpegurl:*,http-get:*:audio/x-ms-asf:*,http-get:*:audio/x-ms-wma:*,http-get:*:audio/x-ms-wmv:*,http-get:*:audio/x-ogg:*,http-get:*:audio/x-vorbis+ogg:*,http-get:*:audio/x-wav:*,http-get:*:video/mp4:*,http-get:*:video/x-ms-asf:*
[UPnP] Listening on: 192.168.178.20
[UPnP] Stream address: http://192.168.178.20:50969/18/stream.wav
[UPnP] transport op: Play
[UPnP] HTTP request #19: HTTP/1.1 GET /18/stream.wav
[UPnP] HTTP concurrency: 1
[UPnP] Source: 192.168.178.37:57637
[UPnP] Connection: Keep-Alive
[UPnP] Host: 192.168.178.20:50969
[UPnP] Icy-MetaData: 1
[UPnP] Serving WAV
[UPnP] Accept-Ranges: none
[UPnP] Connection: close
[UPnP] Content-Type: audio/wav
[UPnP] Server: UPnP/1.0 DLNADOC/1.50, foobar2000/1.x
[UPnP] TransferMode.dlna.org: Streaming
[UPnP] transport op OK, took 0:00.051441
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 00:00:06
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 00:00:11
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 00:00:16
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 00:00:21
[UPnP] Transport state: PLAYING
[UPnP] HTTP request #19 finished
[UPnP] HTTP concurrency: 0

Not sure where the inconsistency comes from. With its eco mode, I leave it on all the time.

Re: UPnP MediaRenderer output | discussion

Reply #284
New beta version:
https://www.foobar2000.org/temp/foo_out_upnp-1.3b3.fb2k-component
Changes:
  • supports-FLAC=false by default - many devices claim to support it, few work right
  • New option: reports-time - use to work around devices which cannot report playback time
  • New device-specific config sections added (reload default settings to apply)

I'm trying to use your component hoping to be able to stream my library to a dac with picore player installed, but after 15 sec it stops working. I tried the beta 3 with the "reports-time=true" and "reports-time=false" but I didn't get any results - ([UPnP] Nonsensical timestamp - 0: 16.294000 while maximum possible is 0: 16.067098).

For a long time I have been trying to stream the flac files on the dac but unfortunately I never succeeded... I would love it if you succeeded. thanks a lot
Code: [Select]
Opening track for playback: "\Music\dire straits\Sultan of Swing\Dire Straits - Your Latest Trick [Live].flac"
[UPnP] Device protocol info:
[UPnP] http-get:*:audio/mpeg:*,http-get:*:audio/L16;rate=8000;channels=1:*,http-get:*:audio/L16;rate=8000;channels=2:*,http-get:*:audio/L16;rate=11025;channels=1:*,http-get:*:audio/L16;rate=11025;channels=2:*,http-get:*:audio/L16;rate=12000;channels=1:*,http-get:*:audio/L16;rate=12000;channels=2:*,http-get:*:audio/L16;rate=16000;channels=1:*,http-get:*:audio/L16;rate=16000;channels=2:*,http-get:*:audio/L16;rate=22050;channels=1:*,http-get:*:audio/L16;rate=22050;channels=2:*,http-get:*:audio/L16;rate=24000;channels=1:*,http-get:*:audio/L16;rate=24000;channels=2:*,http-get:*:audio/L16;rate=32000;channels=1:*,http-get:*:audio/L16;rate=32000;channels=2:*,http-get:*:audio/L16;rate=44100;channels=1:*,http-get:*:audio/L16;rate=44100;channels=2:*,http-get:*:audio/L16;rate=48000;channels=1:*,http-get:*:audio/L16;rate=48000;channels=2:*,http-get:*:audio/vnd.dlna.adts:*,http-get:*:audio/vnd.dlna.adts:*,http-get:*:audio/mp4:*,http-get:*:audio/mp4:*,http-get:*:audio/mp4:*,http-get:*:audio/x-ms-wma:*,http-get:*:audio/x-ms-wma:*,http-get:*:audio/x-ms-wma:*,http-get:*:application/ogg:*,http-get:*:audio/x-flac:*
[UPnP] Listening on: 10.249.203.12
[UPnP] Stream address: http://10.249.203.12:65403/1/stream.flac
[UPnP] transport op: Play
[UPnP] transport op OK, took 0:00.016995
[UPnP] HTTP request #1: HTTP/1.0 GET /1/stream.flac
[UPnP] HTTP concurrency: 1
[UPnP] Source: 10.249.203.16:51848
[UPnP] Accept: */*
[UPnP] Cache-Control: no-cache
[UPnP] Connection: close
[UPnP] Host: 10.249.203.12:65403
[UPnP] Icy-Metadata: 1
[UPnP] User-Agent: iTunes/4.7.1 (Linux; N; piCore; armv7l-linux; IT; utf8) SqueezeCenter, Squeezebox Server, Logitech Media Server/7.9.2/1555406898
[UPnP] Returned time: 0:00:00.729
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:01.787
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:02.849
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:03.897
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:04.944
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:05.990
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:07.037
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:08.092
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:09.148
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:10.200
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:11.254
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:12.302
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:13.349
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:14.393
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:15.442
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:16.481
[UPnP] Nonsensical timestamp - 0:16.481000 while maximum possible is 0:16.068209
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:15.815
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:15.806
[UPnP] Transport state: TRANSITIONING
[UPnP] HTTP request #1 finished
[UPnP] HTTP concurrency: 0

Re: UPnP MediaRenderer output | discussion

Reply #285
New beta version:
https://www.foobar2000.org/temp/foo_out_upnp-1.3b3.fb2k-component
Changes:
  • supports-FLAC=false by default - many devices claim to support it, few work right
  • New option: reports-time - use to work around devices which cannot report playback time
  • New device-specific config sections added (reload default settings to apply)

Peter first of all thank you for this plugin.
May i ask you share for me this plugin for XP?
Thank you!

Re: UPnP MediaRenderer output | discussion

Reply #286

What would really be fun and new, is to be able to play music in scync on multiple Upnp players at the same time.

Thanks for the suggestion, maybe I should consider...  ....
Meanwhile, I hope the next version will bring compatibility improvements!

Hi, any developements or workarounds on this idea?

bump!
:)

Re: UPnP MediaRenderer output | discussion

Reply #287
I'm trying to use your component hoping to be able to stream my library to a dac with picore player installed, but after 15 sec it stops working. I tried the beta 3 with the "reports-time=true" and "reports-time=false" but I didn't get any results - ([UPnP] Nonsensical timestamp - 0: 16.294000 while maximum possible is 0: 16.067098).

For a long time I have been trying to stream the flac files on the dac but unfortunately I never succeeded... I would love it if you succeeded. thanks a lot
Please reset the settings to the defaults. Many devices claim to support FLAC but choke when fed an infinite length FLAC stream. Just send LPCM or WAV instead.
Also, what exact device is it?


Re: UPnP MediaRenderer output | discussion

Reply #289
I'm trying to use your component hoping to be able to stream my library to a dac with picore player installed, but after 15 sec it stops working. I tried the beta 3 with the "reports-time=true" and "reports-time=false" but I didn't get any results - ([UPnP] Nonsensical timestamp - 0: 16.294000 while maximum possible is 0: 16.067098).

For a long time I have been trying to stream the flac files on the dac but unfortunately I never succeeded... I would love it if you succeeded. thanks a lot
Please reset the settings to the defaults. Many devices claim to support FLAC but choke when fed an infinite length FLAC stream. Just send LPCM or WAV instead.
Also, what exact device is it?
first of all thanks for the support.

As a dac I use a RASPTOUCH I-SABER ES9038Q2M KALI Streamer on which runs PicorePlayer and Logitech Media Server.

1- I reset all the default settings
2- I tried the beta 4: no benefit.
3- I tried streaming in flac, wav and lpcm: no benefit
4- support-flac = false the reproduction does not start
5- support-flac = true the reproduction starts but it stops after 15 sec.

in any case the playback counter doesn't move and the sound playback stops after few seconds

Re: UPnP MediaRenderer output | discussion

Reply #290
If playback gets stuck, please try with:
reports-time=false

If this helps, please post the configuration lines you've - including manufacturer & model lines for your device; I will add them to the defaults for the next update.

Re: UPnP MediaRenderer output | discussion

Reply #291
If playback gets stuck, please try with:
reports-time=false

If this helps, please post the configuration lines you've - including manufacturer & model lines for your device; I will add them to the defaults for the next update.

I entered in the configuration file
manufacturer=Logitech
model=Squeezebox
reports-time=false

but no changes

i also try with this
zero-length-flac=true (and false)
send-accept-ranges=true (and false)

but anythink

Quote
Opening track for playback: "D:\ardiz\desktop\Ligabue - Start (2019) FLAC\Ligabue - Ancora noi.flac"
[UPnP] Device protocol info:
[UPnP] http-get:*:audio/mpeg:*,http-get:*:audio/L16;rate=8000;channels=1:*,http-get:*:audio/L16;rate=8000;channels=2:*,http-get:*:audio/L16;rate=11025;channels=1:*,http-get:*:audio/L16;rate=11025;channels=2:*,http-get:*:audio/L16;rate=12000;channels=1:*,http-get:*:audio/L16;rate=12000;channels=2:*,http-get:*:audio/L16;rate=16000;channels=1:*,http-get:*:audio/L16;rate=16000;channels=2:*,http-get:*:audio/L16;rate=22050;channels=1:*,http-get:*:audio/L16;rate=22050;channels=2:*,http-get:*:audio/L16;rate=24000;channels=1:*,http-get:*:audio/L16;rate=24000;channels=2:*,http-get:*:audio/L16;rate=32000;channels=1:*,http-get:*:audio/L16;rate=32000;channels=2:*,http-get:*:audio/L16;rate=44100;channels=1:*,http-get:*:audio/L16;rate=44100;channels=2:*,http-get:*:audio/L16;rate=48000;channels=1:*,http-get:*:audio/L16;rate=48000;channels=2:*,http-get:*:audio/vnd.dlna.adts:*,http-get:*:audio/vnd.dlna.adts:*,http-get:*:audio/mp4:*,http-get:*:audio/mp4:*,http-get:*:audio/mp4:*,http-get:*:audio/x-ms-wma:*,http-get:*:audio/x-ms-wma:*,http-get:*:audio/x-ms-wma:*,http-get:*:application/ogg:*,http-get:*:audio/x-flac:*
[UPnP] Listening on: 10.249.203.12
[UPnP] Stream address: http://10.249.203.12:64266/3/stream.flac
[UPnP] transport op: Play
[UPnP] transport op OK, took 0:00.029161
[UPnP] HTTP request #3: HTTP/1.0 GET /3/stream.flac
[UPnP] HTTP concurrency: 1
[UPnP] Source: 10.249.203.16:47420
[UPnP] Accept: */*
[UPnP] Cache-Control: no-cache
[UPnP] Connection: close
[UPnP] Host: 10.249.203.12:64266
[UPnP] Icy-Metadata: 1
[UPnP] User-Agent: iTunes/4.7.1 (Linux; N; piCore; armv7l-linux; IT; utf8) SqueezeCenter, Squeezebox Server, Logitech Media Server/7.9.2/1556111457
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] Transport state: TRANSITIONING
[UPnP] HTTP request #3 finished
[UPnP] HTTP concurrency: 0

Re: UPnP MediaRenderer output | discussion

Reply #292
Please try:

manufacturer=Logitech
model=Squeezebox
preferred-format=LPCM

There are three stream formats (FLAC, WAV and LPCM); one of them is picked depending on your settings and what the device reports.

Also, of your foobar2000 is set to 24-bit output bit depth, please try with 16-bit instead.

Re: UPnP MediaRenderer output | discussion

Reply #293
I have tried all the combinations that you have indicated to me but without any positive result (lpcm, wav, flac and/or 16-24 bit).

Code: [Select]
Opening track for playback: "D:\ardiz\desktop\Ligabue - Start (2019) FLAC\Ligabue - Ancora noi.flac"
[UPnP] Device protocol info:
[UPnP] http-get:*:audio/mpeg:*,http-get:*:audio/L16;rate=8000;channels=1:*,http-get:*:audio/L16;rate=8000;channels=2:*,http-get:*:audio/L16;rate=11025;channels=1:*,http-get:*:audio/L16;rate=11025;channels=2:*,http-get:*:audio/L16;rate=12000;channels=1:*,http-get:*:audio/L16;rate=12000;channels=2:*,http-get:*:audio/L16;rate=16000;channels=1:*,http-get:*:audio/L16;rate=16000;channels=2:*,http-get:*:audio/L16;rate=22050;channels=1:*,http-get:*:audio/L16;rate=22050;channels=2:*,http-get:*:audio/L16;rate=24000;channels=1:*,http-get:*:audio/L16;rate=24000;channels=2:*,http-get:*:audio/L16;rate=32000;channels=1:*,http-get:*:audio/L16;rate=32000;channels=2:*,http-get:*:audio/L16;rate=44100;channels=1:*,http-get:*:audio/L16;rate=44100;channels=2:*,http-get:*:audio/L16;rate=48000;channels=1:*,http-get:*:audio/L16;rate=48000;channels=2:*,http-get:*:audio/vnd.dlna.adts:*,http-get:*:audio/vnd.dlna.adts:*,http-get:*:audio/mp4:*,http-get:*:audio/mp4:*,http-get:*:audio/mp4:*,http-get:*:audio/x-ms-wma:*,http-get:*:audio/x-ms-wma:*,http-get:*:audio/x-ms-wma:*,http-get:*:application/ogg:*,http-get:*:audio/x-flac:*
[UPnP] Listening on: 10.249.203.12
[UPnP] Stream address: http://10.249.203.12:55131/15/stream.flac
[UPnP] HTTP request #14: HTTP/1.0 GET /15/stream.flac
[UPnP] HTTP concurrency: 1
[UPnP] Source: 10.249.203.16:44676
[UPnP] Accept: */*
[UPnP] Cache-Control: no-cache
[UPnP] Connection: close
[UPnP] Host: 10.249.203.12:55131
[UPnP] Icy-Metadata: 1
[UPnP] User-Agent: iTunes/4.7.1 (Linux; N; piCore; armv7l-linux; IT; utf8) SqueezeCenter, Squeezebox Server, Logitech Media Server/7.9.2/1556111457
[UPnP] transport op: Play
[UPnP] transport op OK, took 0:00.021379
[UPnP] Returned time: 00:00:00
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:01.860
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:02.923
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:03.987
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:05.042
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:06.104
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:07.155
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:08.223
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:09.290
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:10.350
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:11.416
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:12.475
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:13.540
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:14.604
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:15.658
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:15.800
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:15.807
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:15.816
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:15.803
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:15.811
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:15.798
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:15.886
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:15.813
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:15.801
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:15.808
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:15.815
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:15.802
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:15.810
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:15.797
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:15.805
[UPnP] Transport state: TRANSITIONING
[UPnP] HTTP request #14 finished
[UPnP] HTTP concurrency: 0

if I understand the messages of the console well it seems that after the 15 seconds foobar no longer understands where it is and in fact the time slider on foobar does not move at all, but if I move it manually the playback continues regularly for 15 seconds then stops.

if i try with this configuration file:
# defaults that apply to every device
stream-title=foobar2000 audio stream
# default preferred format, can be overridden per-device; available are: FLAC, WAV, LPCM
preferred-format=lpcm
# Various devices fail to pause on what they assume to be a live stream, require a stop command
# Can be overridden to true for specific devices
supports-pause=false
# Default to FLAC not supported even if the device claims otherwise
# Many report that they support FLAC yet fail to play an infinite length FLAC stream
supports-FLAC=false


Code: [Select]
Opening track for playback: "D:\ardiz\desktop\Ligabue - Start (2019) FLAC\Ligabue - Ancora noi.flac"
[UPnP] Device protocol info:
[UPnP] http-get:*:audio/mpeg:*,http-get:*:audio/L16;rate=8000;channels=1:*,http-get:*:audio/L16;rate=8000;channels=2:*,http-get:*:audio/L16;rate=11025;channels=1:*,http-get:*:audio/L16;rate=11025;channels=2:*,http-get:*:audio/L16;rate=12000;channels=1:*,http-get:*:audio/L16;rate=12000;channels=2:*,http-get:*:audio/L16;rate=16000;channels=1:*,http-get:*:audio/L16;rate=16000;channels=2:*,http-get:*:audio/L16;rate=22050;channels=1:*,http-get:*:audio/L16;rate=22050;channels=2:*,http-get:*:audio/L16;rate=24000;channels=1:*,http-get:*:audio/L16;rate=24000;channels=2:*,http-get:*:audio/L16;rate=32000;channels=1:*,http-get:*:audio/L16;rate=32000;channels=2:*,http-get:*:audio/L16;rate=44100;channels=1:*,http-get:*:audio/L16;rate=44100;channels=2:*,http-get:*:audio/L16;rate=48000;channels=1:*,http-get:*:audio/L16;rate=48000;channels=2:*,http-get:*:audio/vnd.dlna.adts:*,http-get:*:audio/vnd.dlna.adts:*,http-get:*:audio/mp4:*,http-get:*:audio/mp4:*,http-get:*:audio/mp4:*,http-get:*:audio/x-ms-wma:*,http-get:*:audio/x-ms-wma:*,http-get:*:audio/x-ms-wma:*,http-get:*:application/ogg:*,http-get:*:audio/x-flac:*
[UPnP] Listening on: 10.249.203.12
[UPnP] Stream address: http://10.249.203.12:55131/44/stream.l16
[UPnP] transport op: Play
[UPnP] transport op OK, took 0:00.018916
[UPnP] Returned time: 00:00:00
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 00:00:00
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 00:00:00
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 00:00:00
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 00:00:00
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 00:00:00
[UPnP] Transport state: TRANSITIONING

and nothing start.

thanks a lot for your help

Re: UPnP MediaRenderer output | discussion

Reply #294
The state remains "TRANSITIONING", so the device is stuck doing something and doesn't even report beginning to play. Perhaps it expects to be able to download the entire file before beginning to play - in that case it can't be helped.

Re: UPnP MediaRenderer output | discussion

Reply #295
You could try maxing out foobar2000's output buffer setting to see if it helps, will at least cause more audio data to be sent to the device despite of no apparent playback progress.

Re: UPnP MediaRenderer output | discussion

Reply #296
1.3 beta 5-
https://www.foobar2000.org/temp/foo_out_upnp-1.3b5.fb2k-component

Changes
  • New default settings for Sonos.
  • Improved error handling, some internal errors were not reported to the user, for an example when no compatible format could be determined.
  • New settings: force-format, bitdepth, bitdepth-max, dither.

Re: UPnP MediaRenderer output | discussion

Reply #297
hi peter,
I tried the latest version of your plug-in with this configuration:
buffer maximized
24 bit depth output format
preferred-format=FLAC
supports-pause=true
supports-FLAC=true

everithing works for 45 seconds then
Code: [Select]
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:43.649
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:44.696
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:44.793
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:44.797
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:44.806
[UPnP] Transport state: TRANSITIONING
[UPnP] HTTP request #4 finished
[UPnP] HTTP concurrency: 0


and time slider of foobar does not move.
I really hope you can find a solution to the problem

Re: UPnP MediaRenderer output | discussion

Reply #298
1.3 beta 5-
https://www.foobar2000.org/temp/foo_out_upnp-1.3b5.fb2k-component

Changes
  • New default settings for Sonos.
  • Improved error handling, some internal errors were not reported to the user, for an example when no compatible format could be determined.
  • New settings: force-format, bitdepth, bitdepth-max, dither.

since I had guessed that on the foobar2000 side there was not much else to try, I went to check all the settings of the DAC that is based on the Logitech Media Server, and in fact I found that the DLNA server settings were not active : it was enough to activate the DLNA functions to make the streaming work correctly. It works the play, pauses advancement of the song etc etc ... increase and decrease of the volume ...

The 192/24 files are also correctly recognized by the DAC.
The only settings I've activated are

preferred-format = FLAC
supports-pause = true
supports-FLAC = true

thank you very much Peter for your support.
if I can help you, tell me

Re: UPnP MediaRenderer output | discussion

Reply #299
Thanks for getting back to me and confirming that Squeezebox works correctly. I'll merge your settings with the defaults for the next update.

 
SimplePortal 1.0.0 RC1 © 2008-2019