Skip to main content
Topic: about foo_dsp crossfader (Read 8079 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

about foo_dsp crossfader

Reply #25
Current version of foo_dsp_nogaps (0.1.3) crashes on track change onto a track with silence at the beginning here (foobar 0.62a). One of these files has 6 seconds of silence at beginning.
.

about foo_dsp crossfader

Reply #26
Quote
Current version of foo_dsp_nogaps (0.1.3) crashes on track change onto a track with silence at the beginning here (foobar 0.62a). One of these files has 6 seconds of silence at beginning.

I hope 0.1.4 fixes it.

about foo_dsp crossfader

Reply #27
Quote
Quote
Current version of foo_dsp_nogaps (0.1.3) crashes on track change onto a track with silence at the beginning here (foobar 0.62a). One of these files has 6 seconds of silence at beginning.

I hope 0.1.4 fixes it.

Yes, no crashes, but its not skipping the gap anymore

I left the console open with 0.1.3, it would skip some of the samples and then crash. 0.1.4 doesn't skip anything, I tried increasing the threshold too but with no luck.

I also went back to 0.1.3 to confirm the gap is skipped with it, I noticed the DSP latency goes to -15 when it crashes..

edit: from what I can tell its no longer removing samples at the beginning of the track.
.

about foo_dsp crossfader

Reply #28
I didn't change anything in silence detection code for .14, only made it obey the maximum gap length setting. Also console now reports only once the total number of samples skipped at the beginning of track, not the skips of individual chunks.
If changing gap length setting doesn't help, could you e-mail me two tracks that should be gapless but don't work properly anymore? Use address cse at sci dot fi.

about foo_dsp crossfader

Reply #29
I really can't email because Im on 56k.

It only seems to be skipping samples at the end of the track now.. I don't know why, but I've tried increasing the max legth to 10s and the threshold to -10db.

Actually, I've found out some otherthing, its not working with some rogue OGGs Ive got. They are mono and pretty low quality. I know its not working with them because the DSP latency stays at 9ms instead of ~10000ms.

I fixed this by putting a mono>stereo dsp in the chain (I dont know if this was needed in previous versions), but it still doesn't seem to be skipping gaps at the beginning of tracks (whilst it did in previous versions)..

edit: Though I kept the same settings as 0.1.3, it seems I got the scale backwards (should have paid more attention to the options). Though it doesnt report skipping anything at the beginning of that particular track for some reason (I think maybe because it has more silence than 10 secs when combined with last track), but it is actually skipping now so im not bothered..

Thanks for the help, Case..
.

about foo_dsp crossfader

Reply #30
Thank you
Chinese Kongfu

about foo_dsp crossfader

Reply #31
now crossfader work with diskwriter !
use "not reset dsp between files"
thank you Case and Peter!
Music is my first love.

about foo_dsp crossfader

Reply #32
when play cd , crossfader enamble, i ear "tick tick tick..."
tested with directsound, wave out, limit cd reading speed on & off, full file buffering 0 & 10000 Kb.

foobar 0.667
crossfader 27/06/2003
Music is my first love.

 
SimplePortal 1.0.0 RC1 © 2008-2019