Skip to main content
Topic: about foo_dsp crossfader (Read 8080 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

about foo_dsp crossfader

1)  THANK YOU  CASE for your component! now foobar is the best player and the most completed.

2) I found  a small problem, seeking is very slow,  not very obvious at 2 seconds but very obvious at 5 seconds of fade duration.
Music is my first love.

about foo_dsp crossfader

Reply #1
Quote
1)  THANK YOU  CASE for your component! now foobar is the best player and the most completed.

You're welcome

Quote
2) I found  a small problem, seeking is very slow,  not very obvious at 2 seconds but very obvious at 5 seconds of fade duration.

Fixed in 0.0.4 with smarter buffering.

about foo_dsp crossfader

Reply #2
wonderful !!!
 


question:
believe you to add "remove silences at the beginning / end of the tracks"?

if this does not change the definition "simple crossfader"...
Music is my first love.

about foo_dsp crossfader

Reply #3
See "gap remover" DSP.

about foo_dsp crossfader

Reply #4
Thank you, Case!!  I listen to a lot of mp3'd concerts, and your gap/crossfade dsp's have made it a joy again. Just super.
That's so plausible, I can't believe it.

about foo_dsp crossfader

Reply #5
crossfader not work at fade duration more than 6 seconds

and not work with diskwriter at all durations

0.04 version

Music is my first love.

about foo_dsp crossfader

Reply #6
Quote
crossfader not work at fade duration more than 6 seconds

That depends on source file length, when file is at least twice the size of fade buffer it will work.

Quote
and not work with diskwriter at all durations

This is fixed in 0.0.5.

about foo_dsp crossfader

Reply #7
now I understands!
I am the idiot of the day. 

even if I am likely to be the idiot of the month, with diskwriter it does not work yet.
I am explained: that it with or without crossfader the files wav make by diskwriter are the same. crossfader is not apply. (use dsp is checked and crossfader is in dsp windows)
perhaps I expect a behavior not planned, that can hear  transition in the wav files, for then burn one mix-Cd

Music is my first love.

about foo_dsp crossfader

Reply #8
Oh, sorry. I hadn't actually tested diskwriting behavior so I wasn't aware of this limitation. This is a problem with the way foobar handles this task and I can't fix it without ugly hacks which I do not want to add.

Edit: I have asked Peter to add option for diskwriter to not flush DSPs between files which would make it work. He didn't seem interested but we'll see...

about foo_dsp crossfader

Reply #9
Thank you CASE for your answer, now all is clear.
I agree , not ugly hacks.
We'll see, one of these days can be Peter will has a little time for add option for diskwriter "not flush DSPs between files".
it is not urgent nor essential, but that would be quite useful.

thank you CASE for yours components, thank you PETER for foobar and thank you at all people who take part in the development of this fantastic software.


Music is my first love.

about foo_dsp crossfader

Reply #10
wow, thanks for this, crossfade and gapkilling was the one thing stopping me moving from winamp fulltime, a couple of questions though.

i presume the gapkiller works alongside the output buffer length, if thats so is there a way for you to control the speed the buffer fills on track change at the moment foobar tries to do it asap and causes a judding cpu spike

is the gap killer just looking for digital silence or a sound level above which it presumes silence?

with the crossfader can you also do winamp style stop/start/pause/seek fades?

either way thanks for the cool work on this plugin

-J
"...ambience?, I AM ambience!"

about foo_dsp crossfader

Reply #11
Quote
i presume the gapkiller works alongside the output buffer length

It has no way to determine output buffer size and it uses its own fixed 2 seconds buffer. I will add configuration for this at some later point.

Quote
if thats so is there a way for you to control the speed the buffer fills on track change at the moment foobar tries to do it asap and causes a judding cpu spike

It seems I need to add similar slow buffering as I introduced for crossfader.

Quote
is the gap killer just looking for digital silence or a sound level above which it presumes silence?

It is mainly meant for non-gapless formats such as MP3 and AAC so removing only digital silence wouldn't work. Right now it decides start of silence by searching for dramatic changes in the amplitude of the signal, it works quite well but I'll try to come up with some better method for next version.

Quote
with the crossfader can you also do winamp style stop/start/pause/seek fades?

These must be done in output component.

about foo_dsp crossfader

Reply #12
thanks Case that all sounds cool, i'll look forward to your updates

-J
"...ambience?, I AM ambience!"

about foo_dsp crossfader

Reply #13
Quote
It is mainly meant for non-gapless formats such as MP3 and AAC so removing only digital silence wouldn't work. Right now it decides start of silence by searching for dramatic changes in the amplitude of the signal, it works quite well but I'll try to come up with some better method for next version.

So you can use a method Peter's Winamp DSound plugin (and nearly everybody else) uses:
searching for given volume - of course that would require at least some configuration.

Anyway, crossfader adds a skip and eats 100% CPU for about 1,5 at the last song in the playlist if repeat is off
(at around [song time]-[fade size])
ruxvilti'a

about foo_dsp crossfader

Reply #14
Quote
So you can use a method Peter's Winamp DSound plugin (and nearly everybody else) uses:
searching for given volume - of course that would require at least some configuration.

That method requires different configuration for all files with different loudness, I don't quite like it. Perfect algorithm would be something that didn't require configuration at all. I know current method makes lots of mistakes but I will improve it when I have more time to spend investigating my mp3s... If I can't get my own system working satisfyingly I will have to resort to that simple signal level checking.

Quote
Anyway, crossfader adds a skip and eats 100% CPU for about 1,5 at the last song in the playlist if repeat is off
(at around [song time]-[fade size])

What settings are you using? I don't seem to be able to reproduce this, foobar CPU usage stays at zero to the very end of playback.

about foo_dsp crossfader

Reply #15
I mentioned similar results in the 3rd party plugins thread.  With my 1.4GHz Athlon I see cpu usage spike as it starts preloading the next track, and it is so bad that I get a silent portion in playback.  If I remove the advanced limiter, EQ (Garf's release), and resampler (32bit slow mode) so that nothing is in the DSP chain except the crossfader it seems to work fine.

about foo_dsp crossfader

Reply #16
Quote
I mentioned similar results in the 3rd party plugins thread.  With my 1.4GHz Athlon I see cpu usage spike as it starts preloading the next track, and it is so bad that I get a silent portion in playback.  If I remove the advanced limiter, EQ (Garf's release), and resampler (32bit slow mode) so that nothing is in the DSP chain except the crossfader it seems to work fine.

Hi, could you activate all of those DSPs with the settings you normally use, EXCEPT for crossfader, set disk writer to Speed Meter (requires foo_null) and run conversion on one or more of the files you state to be skipping? Two to three runs per file should be fine, you'll find the results in the console.

about foo_dsp crossfader

Reply #17
Quote
QUOTE 
with the crossfader can you also do winamp style stop/start/pause/seek fades?


These must be done in output component.


Can't you just fade to silence ? I don't now how it works I think it should be possible to do it that way  :-/

about foo_dsp crossfader

Reply #18
Quote
What settings are you using? I don't seem to be able to reproduce this, foobar CPU usage stays at zero to the very end of playback.

Foobar2000 version 0.62a and 0.666b2
Crossfader 0.0.5
Playing MP3 file of duration 3:12 - skip at 2:51 - 100% CPU usage
Output buffer ~500ms (OpenAL, 16 buffers)

DSP configuration:
Crossfader (10 s)
Advanced Limiter
Resampler (slow, 64bit)
Convert mono to stereo

Happens regardless of output.

CPU usage is twice higher if I put the fader after the resampler. (normally ~17%, jumps up to ~35%)
There's obvoiusly some interaction between these two plugins.

Additionally, FB2k consumes much ram with Crossfader in plugin chain. Always.
I think the buffer should be allocated and used only when needed (at the end/beggining).
ruxvilti'a

about foo_dsp crossfader

Reply #19
Tip for sanity, safety with files of multiple sample rates, and also a temporary solution to your problem: Place crossfader after resampler. Hell, it's even safe to place crossfader at the end of the chain, since it won't be making anything louder than it already is.

about foo_dsp crossfader

Reply #20
Quote
Quote
What settings are you using? I don't seem to be able to reproduce this, foobar CPU usage stays at zero to the very end of playback.

Foobar2000 version 0.62a and 0.666b2
Crossfader 0.0.5
Playing MP3 file of duration 3:12 - skip at 2:51 - 100% CPU usage
Output buffer ~500ms (OpenAL, 16 buffers)

DSP configuration:
Crossfader (10 s)
Advanced Limiter
Resampler (slow, 64bit)
Convert mono to stereo

Happens regardless of output.

CPU usage is twice higher if I put the fader after the resampler. (normally ~17%, jumps up to ~35%)
There's obvoiusly some interaction between these two plugins.

Additionally, FB2k consumes much ram with Crossfader in plugin chain. Always.
I think the buffer should be allocated and used only when needed (at the end/beggining).

With your config I managed to reproduce it, the reason for slowdowns is that crossfader passes 20 seconds long audio chunk over to DSP chain and SSRC needs too much time to process it. As kode54 already suggested, you really should place crossfader last in chain.

Quote
CPU usage is twice higher if I put the fader after the resampler. (normally ~17%, jumps up to ~35%)
There's obvoiusly some interaction between these two plugins.

CPU usage is high only temporarily, it will get down to normal numbers quickly after buffer is filled.

Quote
Additionally, FB2k consumes much ram with Crossfader in plugin chain. Always.
I think the buffer should be allocated and used only when needed (at the end/beggining).

I would do this if it was possible but there's no way to know where track ends before hand. That's why DSP needs to keep  enough data in buffer all the time to be able to react when core signals that track has ended.

about foo_dsp crossfader

Reply #21
Quote
Hi, could you activate all of those DSPs with the settings you normally use, EXCEPT for crossfader, set disk writer to Speed Meter (requires foo_null) and run conversion on one or more of the files you state to be skipping? Two to three runs per file should be fine, you'll find the results in the console.

INFO (foo_null) : decoding took 5788 milliseconds, speed 66.94x

and I'd say file's irrelevant, does it with every mp3 it seems.

<edit> oh, and I'm using a 10 second crossfade buffer

about foo_dsp crossfader

Reply #22
Oops. Could you repeat that test, and make sure disk writer is set to use both DSP and ReplayGain?

about foo_dsp crossfader

Reply #23
whoops, yeah, DSP was off. INFO (foo_null) : decoding took 76951 milliseconds, speed 5.3x

about foo_dsp crossfader

Reply #24
Thanks Kode, I figured it out myself, but thanks anyway for thorough explanation of the problem.

What about an option to select logarithmic, linear fades or maybe even fading curve?
ruxvilti'a

 
SimplePortal 1.0.0 RC1 © 2008-2019