Skip to main content
Topic: Playback Statistics Disappearing - Please Help! (Read 3269 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Playback Statistics Disappearing - Please Help!

Please help - my Playback Statistics are constantly disappearing.  I am using Playback Statistics 3.0.2 and I am positive the Play Count has incremented when the track is played, but then later the count will no longer show.  I tried to use the Playback Statistics context menu to import statistics from file tags, but it had no effect.  When I play the track again, the Play Count shows 1, but I know the track has played before.  Am I doing something wrong?  It is incredibly frustrating to have the play counts reset all the time - I know I have not Reset Statistics from the context menu because it seems to happen on completely random tracks - sometimes whole albums, but sometimes only a few tracks.  Any assistance would be greatly appreciated!

Thanks!

Playback Statistics Disappearing - Please Help!

Reply #1
Are you sure that the tracks was played at least one minute? Did you see that playcout also was increased after playing?

Playback Statistics Disappearing - Please Help!

Reply #2
[quote author=q-stankovic link=msg=795385 date=1336936092]Are you sure that the tracks was played at least one minute? Did you see that playcout also was increased after playing?[/quote]
Absolutely.  The play count had incremented to 1 already and then at some point later reverted to blank.  I added the First Played statistic (which is not something I normally have) to my Playlist View as well to see if the same thing was happening and sure enough - there were no values on those tracks where the Play Count disappeared.

Playback Statistics Disappearing - Please Help!

Reply #3
Are you sure that these tracks are in foobar2000 media library?

"A record gets removed when no matching track has been seen by foobar2000 (in Media Library or in any playlist or in an imported XML backup of playback statistics) for four weeks." - wiki

Playback Statistics Disappearing - Please Help!

Reply #4
Are you sure that these tracks are in foobar2000 media library?

"A record gets removed when no matching track has been seen by foobar2000 (in Media Library or in any playlist or in an imported XML backup of playback statistics) for four weeks." - wiki


Ah, I think this sounds like it could be the problem (four weeks sounds very likely as to when this is occurring).  I generally just add music to the directory on my computer where I store music and I have foobar monitoring this folder so the albums/tracks are automatically picked up.  Do I need to be doing something else to ensure that these are actually in the Media Library?

Playback Statistics Disappearing - Please Help!

Reply #5
If the folders are monitored by defining them in preferences -> media library ->music folders so they are in library.

Playback Statistics Disappearing - Please Help!

Reply #6
Try to find them via (menu) Library -> Search.

Playback Statistics Disappearing - Please Help!

Reply #7
[quote author=q-stankovic link=msg=795398 date=1336940525]If the folders are monitored by defining them in preferences -> media library ->music folders so they are in library.[/quote]

Yes, that is where my single music folder is defined for monitoring, but the play counts are still being removed.

lvqcl mentions that this occurs "when no matching track has been seen by foobar2000."  Can a track be in the Media Library, but not be seen by foobar?  This doesn't seem like it could be the case, but then again, the tracks are still appearing in my Playlist View, but the Play Counts are not there...

Thanks for all the suggestions/help thus far.

Playback Statistics Disappearing - Please Help!

Reply #8
Can a track be in the Media Library, but not be seen by foobar?
That is only the case if that track is hidden in Windows Explorer. But since the track exists in your playlist that could not be the reason for removal of playcount. Nevertheless, check if the concerned files are hidden. Did you add them to playlist view by explorer and have removed them before that from playlist?

Playback Statistics Disappearing - Please Help!

Reply #9
[quote author=q-stankovic link=msg=795403 date=1336941342]
Can a track be in the Media Library, but not be seen by foobar?
That is only the case if that track is hidden in Windows Explorer. But since the track exists in your playlist that could not be the reason for removal of playcount. Nevertheless, check if the concerned files are hidden. Did you add them to playlist view by explorer and have removed them before that from playlist?
[/quote]

I thought that was probably the case.  Unfortunately, that still leaves me with Play Counts that are disappearing for an unknown reason.

One thing I did notice regarding the possibility that this was happening after four weeks is that some tracks have retained their Play Counts even if they were played last much longer than four weeks ago while some tracks that were very recently added and played now have missing Play Counts.  It seems to be completely random (though I am sure there is some underlying commonality with them resulting in the reset if the Playback Stats).



Playback Statistics Disappearing - Please Help!

Reply #10
One thing I did notice regarding the possibility that this was happening after four weeks is that some tracks have retained their Play Counts even if they were played last much longer than four weeks ago while some tracks that were very recently added and played now have missing Play Counts.  It seems to be completely random (though I am sure there is some underlying commonality with them resulting in the reset if the Playback Stats).



I've noticed something similar - once in a while some tracks loose their playback stats (added/playcount) and appear in my "not played yet playlist" but everything gets back to normal after playback -- all the information is in the file tags also therefore simple "import information from file tags" also works. However it's a bit annoying and at first made me a bit worried that I've lost the stats...

Playback Statistics Disappearing - Please Help!

Reply #11
Unfortunately, in my case, the Import Statistics From File Tags is not working - the statistics appear to be resetting without prompting.

As this is still unresolved, I would greatly appreciate help anyone can give me.

Thanks!

Playback Statistics Disappearing - Please Help!

Reply #12
Do you have tag synchronization turned on? It's off by default but I explicityly enabled it therefore getting statistics back from tags work for me.

Playback Statistics Disappearing - Please Help!

Reply #13
Do you have tag synchronization turned on? It's off by default but I explicityly enabled it therefore getting statistics back from tags work for me.


n00b question - where do I turn the tag synchronization on?

Playback Statistics Disappearing - Please Help!

Reply #14
Preferences -> Advanced -> Tools -> Playback statistics -> Automatically synchronize file tags...

Playback Statistics Disappearing - Please Help!

Reply #15
Preferences -> Advanced -> Tools -> Playback statistics -> Automatically synchronize file tags...


Thanks wojtek.  Do you know why the option says "disrecommended"?  What is the risk?

Playback Statistics Disappearing - Please Help!

Reply #16
you are having foobar2000 write to a file while it is playing. Dependent on cpu load you may hear a glitch. Most likely not an issue.

Playback Statistics Disappearing - Please Help!

Reply #17
I would say another thing is that if there are multiple user accounts with separate playback statistics then those would overlap between users.

Playback Statistics Disappearing - Please Help!

Reply #18
Same thing keeps happening to me. I keep losing random playback statistic info. Just now I was playing an album and noticed that my playcount was being reset to zero. Thankfully I had tag synchronization on or else the info would have been lost. I think i'll go back to playback_statistics_custom for now until this issue is solved.

Playback Statistics Disappearing - Please Help!

Reply #19
This happens to me with two tracks very often (RISE and INNER UNIVERSE from Origa..funny enough) and a few others a lot more rarely...but they're all FLACs. It only happens with FLACs. having synchronization on didnt fix the issue either. I hope someone can figure out the cause of this...it's been happening for years. Also, I dont mean to thread hijack but is there a way to manually change the file tags? I use last.fm so I still know how many plays, first played. last played, ect ect for the files. I used search and found no concrete answers so if someone could PM me with help to do this I would appreciate it. I tried just modifiyng the numbers in the field but all that did was change the numbers on the Metadata page but not on the Properties page

Playback Statistics Disappearing - Please Help!

Reply #20
So apparently some other files have just done this to me. I'm not sure why, everything is set properly according to other posts I've found on these forums. This time it was two entire folders (about 10 songs luckily).  This time they were all mp3s so I guess what I said about them being only FLACs has been destroyed. Everything I have is up-to-date including the version of foobar (latest stable). And again, manually modifying the "play_count" isnt doing anything.

edit: Just found another file that lost it's data. its the only file in it's folder (of about 30 songs) that lost its playback data. the weird part is instead of losing play_count,last played, and rating like the others have, this one only lost its play_count and last played. it kept it's rating. this is just baffling. there is nothing that these files have in common anymore except that they are songs

 
SimplePortal 1.0.0 RC1 © 2008-2019