Skip to main content
Topic: %album artist%: fb2k puts both VA+artist, so does’t recognise VA album (Read 1219 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

%album artist%: fb2k puts both VA+artist, so does’t recognise VA album

Morning all.
Just updated v0.9.6.1 to v1.1.11. I have managed to replicate most of my previous settings but I am getting a discrepancy with reading of album artist tags, even on the same files. The new version is putting both 'Various Artists' and the artist name in the VA field and won't recognise a VA album as one album because of this. Screenshots to demonstrate:

Old foobar:
http://www.freeimagehosting.net/flfy6
New foobar:
http://www.freeimagehosting.net/jzbt4
(couldn't find a proper image host that works at work, sorry)

Can someone please help me fix the config of the new version to be the same as the old? I'm sure it's something simple I'm missing.
Many thanks in advance
Sync

%album artist%: fb2k puts both VA+artist, so does’t recognise VA album

Reply #1
The ID3v2 frame token TPE2 was once read as "BAND", and "BAND" was written back as TPE2. "Album Artist" was originally written to TXXX with the description of "Album Artist".

The current default reads and writes both as "Album Artist". The solution is to remove one of the values of Album Artist. You may locate files with this problem easily by searching for "$meta_num(album artist)" IS 2. Mass fixing them may be as easy as using format from other fields, with a script of $meta(album artist,0) or ,1, depending on which value you want to keep. It doesn't matter which one you keep, as long as the entire album has the same value for all tracks.

Of course, you may also find the setting to reverse that change in Advanced Preferences, but remember that this change is in line with other players which support reading and writing the TPE2 frame token.

%album artist%: fb2k puts both VA+artist, so does’t recognise VA album

Reply #2
Thanks for the reply.

Quote
The current default reads and writes both as "Album Artist".


Then how do I change this back to how it was? Foobar's behaviour is the same whether the 'map TPE2 to Album Artist' option is checked in Advanced -> Tagging or not.
I don't want to change the tags on the files at all, having set them up to be perfect (for my purposes) on v0.9.6.1, as that would involve resyncing many files across many devices and potentially having new problems on other platforms. It's not really an option unless as a last resort.

%album artist%: fb2k puts both VA+artist, so does’t recognise VA album

Reply #3
Uncheck the option and reload tags from files (Tagging -> Reload info ...)

%album artist%: fb2k puts both VA+artist, so does’t recognise VA album

Reply #4
Uncheck the option and reload tags from files (Tagging -> Reload info ...)


That does it. Wondered how I could force a reload after changing the option (had to enable it in context menu).
Many thanks guys, will fix tags in long term but for now this does it. Cheers.

 
SimplePortal 1.0.0 RC1 © 2008-2019