Skip to main content
Topic: Starting DTS-CD/track manually cuts first 1sec (playing to next is OK) (Read 2093 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Starting DTS-CD/track manually cuts first 1sec (playing to next is OK)

I have recently downloaded Foobar2000 1.1.11.  It has been the only thing I have been able to find that plays DTS CDs out of the box which is great.  One issue is that when you start the CD or start a track manually it cuts off the first .5 to one full second of the track.  I've messed with the buffers, doesn't seem to matter. However when the CD continues playing additional tracks one after the next I don't hear the cutoff. Any help is welcome.  TIA

Starting DTS-CD/track manually cuts first 1sec (playing to next is OK)

Reply #1
Are you using a digital output to a amp?

and you give us a little more info about your setup?
Who are you and how did you get in here ?
I'm a locksmith, I'm a locksmith.

Starting DTS-CD/track manually cuts first 1sec (playing to next is OK)

Reply #2
Are you using a digital output to a amp?

and you give us a little more info about your setup?

Typical Spdif out on the PC to a typical dts Receiver

Starting DTS-CD/track manually cuts first 1sec (playing to next is OK)

Reply #3
It might be your amp taking a little time to sync the digital signal.

When i used to use a digital cable i had the same problem which turned out being my soundcards sample rate being set to 48khz by default. So when i played any music the sample rate on the card had to change to 44.1khz which caused the 0.5 sec delay. Once I changed the default sample rate to 44.1khz the problem went away.

Could you try a analogue audio cable to your amp to make sure your PC isn't a fault?

EDIT:
Are you using onboard sound?
Who are you and how did you get in here ?
I'm a locksmith, I'm a locksmith.

Starting DTS-CD/track manually cuts first 1sec (playing to next is OK)

Reply #4
Yes I'm hearing this gap or lag even in the 'test' in Windows Sound setup too, can this be fixed?
Doesn't seem to happen in 16 bit , just when you go to 24 bit settings
Onboard yes

Starting DTS-CD/track manually cuts first 1sec (playing to next is OK)

Reply #5
maybe, but we need more info, what soundcard are you using?

Try this

I assume your on Windows 7?

Start menu > Control Panel > Sound > right click the SPDIF output device your using > advanced tab > change the default format to 2 channel, 16 bit, 44100 Hz > apply and test again.

EDIT:
just saw your ninja edit, so all good with 16bit then?
Who are you and how did you get in here ?
I'm a locksmith, I'm a locksmith.

Starting DTS-CD/track manually cuts first 1sec (playing to next is OK)

Reply #6
maybe, but we need more info, what soundcard are you using?

Try this

I assume your on Windows 7?

Start menu > Control Panel > Sound > right click the SPDIF output device your using > advanced tab > change the default format to 2 channel, 16 bit, 44100 Hz > apply and test again.


Already tried,  when set at that setting Foobar plays no sound, has to be set at 24 bit

Starting DTS-CD/track manually cuts first 1sec (playing to next is OK)

Reply #7
what output mode are you using in Foobar?
Who are you and how did you get in here ?
I'm a locksmith, I'm a locksmith.


Starting DTS-CD/track manually cuts first 1sec (playing to next is OK)

Reply #9
If you find no other way to solve it there's a DSP component designed to workaround the problem.

Starting DTS-CD/track manually cuts first 1sec (playing to next is OK)

Reply #10
sorry my wording was wrong, output device I meant.
Who are you and how did you get in here ?
I'm a locksmith, I'm a locksmith.

Starting DTS-CD/track manually cuts first 1sec (playing to next is OK)

Reply #11
If you find no other way to solve it there's a DSP component designed to workaround the problem.


It adds a gap but the music is still cutoff same way

Seems that Neros player did the same thing as I remember too

Starting DTS-CD/track manually cuts first 1sec (playing to next is OK)

Reply #12
It seems it might be the Receiver itself, just trying to sync.  Takes that 1st second. Is that a common problem with maybe a slow processor in the receiver?

Starting DTS-CD/track manually cuts first 1sec (playing to next is OK)

Reply #13
Sorry Ducky, output device I tried default and spdif, no change

Starting DTS-CD/track manually cuts first 1sec (playing to next is OK)

Reply #14
Could you try this version, it adds quiet noise instead of silence. I'm curious to know if this helps.

Starting DTS-CD/track manually cuts first 1sec (playing to next is OK)

Reply #15
Unrecoverable playback error: Bug check (at: playback_process entry=>dsp/run=>dsp_manager::run)

Starting DTS-CD/track manually cuts first 1sec (playing to next is OK)

Reply #16
I removed the gap dll.  Going back to the beginning I noticed the receiver flashes PCM real quick then shows DTS, if that might be a clue for why it might be cutting off the 1st second of any track when started manually.

Starting DTS-CD/track manually cuts first 1sec (playing to next is OK)

Reply #17
I removed the gap dll.  Going back to the beginning I noticed the receiver flashes PCM real quick then shows DTS, if that might be a clue for why it might be cutting off the 1st second of any track when started manually.


You must have your receiver set to auto detect the input format (DTS, PCM, DD, etc.). It's pretty standard to get the first bit of audio cut off while the receiver analyzes the signal and figure out what input mode to switch to. You can fix this on the receiver side by changing it to the actual mode you are outputting (e.g. always PCM, or always DTS). Of course if you expect different input types to be coming into the receiver (as I think you do) then you probably want to just leave it in auto mode and live with the missing bit of audio.

There probably would be some way of fixing this from your PC side though by always having it stream 1 second of DTS encoded silence before playing a DTS track, but I'm not sure how or what could easily do that other than some manual playlist with the silent bits thrown in.

Starting DTS-CD/track manually cuts first 1sec (playing to next is OK)

Reply #18
Entry level Pioneer Receiver, no option to set a default, guess I'm screwed.  Or to not use Spdif which ain't gonna happen, since dts requires digital

Starting DTS-CD/track manually cuts first 1sec (playing to next is OK)

Reply #19
Can you use HDMI from your PC to the AMP?

If so you could let Foobar decode your DTS to PCM and send that to the AMP?
Who are you and how did you get in here ?
I'm a locksmith, I'm a locksmith.

Starting DTS-CD/track manually cuts first 1sec (playing to next is OK)

Reply #20
You could also try setting all fade durations to 0. You know, because fading messes with DTS bitstreams.

 
SimplePortal 1.0.0 RC1 © 2008-2019