Skip to main content
Topic: Making Foobar default player (Read 11279 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Making Foobar default player

The FAQ indicates that one should go to Preferences--File types to associate Foobar with music files.  The only Preference I found showed no "File types".  Where is the correct place to look?

Making Foobar default player

Reply #1
On Vista or 7 you go to Preferences - Shell Integration and click the blue 'Manage file type associations' link.

Also check the options below if needed.
"I hear it when I see it."


Making Foobar default player

Reply #3
http://wiki.hydrogenaudio.org/index.php?ti...nces:File_Types

"This page appears only in standard (not portable) installs of foobar2000, running on Windows XP."

http://wiki.hydrogenaudio.org/index.php?ti...ell_Integration


I've followed all of the suggestions given, rebooting after each set, but to no avail.  The Windows Explorer menu does not show Foobar as either Play or Queue option as it used to.  The version of Foobar had previously associated with my files was several yrs old.  Could that be the problem?

Making Foobar default player

Reply #4
I've followed all of the suggestions given, rebooting after each set, but to no avail.  The Windows Explorer menu does not show Foobar as either Play or Queue option as it used to.  The version of Foobar had previously associated with my files was several yrs old.  Could that be the problem?


The context menu for example shows up immediately after I enable the option and press Apply on my computer.
What operating system are you using? Did you accidentally install fb2k in portable mode?

As for old file associations, if you installed the new version on top of the old one (= upgrade) they should still work. But even if they are not set correctly you can easily re-set them as described above.
"I hear it when I see it."

Making Foobar default player

Reply #5
I've followed all of the suggestions given, rebooting after each set, but to no avail.  The Windows Explorer menu does not show Foobar as either Play or Queue option as it used to.  The version of Foobar had previously associated with my files was several yrs old.  Could that be the problem?


The context menu for example shows up immediately after I enable the option and press Apply on my computer.
What operating system are you using? Did you accidentally install fb2k in portable mode?

As for old file associations, if you installed the new version on top of the old one (= upgrade) they should still work. But even if they are not set correctly you can easily re-set them as described above.


I believe I found the problem.  I was looking for the Play or Queue options on the folder menu where only the WMP options were presented.  However, I found the foobar options on the file context menus.  It's been six months since I used this app, and at 79 my memory isn't as good as it once was, but I thought for sure that I was able to play all of the files within a folder with my older version of foobar without having to highlight all of the files first.  Am I mistaken, or was that a capability of an older version perhaps many years old?

One more small detail--in Set associations for a program, when I selected them all I was subsequently unable to unselect any of them.  Is that something of concern?  Thanks for your help.

Making Foobar default player

Reply #6
However, I found the foobar options on the file context menus.



Did you check "Folder context menus"?
(Windows 7, foobar2000 1.1.7 beta 6, Preferences - Shell Integration)

Making Foobar default player

Reply #7
One more small detail--in Set associations for a program, when I selected them all I was subsequently unable to unselect any of them.  Is that something of concern?  Thanks for your help.


The 'Set associations for a program' window is from Vista/Windows 7, so foobar developers cannot change it.

Above the list of file types you can see the application which you assign the file type to. Once associated you cannot un-associate it anymore, instead you have assign the file type to another application.

Example: You assigned .wav to foobar2000. If you want to change that you have to choose another application, like Windows Media Player, and assign .wav to it.


Btw, you can also right-click on a music file on your Desktop or in Explorer, click Open with - Choose default program... - and select foobar2000 for example.
If you check 'Always use the selected program ...' there, the file association will be changed as well.
"I hear it when I see it."



Making Foobar default player

Reply #10
One more small detail--in Set associations for a program, when I selected them all I was subsequently unable to unselect any of them.  Is that something of concern?  Thanks for your help.


The 'Set associations for a program' window is from Vista/Windows 7, so foobar developers cannot change it.

Above the list of file types you can see the application which you assign the file type to. Once associated you cannot un-associate it anymore, instead you have assign the file type to another application.

Example: You assigned .wav to foobar2000. If you want to change that you have to choose another application, like Windows Media Player, and assign .wav to it.


Btw, you can also right-click on a music file on your Desktop or in Explorer, click Open with - Choose default program... - and select foobar2000 for example.
If you check 'Always use the selected program ...' there, the file association will be changed as well.


"click Open with - Choose default program... - and select foobar2000 for example."  The files already show the options of Open or enqueue w/ Foobar.  The folder encasing those files shows Open in new window which leads me nowhere.  7 Home Premium

Any disadvantage to having all those apps associated w/Foobar?  I don't plan to use any other music-related apps in the future.

How do I get music folders to be associated w/Foobar?

Making Foobar default player

Reply #11
I'm guessing that the folders that you are having problems with are in you windows 7 "Music" Library. Try Control Panel\All Control Panel Items\Default Programs\Set program access and computer defaults and uncheck the Allow option for Windows Media Player and Windows Media Centre (although this will disable Media Centre completely, but you said you didn't plan on using other apps.)

Making Foobar default player

Reply #12
I'm guessing that the folders that you are having problems with are in you windows 7 "Music" Library. Try Control Panel\All Control Panel Items\Default Programs\Set program access and computer defaults and uncheck the Allow option for Windows Media Player and Windows Media Centre (although this will disable Media Centre completely, but you said you didn't plan on using other apps.)


Thanks, Purple Monkey, that did the trick.  Now, would I have access to WMP and WMC if I were to shift all of my music files to a folder other than "Music Library"?


Making Foobar default player

Reply #13
I think so, you can definitely use WMP ether way but it has been a while since I had that option enabled. You wouldn't need to actually move your files, removing the affected folders from the library locations (click on Includes x locations when viewing Libraries\Music) should do the same.

 
SimplePortal 1.0.0 RC1 © 2008-2019