Skip to main content
Topic: foo_vst: VST 2.4 adapter (Read 358227 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

foo_vst: VST 2.4 adapter

Reply #300
Quote
only a slightly slower foobar startup
Yep, this is the way the adapter works. It keeps track of DSP stack from the very application startup as opposed to deferred loading, i.e. when the user starts playback. Either way, there is a delay before you can hear something

Further development of the adapter seems somewhat problematic to me because I have no time at all, you know, two jobs and two educations at once (final year both with all the headaches). And when I graduate, I'll have to go to the god damn army (it's obligatory here in Russia). That is I'll return home in summer 2012. Most likely i'll make it open source so you (yes, You, the most experienced and patient developer!  will be able to finish the job.


"Most likely i'll make it open source". Is this possible?

foo_vst: VST 2.4 adapter

Reply #301
Yep! It does everything I need and I'm bored with it anyway. Here you are: [attachment=6658:foo_vst_src.zip]
The Simplified BSD License is in license.txt.

foo_vst: VST 2.4 adapter

Reply #302
Thanks for the source.
There's a developer to improve the Foobar2000 VST 2.4 adapter, in particular chapter GUI to look better?

foo_vst: VST 2.4 adapter

Reply #303
Thanks for the source.
There's a developer to improve the Foobar2000 VST 2.4 adapter, in particular chapter GUI to look better?


The UI is fine, what could be improved is VST compatibility and performance to a lesser extent.

foo_vst: VST 2.4 adapter

Reply #304
I noticed they were already 244 number of downloads. There are a developer who has brought or will bring several improvements to the adapter (now or in future)?

foo_vst: VST 2.4 adapter

Reply #305
Voxengo SPAN seemed to work but a little retarded when used for a few minutes. The RMS volume statistic doesn't get updated accurately.
Seemed to work fine on most renown DAWs.

Hope some new developer comes along to improve the foo_vst plugin performance.

Regards.

foo_vst: VST 2.4 adapter

Reply #306
Quote
Voxengo SPAN seemed to work but a little retarded when used for a few minutes. The RMS volume statistic doesn't get updated accurately.
Seemed to work fine on most renown DAWs.
This is a known issue:
Quote
Display goes ahead of audio by the size of the output buffer.
It can't be fixed due to different buffering approaches between media players and DAWs. The foobar's DSP line isn't supposed to be used for visualization at all.

foo_vst: VST 2.4 adapter

Reply #307
It is there some way to integrate de vst adapter as a pannel on Defaul User Interface or Columns UI?

Ys
Rozzo

foo_vst: VST 2.4 adapter

Reply #308
Thank you for making this VST Adapter
working very well
Foobar2k sounds much better now.........
Thank you once again......

Foobar2k v.1.1.8 final
DSP Setting
   - SoX Resampler 2x Best
   - VST VB-FFX4 to load DX FX (RComp, BBE, L2)



Systems:
   - Audiotrak Prodigy HD2 - Wasapi Output 24bit
   - OpAmp 2xLT1364 + AD797-BR (browndog adapter)
        - DIY LM3886 Amp + Philips 6922 Tube Buffer
        - Wharfedale Diamond 9.1 (anniv) Speakers
        - Yamaha YST-SW325 Sub

 

foo_vst: VST 2.4 adapter

Reply #309
Hey there,

Thanks for developing this amazing component!

Here's a bug for you:

foobar 1.1.8 with current version 2.4 of foo_vst.dll crashes/freezes with Electri-Q 1.8.8 when doing many critical features like loading a preset or setting the ability to resize the window. I think this is related to the VST plugin giving a popup; in Electri-Q, loading a preset asks for a file and setting "allow resize" gives a warning popup that a restart is necessary.

Thing is, whatever version of foo_vst.dll with the "date modified" being 1/8/2011 9:35PM, 170KB in size, works fine with this electri-q plugin. Perhaps it is good if you would post an archive of old versions as problems with some VST plugins may be fixed with an older version of foo_vst.dll!


foo_vst: VST 2.4 adapter

Reply #311
It's also multichannel to some extent, it supports Foobar's DSP preset subsystem and is able to work within portable installations. OTOH, it lacks support for non-GUI VSTs and isn't very robust due to huge differences between VST and fb2k's APIs.

foo_vst: VST 2.4 adapter

Reply #312
All

I get this error, when I try to load the Allocator VST:

"Could not load VST DLL. You may have tried to use x64 DLL or there is an internal error in the plug-in.

C:\Program Files (x86)\foobar2000\components\VST Plugins\Allocator1.0.15\Allocator.dll"

Per this link, the combo should work:

http://www.exadevices.com/Blog/tabid/253/a...oobar-2000.aspx

Per the Allocator creator it should work, too:

http://www.thuneau.com/forum/viewtopic.php...b45ca1597bbf4db

Any idea what's up?

Thanks!
Jim

foo_vst: VST 2.4 adapter

Reply #313
Nevermind...did some more research.  I got it working by copying msvcr71.dll to the Windows/SysWOW64 directory.

-Jim

foo_vst: VST 2.4 adapter

Reply #314
Not surprizingly, the thing made its way to the troubleshooter. Well, any bridge like this would be doomed anyway.

foo_vst: VST 2.4 adapter

Reply #315
foobar2000 1.1.9

--
Online Troubleshooter:
foo_vst.dll : VST 2.4 adapter 0.9.0.3
Reason: Repeated crash reports.

foo_vst: VST 2.4 adapter

Reply #316
Archive is corrupt in the op and the dll won't extract and can't be repaired.

Please repack/repost.

foo_vst: VST 2.4 adapter

Reply #317
Yegor, would it be possible if you posted the previous version of your VST bridge? It was asked previously, and it does make sense as the previous version is your official latest stable version, while 0.9.0.3 is an experimental version. Both versions display different behavior with certain VSTs, so it would increase the VST compatibility range quite a bit.

foo_vst: VST 2.4 adapter

Reply #318
It turns out the only previous version on my new PC is 0.9 and its only difference from 0.9.0.3 is correct update handling. Do you still want me to publish it?

foo_vst: VST 2.4 adapter

Reply #319
Oh, I see. The version I was looking for was the previous stable one, 0.8.x.x, which I unfortunately can't remember the exact numbering  But thanks anyway.

foo_vst: VST 2.4 adapter

Reply #320
Well, I looked up in my back-ups and found all binaries starting from v0.5. I just thought they weren't backed up.

foo_vst: VST 2.4 adapter

Reply #321
Hats off to you sir, with my most sincere thanks *bows down* 

foo_vst: VST 2.4 adapter

Reply #322
Quote the Foobar "Online Help":

foobar2000 troubleshooter
The following components found on your system are known to be problematic and should be either uninstalled or updated to their latest versions:

foo_dynamic_range.dll : Dynamic Range Meter 1.0.0
Reason: Repeated crash reports.

foo_vst.dll : VST 2.4 adapter 0.9.0.3
Reason: Repeated crash reports.

Do you have a fix for this?

Bob

foo_vst: VST 2.4 adapter

Reply #323
The only way to fix it is to sandbox VST DLLs in a separate process. It is possible but it'd be a major rework, not just a fix.

foo_vst: VST 2.4 adapter

Reply #324
The only way to fix it is to sandbox VST DLLs in a separate process. It is possible but it'd be a major rework, not just a fix.


OK. I haven't had any problems, just wanted to make sure you were aware. I would hate to see this plug-in black listed.

Bob

 
SimplePortal 1.0.0 RC1 © 2008-2018