Skip to main content
Topic: High CPU and memory usage after upgrading from v0.9.6.9 (Read 3125 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

High CPU and memory usage after upgrading from v0.9.6.9

Good night, everyone,

I recently upgraded my fb2k from v0.9.6.9 to the latest v1.0.2.1 I kept all the settings, plugins etc. unchanged.

Frankly speaking, I haven't yet noticed any considerable improvements as compared to the previous version, but one thing got worse for sure: the latest fb2k uses a lot more CPU power and System Memory!

I start my v0.9.6.9 and it uses and average of 10—15% of CPU and 66 megs of Memory Usage while playing music. Then I start v1.0.2.1 and—surprise surprise—it uses a staggering 60—70% of CPU and 77 megs respectively with EXACTLY THE SAME SETTINGS AND PLUGINS CONNECTED. It's a SCANDAL . I have a pretty old computer and now I have difficulty browsing the web with my browser (a few pages at at a time) with my ativirus program on AND with the latest fb2k playing. If I unload the fb2k, everything gets back to normal. If I start it again, my browser slows down to an annoying degree. If I change the player’s priority from Nornal to Below normal, it starts playing music by fits and starts, with pauses every few seconds. That sucks, too!

All that reminds me of the good ol' times some 9 or 10 years ago when many of us listened to our music with WinAmp. We loved the player for its simplicity and light weight (the latter being crucially important in view of the technical limitations that our computers had back in the day). As years went by, WinAmp became all the more complex, improved, and plugin-laden until one "sweet" day it bacame so HEAVY, BULKY, and SLOW that it became a pain in my system's digital ass. That's why I dumped it in favor of the quick, fresh, and LIGHT fb2k a few years ago.

Now, I wonder if I'm being too paranoid and quick to judge OR maybe our wonderful player fb2k has really started to follow in Winamp's (heavy) footsteps.

What do YOU think?
¡No por mucho madrugar amanece más temprano!

High CPU and memory usage after upgrading from v0.9.6.9

Reply #1
7.5MB working set playing an MP3 in my minimal portable installation. If you've got a problem with an application using <8MB of memory in 2010, you've got serious problems.

High CPU and memory usage after upgrading from v0.9.6.9

Reply #2
Maybe it's indexing all your files. It will only do it once.
It should not use more than like 1% CPU, during playing, unless you use lots of components and maybe some vis.
Windows 10 Pro x64 // foobar2000 1.3.10

High CPU and memory usage after upgrading from v0.9.6.9

Reply #3
If there really were a 700% CPU usage increase, I bet there would be much more complaining to read on this forum.
Maybe you could let us see the full list of your components, there might be some compatibility problems or whatever.
There are also some [a href='index.php?act=findpost&pid=617783']guides[/a] available on how to track down what exactly is the CPU intensive task.
Full-quoting makes you scroll past the same junk over and over.

High CPU and memory usage after upgrading from v0.9.6.9

Reply #4
I told you, guys, that I currently use the same number of components/plugins and just the same settings as I had in my previous v0.9.** installation. There must be something in the core of the v1.*** that requires a much higher CPU usage.

All the media files have been perfectly indexed, too, because I've been using the new version for about a couple of weeks now.
¡No por mucho madrugar amanece más temprano!

High CPU and memory usage after upgrading from v0.9.6.9

Reply #5
maybe those "exact same plugins" you use aren't working well with 1.0 because they are not yet compiled with the latest SDK?
fb2k on OSX: flac q8 > rockboxed Sansa e280v1: Vorbis q5.0

High CPU and memory usage after upgrading from v0.9.6.9

Reply #6
I doubt that. I went to the trouble of downloading the latest versions of all the components/plugins from foobar2000's web-site. It's all kosher, compatible and up-to-date.
¡No por mucho madrugar amanece más temprano!

High CPU and memory usage after upgrading from v0.9.6.9

Reply #7
I start my v0.9.6.9 and it uses and average of 10—15% of CPU and 66 megs of Memory Usage while playing music.


and you think that's normal? :/

High CPU and memory usage after upgrading from v0.9.6.9

Reply #8
This thread needs less trolling and more technical information.
Full-quoting makes you scroll past the same junk over and over.

High CPU and memory usage after upgrading from v0.9.6.9

Reply #9
It's normal for an 8-year-old computer with AMD Athlon 1700 and 512 megs of system memory.
¡No por mucho madrugar amanece más temprano!

High CPU and memory usage after upgrading from v0.9.6.9

Reply #10
suggest using Sysinternal's Process Explorer to nail down your actual memory usage and take a look at the threads to see what dll's (components) might be causing high CPU.

if you have a lot of Autoplaylists that update very frequently that could be part of your issues as well.

v1.0 is just as snappy as v9.x was for me. 
CPU usage hovers very close to 0% for me even with the app playing full screen, 4 built-in visualizations and lyrics display (27 plug-ins total including core). CPU spikes very briefly on start up, but that's expected as autoplaylists initialize and the library scans for any changes.  memory usage sits around 160MB Private Bytes  for me, but i have a 46K item library which foobar manages better than winamp ever could.

even with my huge library, memory usage is very comparable to firefox or chrome with a 3-5 tabs open.

would never even dream of going back to winamp...

With Full Portable install no additional plugins, Slim View, no Vis., one playlist, no library ...while playing its 12.5MB Private Bytes and still 0% CPU usage.

anyways, good luck.

High CPU and memory usage after upgrading from v0.9.6.9

Reply #11
You said you've updated the components - So maybe a component is to blame. Get a list of the components and which ones you've updated.

Personally I run foobar2000 on an Atom N270 with Windows 7, a large bunch of components and absolutely no problems. Sure it's running as a server so I don't really experience how programs run by it's side.
Can't wait for a HD-AAC encoder :P

High CPU and memory usage after upgrading from v0.9.6.9

Reply #12
v1.0 is just as snappy as v9.x was for me.


Here also. I even use it in an a ancient IBM A31 laptop with a 1.6GHz P4-M, 512MB ram, so a much slower processor than your's and my music folders point to a shared MP3 folder in my main computer with like 14000 tracks and cpu never goes above 5-10% when playing. I'm using EQ, Audioscrobbler and -6db hard limiter and no vis. If i put vis (Spectrum), it goes between 30-40% so maybe you're using some type of vis? But v0.9 was the same for this pc.

This is just for a terms of comparison with your rig.

High CPU and memory usage after upgrading from v0.9.6.9

Reply #13
[font= "Impact"]PROBLEM SOLVED![/font][/size]

A few minutes ago I pressed Ctrl+Alt+Del to open the Windows Task Manager to see if my foobar2000 (it was playing at the time) was still using ahellavelotta CPU power. Guess what! It was some 5-10%. BUT the player was minimized to system tray. I opened it, and the CPU usage jumped to 65-70% at once  My inner voice told me to remove the Visualization:Spectrum thing from the toolbar and voilá--the CPU usage dropped to 10%.

WHO'D HAVE THOUGHT THAT SPECRUM-SHPECTRUM BAR REQUIRED SO MUCH CPU POWER!

P.S. Then again, the Spectrum toolbar was ON in my previous foobar2000 version and the CPU usage was low. IT BEATS ME.
¡No por mucho madrugar amanece más temprano!

High CPU and memory usage after upgrading from v0.9.6.9

Reply #14
Yeah it does beat you.

Probably a component conflict, but no one can help until you post the list of components you use...


 
SimplePortal 1.0.0 RC1 © 2008-2020