Skip to main content
Topic: Crossfader DSPs choppy on radio stream start (Read 1152 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Crossfader DSPs choppy on radio stream start

I tried both of these superb crossfader plugins, and both are great but my favourite is Continuator because you can set a threshold dB drop at the end.
The problem is when starting an online radio stream the sound is "choppy" until the DSP buffer size fills (~10000ms). Both of the plugins has an option to automatically trigger on a script to disable crossfader. They got disabled but the 10000ms buffer is still kept that needs to be filled, and the sound is still choppy.
I use only a crossfader in the DSP chain.


for foo_dsp_crossfader I use this trigger script:
Code: [Select]
$if($strcmp(%gc_playback_order%,Random),$gc(fading:enable,1),$gc(fading:enable,0))


P.S.: I don't have problems with the bandwidth, without crossfader in DSP chain everything works fine, even the new experimental OGG-FLAC stream of Absolute Radio

Any solution?? Are these plugins outdated??Needd to be recompiled with latest SDK???

Once again: foo_dsp_continuator, foo_dsp_crossfader
LAME 3.99.5 -V0

Crossfader DSPs choppy on radio stream start

Reply #1
Problem solved!! It was a config problem in foo_dsp_continuator (I used to upgrade foobar2000 without reconfig).
Deleting foo_dsp_continuator.cfg solved the problem.
Now foobar is the perfect player for my needs.


Problem still persists with ogg streams (Absolute Radio)
LAME 3.99.5 -V0

 
SimplePortal 1.0.0 RC1 © 2008-2020