Skip to main content
Topic: high CPU usage with resampler! (Read 3593 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

high CPU usage with resampler!

hi,

when i use the resampler my comp have a cpu usage over 20%. what can i do. i´ve a 800 mhz p3 and a creative soundcard.

high CPU usage with resampler!

Reply #1
i believe thats normal for a pIII, even in fast mode.
.

high CPU usage with resampler!

Reply #2
I have Celeron 800MHz and Audigy1 In fast mode @48000Hz - 16-20%; in normal mode even 50%..........

high CPU usage with resampler!

Reply #3
I know that mine is an extreme case but a PII 350 = 50%

Is there any optimisations that can be made for the resampler?

high CPU usage with resampler!

Reply #4
[deleted]

high CPU usage with resampler!

Reply #5
Using directsound output would probably decrease the CPU usage. But sometimes, other programs running in the background seems to cause increased CPU in foobar. For example, on my Athlon 750, my foobar with resampler on usually takes about 15% of my CPU, but when MSN Messenger is running on the background, that goes up to 20-22%!  I believe this has been discussed on the forums before, but seems like there's no remedy for this issue.

But then again, most times I don't notice the change, so I guess it's not that important...

high CPU usage with resampler!

Reply #6
Resampling is a very CPU intensive process, and is only used when extreme quality is needed.  So any quality trade offs would just about render the resampler usless.  If you want good sound enable the resampler, you want low cpu usage disable it.  Simple as that

high CPU usage with resampler!

Reply #7
Quote
Using directsound output would probably decrease the CPU usage. But sometimes, other programs running in the background seems to cause increased CPU in foobar. For example, on my Athlon 750, my foobar with resampler on usually takes about 15% of my CPU, but when MSN Messenger is running on the background, that goes up to 20-22%!   I believe this has been discussed on the forums before, but seems like there's no remedy for this issue.

But then again, most times I don't notice the change, so I guess it's not that important...

yeah, when i run burn a disc with burnatonce foobar goes from 1-5% cpu time (w/ resampler on fast) to 15-20%!  This on a p4 2.1ghz under win2k.  Strange behaviour.

 

high CPU usage with resampler!

Reply #8
Well, resampling is a pretty huge overhead.

P.S.  I've seen the increase in CPU usage as well (when running UT2003).  I think part of it is the way Windows calculates CPU usage.  I don't really think it's overly accurate.

 
SimplePortal 1.0.0 RC1 © 2008-2019