Skip to main content
Topic: Question on %name%, %<name>%, etc. (Read 3932 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Question on %name%, %<name>%, etc.

Hi all!

Can someone please point me to a piece of documentation on the differences of

%name%
%<name>%
$meta(%name%)
$meta(%<name>%)

The Titleformat Reference was no help for me on that and I couldn't find any further info. Might be my imperfect english though ...

Thanks,
Michael

Question on %name%, %<name>%, etc.

Reply #1
Maybe.

%name% – Retrieves titleformatting field "name". Can be either from metadata/tag (%artist%), other file related data (%bitrate%) or provided internally by something else (%isplaying%). Suspect to remapping as detailed in the docs.
%<name>% – As above, but multiple values of one field (e.g. multiple artists) are not returned as a single string separated by commas, but like separate entries instead. Usable only in contexts where it makes sense (Album List, Facets).
$meta(name) – Retrieves the metadata field "name" directly (i.e. only from file tags, no remapping).
$info(name) – Retrieves the technical information "name" directly.

$meta(%name%), $meta(%<name>%) – Nonsense.
Full-quoting makes you scroll past the same junk over and over.

Question on %name%, %<name>%, etc.

Reply #2
Thanks Yirkha!

While your answer was perfectly understandable I'm afraid, I don't really get it, though.

When toying around i couldn't produce a difference.

When I change the standard album list view 'by year' from "%<date>%|..." to "%date%|..." nothing changes. Neither does changing [%<genre>%] to [%genre%] in Facets.

Do you have an example?

Michael

Question on %name%, %<name>%, etc.

Reply #3
If you have one track with two genres like Country and Eurodance (and they are properly saved as two values of field GENRE), %genre% shows them under one node "Country, Eurodance", while %<genre>% lists the track twice, once under "Country", secondly under "Eurodance".

An example for custom multi-value field FOO and one track with FOO set to "bar; baz":
Full-quoting makes you scroll past the same junk over and over.

Question on %name%, %<name>%, etc.

Reply #4
Thanks for your example, now I understand.

Unfortunately I can't reproduce it with 0.9.6.2 beta 2, no matter what I try.

But i gotta leave now, cu l8tr.

Question on %name%, %<name>%, etc.

Reply #5
Hmm I wanted to ask what specifically didn't seem to work, but never mind if you have gone away. See ya
Full-quoting makes you scroll past the same junk over and over.

Question on %name%, %<name>%, etc.

Reply #6
Hmm I wanted to ask what specifically didn't seem to work, but never mind if you have gone away. See ya

Hi, back again!

OK, here's what I do:

Select one track, right click -> Properties.
Tools -> Add new field.
Name = foo, Value = "bar; baz" (bar, semicolon, blank, baz) -> OK

Then I create two album list views.

by %foo% : %foo%|%album% ... etc.
by %<foo>% : %<foo>%|%album% ... etc.

But when I switch view in the album list nothing happens! Please have a look:



*scratching head*

Question on %name%, %<name>%, etc.

Reply #7
Just tested it, yes something is a bit weird now. This always worked like Yirkha said but apparently something was changed. Now it seems you -have- to use "split values" in the file properties in order to make them display as separate values. Before simply using the ; sign would take care of that. I can only guess it was changed so values which actually contain the ; sign (band names?) don't get split automatically.
Too bad the change log never mentions these kind of changes. :/

Question on %name%, %<name>%, etc.

Reply #8
Just tested it, yes something is a bit weird now. This always worked like Yirkha said but apparently something was changed. Now it seems you -have- to use "split values" in the file properties in order to make them display as separate values. Before simply using the ; sign would take care of that. I can only guess it was changed so values which actually contain the ; sign (band names?) don't get split automatically.
Too bad the change log never mentions these kind of changes. :/

Aaahhh ... OK, now I've used "Split Values ...", and now the Album List views work as Yirkha has shown.

I find the user interface a little awkward here. When you use "Split Values ..." in the file properties dialog nothing indicates that you've used this function. You can't see wether the displayed entry for "foo" represents a string or a list. Maybe just like with «multiple values» there should be an indicator like «split values» or «list»?

Interestingly, when using the "by %foo%" view, the display changes from "bar; baz" to "bar, baz" (semicolon is now displayed as comma), while it remains "bar; baz" in the file properties dialog.

Greetings,
Michael

Question on %name%, %<name>%, etc.

Reply #9
It depends on the settings under Advanced preferences > Display > Properties dialog > Multivalue fields. Semicolon is not automatically regarded as separator for fields which are not specified there.

%foo% uses simple comma as the separator, because that's what looks better (in playlist, status bar, …). You can use $meta_sep() to customize it. Properties dialog uses semicolon instead, it's a special case.
Full-quoting makes you scroll past the same junk over and over.

Question on %name%, %<name>%, etc.

Reply #10
Good thing someone knows why ... I guess there's nothing else to be said.

Anyway, thank you guys for taking the time to help me understand (and learn). See y'all in the next thread!

Question on %name%, %<name>%, etc.

Reply #11
It depends on the settings under Advanced preferences > Display > Properties dialog > Multivalue fields. Semicolon is not automatically regarded as separator for fields which are not specified there.

Only to clear things up. I added "FOO" to the multivalue fields when i tested it, but i didn't restart foobar. I guess thats why it wasn't split automatically. After a restart everything worked as expected.

 

Question on %name%, %<name>%, etc.

Reply #12
I added "FOO" to the multivalue fields when i tested it, but i didn't restart foobar. I guess thats why it wasn't split automatically. After a restart everything worked as expected.
Only to clear things up. Reopening Properties dialog is enough, no restart needed.
Full-quoting makes you scroll past the same junk over and over.

 
SimplePortal 1.0.0 RC1 © 2008-2019