Skip to main content
Topic: I have a problem with foobar not being able to play some files. (Read 8100 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

I have a problem with foobar not being able to play some files.

I get and "Unable to Open" messge on some files but I play them in in something else they work fine.  It seems to be on mp3.  Any suggestions?

Marc

I have a problem with foobar not being able to play some files.

Reply #1
Are you opening them from folders in windows or in foobar? If in foobar, maybe you moved the files around and foobar can't find them because it's searching in the original location.

Do you also have this error when you rightclick in explorer on a file and choose open with foobar?

I have a problem with foobar not being able to play some files.

Reply #2
Please post the whole error message.

I have a problem with foobar not being able to play some files.

Reply #3
Please post the whole error message.


This is the message and it's does happen on all the files in the folder/album.  It played tracks 101, 102 and 103 with out a problem.

"Unable to open item for playback (Object not found):
"G:\Backyard Babies\Independent Days\Backyard Babies - Independent Days - 104 - (Is It) Still Alright to Smile!.mp3""

Marc

I have a problem with foobar not being able to play some files.

Reply #4
And is that location exactly where the file is located?

You might want to simply rescan the library in the chance that some small change regarding file location / name was made outside of foobar.

Library > rescan media library

terry

I have a problem with foobar not being able to play some files.

Reply #5
And is that location exactly where the file is located?

You might want to simply rescan the library in the chance that some small change regarding file location / name was made outside of foobar.

Library > rescan media library

terry


Exact same folder!  That's what confusing.

Marc

I have a problem with foobar not being able to play some files.

Reply #6
Did you rescan the library?

terry


I have a problem with foobar not being able to play some files.

Reply #8
marc

Really not sure. Did you try the above suggestion to attempt to play the files via explorer [play with foobar], or use drag and drop.

Do you still get the sometimes work, sometimes not.

Only other thought I have is a crap shoot and past my level of expertise.
Maybe try the two right click utils options. Fix vbr header or rebuild stream. This is only based on my experience with one file  - rebuild stream repaired a problem file of mine - but it was been a long time ago and I no longer remember any pertinent details.

good luck

terry

I have a problem with foobar not being able to play some files.

Reply #9
"Object not found" means the file could not be opened. Nothing about the decoder failing to read it or whatever.

That said, it seems to me like your "G:\Backyard Babies\Independent Days\Backyard Babies - Independent Days - 104 - (Is It) Still Alright to Smile!.mp3" either does no longer exist or fb2k thinks so for some reason.
You might use Process Monitor to see what file it's trying to open and why exactly it fails (run it, add a filter "Process Name - is - foobar2000.exe - Include", try to play one of the failing files and look for lines, where it's in the Path column and Result is not SUCCESS).
Full-quoting makes you scroll past the same junk over and over.

I have a problem with foobar not being able to play some files.

Reply #10
I get this problem when I have a cue shit included in the folder, remove the cue sheet or rename the tracks in the cue sheet.

I have a problem with foobar not being able to play some files.

Reply #11
I get this problem when I have a cue shit included in the folder, remove the cue sheet or rename the tracks in the cue sheet.


I don't have any cue sheets but how do I fix the VBR header?

Marc

I have a problem with foobar not being able to play some files.

Reply #12
I would ignore any reference that I made to vbr header. I would consider Yirkha more knowledgeable

terry

I have a problem with foobar not being able to play some files.

Reply #13
I would ignore any reference that I made to vbr header. I would consider Yirkha more knowledgeable

terry

I think that's where the problem is because there are a lot more files than the one that I posted.  The last one wasn't VBR but (Xing) Guess but it has to be some wierd problem that Foobar doesn't like.

Marc

I have a problem with foobar not being able to play some files.

Reply #14
Here are a couple of thoughts.

Let's look at one folder where some of a set of similar files , say all mp3, play and some do not.

In foobar, select a single playable file > right click >open containing folder. Does the folder open correctly?

Try again with a problem file. Does the folder open or do you get nothing?
If nothing, then I would guess that you have a file naming / path issue.
Maybe for grins, take that problem file and change the long file name to simply song.mp3. Refresh the media library. Will it now play?

good luck

terry

 
SimplePortal 1.0.0 RC1 © 2008-2019