Skip to main content
Topic: Use of 'IPOD_COMPILATION' for foo_dop (Read 3147 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Use of 'IPOD_COMPILATION' for foo_dop

Hello,

I just tried to use the compilation flag with foo_dop and an 8gb Nano. I understood that since there doesn't seem to be any check box for this in any UI, one would need to edit a file's properties and from there set a new metadata string 'IPOD_COMPILATION' = 1. Although compilation mode is on in the iPod, this doesn't work.

Is this at all the right way to use it? And if it indeed is, it would be great if this flag could be set separately from the actual file instead. This is because one could like to have a song both in mix-playlist and as a part of an entire album by that artist. And my main library is in FLAC and the iPod library is an mp3-mirror of that, which means that if I set this flag onto the file itself, my conversion script will determine that the file needs to be converted again... With iTunes this works, so apparently that at least keeps separate track of this flag.

Regards,

.brum

Use of 'IPOD_COMPILATION' for foo_dop

Reply #1
Can you not use the compilation mapping instead of this field?

If you do want to use this field, you either set it before sending, or if set on a file physically located on the iPod you need to use the 'Update metadata (..)' command.
.

Use of 'IPOD_COMPILATION' for foo_dop

Reply #2
Hi,

I'll use whatever that works and is easy to use . Point is, I don't know how to use this, and the metadata technique was the only one I found out about. Currently in the mapping section there's a string including (not byt that computer right now) "various artists", but as far as I understand this wouldn't help in this case (where it's not really a various artists album, but just a playlist)?

So I would appreciate a short introduction to compilation mapping .

TIA,

.brum

 

Use of 'IPOD_COMPILATION' for foo_dop

Reply #3
Hi again,

1) I tried a couple of times to re-do adding the <IPOD_COMPILATION> flag, and checked from the files on the iPod that the metadata was set to 1, but it doesn't work for me. Anybody else having this problem?

2) I read up on the documentation, but unfortunately I'm not wiser as how to use the compilation re-mapping.

I would really appreciate a hint in the the right direction, since foo_dop is otherwise so excellent, but this issue is a real nuisance for me.

TIA,

.brum

 
SimplePortal 1.0.0 RC1 © 2008-2020