Skip to main content
Topic: XMMS FLAC plugin (Read 3436 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

XMMS FLAC plugin

In the archive I downloaded from sourceforge there's also xmms plugin, but it doesn't work under my RH8, it's just like the .so file was not there at all.

Then I got the source, but I couldn't figure out how to compile it, there is no regular "configure" file or something.

XMMS FLAC plugin

Reply #1
try an older package.  in older packages are two files (*.so and ...can't remember the extension).  put both files in the plugin directory. works great on my rh8.

BadHorsie

XMMS FLAC plugin

Reply #2
Quote
Then I got the source, but I couldn't figure out how to compile it, there is no regular "configure" file or something.

Are you sure you got the right tarball?  flac-1.1.0.tar.gz is the source release and there *is* a configure script in it.

Josh

XMMS FLAC plugin

Reply #3
I had the same problem with the plugin. Changing the access etc. rights of the file did solve the problem on my machine...

regards,
userXYZ

XMMS FLAC plugin

Reply #4
Quote
I had the same problem with the plugin. Changing the access etc. rights of the file did solve the problem on my machine...

The permissions are ok, anyone can read the file.

In the meantime, I got these rpms:
http://ftp.freshrpms.net/pub/freshrpms/psy....0-fr1.i386.rpm
http://ftp.freshrpms.net/pub/freshrpms/psy....0-fr1.i386.rpm

I upgraded to 1.1.0 with the first rpm, but failed to install xmms plugin with the second rpm due to some module dependency problems, like id3tag, tagid3 or something like that.

Looks like I'll have to grab the source again 

XMMS FLAC plugin

Reply #5
Quote
Quote
Then I got the source, but I couldn't figure out how to compile it, there is no regular "configure" file or something.

Are you sure you got the right tarball?  flac-1.1.0.tar.gz is the source release and there *is* a configure script in it.

Josh

Is there a static linked version of this plugin?
Here is a libc 2.1 system in use, and this plugin can't be loaded.
--  Frank Klemm

XMMS FLAC plugin

Reply #6
Quote
I upgraded to 1.1.0 with the first rpm, but failed to install xmms plugin with the second rpm due to some module dependency problems, like id3tag, tagid3 or something like that.

Looks like I'll have to grab the source again  <_<

From psyche.freshrpms.net you can get the neccessary packages like id3lib for RH8. This way things should work on your system...

XMMS FLAC plugin

Reply #7
Quote
Is there a static linked version of this plugin?
Here is a libc 2.1 system in use, and this plugin can't be loaded.

I'm not sure exactly what you mean... do you mean where all required libs are statically linked?  by default libxmms-flac.so links to static versions of the flac libraries (libFLAC, plugin_common, etc.) but I don't know of a way to make libtool link the static version of libc or other system libraries.

It is so hard to make a libxmms-flac.so that works for everyone out of the box that I stopped putting it in the binary releases.  Luckily there are RPMs now that cover most people, and otherwise building from source is pretty reliable.  There is even a switch to configure in flac-1.1.0 to install the plugin in $HOME/.xmms/plugins if the user doesn't have root access.

Josh

XMMS FLAC plugin

Reply #8
I finally got it working. After installing that id3lib thing the xmms still didn't "see" the plugin, then I changed file permissions to a+w and it worked! Then I changed permissions back to rwxr-xr-x and it still worked! I don't understand this wierd thing, but it works now.

 
SimplePortal 1.0.0 RC1 © 2008-2019