Skip to main content
Topic: foo_httpcontrol (Read 776649 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: foo_httpcontrol

Reply #1100
the defauld is a cute one.. but don't like white, so have changed colors..

looks like this

have changed the directory from /default to /MEOW
have changed the files: <-config file <-control html repost caused wrong file link =^.^= <- browse html
MEOW have fun! =^.^=

Re: foo_httpcontrol

Reply #1101
I'm having trouble with PlayingCommand... I think.
I have a "Run Command" which works fine on the command line, but I can't seem to make it work through foo_httpcontrol.
It's fairly esoteric (although essential to my workflow): adding the current playing track to a specific playlist.

The full syntax should be like:
Code: [Select]
(assuming I'm adding the track to a playlist called My Playlist).
The equivalent commandline command does work:
Code: [Select]
foobar2000.exe /runcmd-playing="Edit Other/Add to Playlist/MyPlaylist"

For the http version I've urlencoded the spaces and slashes, so I feel it ought to work. Any suggestions?

Re: foo_httpcontrol - Status isPlaying

Reply #1102
How do I determine a sound is playing?

Re: foo_httpcontrol

Reply #1104
Still having trouble with the PlayingCommand above. The Console says simply:
foo_httpcontrol error: command PlayingCommand failed

As a really simple (amusing) check, running:
Code: [Select]
actually results in the track being copied to my Windows clipboard! So "PlayingCommand" as such works.

But with that slightly deeper menu command above, it errors out without any suggestion as to why.
I've tried no urlencoding, selected urlencoding, wrapping the command in double quotes... but no dice.

Any suggestions? Bueller?

Re: foo_httpcontrol

Reply #1105
Dear all

I've been using the Android App Foobar2000 controller PRO (newest version for 2 years now. I'm having fun with it, however, since recently it shows an error message it has now shown before when closing the app:

"Last custom version of HTTP Control is needed"

I've already downloaded the most recent version 0.97.17 from Hydrogenaudio:,62218.0.html

and saved it to the following folder:

How can I get rid of this error message and again take control of Foobar (closing, restart etc. the programme)? Many thanks for your help!

Re: foo_httpcontrol

Reply #1106
"Last custom version of HTTP Control is needed"

This is the key... It requires a *custom* version of this component. Google the app, or have a look somewhere in the help screens I think (I don't have it in front of me right now).

Re: foo_httpcontrol

Reply #1107
Thanks for your answer. I already did google for a custom version, but did not find any such version of the component.

Does that mean that with the standard component (version 0.97.17 from Hydrogenaudio) it does not work? It did so earlier...

Re: foo_httpcontrol

Reply #1108
Does that mean that with the standard component (version 0.97.17 from Hydrogenaudio) it does not work? It did so earlier...

On the one hand, you can find their site at:

But on the other hand, what you're seeing is just a notification about performing an action upon closing the application. The app itself should be working fine other than this message, yes?
Just tap the box next to "Don't ask again" and you won't get that warning again!

Re: foo_httpcontrol

Reply #1109
Thanks for the link to the blogspot. So far I have not found another version other then the "official" 0.97.17 (previously, with the official version it was possible to close Foobar).

True, appart from this message, the app performs just fine. I had some crash issues with the previous version 0.97.15, but it might have had to to with an incompability with Windows 10.

Hoping that controlling Foobar will be able again with the App (e.g. closing it etc.). But it's at least no major issue as it's no malfunction. Guess I will tick the box "don't ask again".

Re: foo_httpcontrol

Reply #1110
did you resolved this ?

Re: foo_httpcontrol

Reply #1111

Re: foo_httpcontrol

Reply #1112
I can't seem to get my PC detected on my android device, media servers just shows blank. Even adding my IP manually still doesn't get it to connect. The instructions link doesn't work anymore.

Re: foo_httpcontrol

Reply #1113
savas, try to disable your firewall. Mine @ nod32 blocked this connection, and when i turned firewall off, my android device found the pc immediately.

Re: foo_httpcontrol

Reply #1114
For those who have found it starting to cause crashes/come up as a warning for frequent crashing in the Online Troubleshooter in FB2k recently when running an older version, and also found the developers bitbucket to be down/inaccessible, i've manage to source v0.97.17 via's wayback machine. See link below.

Many thanks for a great plugin that i've enjoyed with the android app for many years!

SimplePortal 1.0.0 RC1 © 2008-2020