Skip to main content
Topic: %samplerate% unknown after jumping to another position (Read 2586 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

%samplerate% unknown after jumping to another position

I use "%samplerate% Hz" in the status bar. When I play MIDI, SID, MOD, XM, IT or S3M and jump to another position, it only displays "? Hz". When I start a track, I can see it displays "? Hz" for a short time and then "96000 Hz", as it should, until I jump to another position in the track.

My used components:

Code: [Select]
Core (2007-12-31 18:57:54)
    foobar2000 core 0.9.5
foo_abx.dll (2006-12-16 13:52:46)
    ABX Comparator 1.3.1
foo_ac3.dll (2007-02-06 19:44:00)
    AC3 decoder 0.9
foo_albumlist.dll (2007-12-29 15:47:54)
    Album List 4.1
foo_bitcompare.dll (2006-08-04 21:56:00)
    Binary Comparator 1.1
foo_cdda.dll (2007-12-13 23:38:24)
    CD Audio Decoder 2.1.2
foo_converter.dll (2007-12-29 15:47:36)
    Converter 1.0.2
foo_dsp_soundtouch.dll (2007-04-01 08:06:00)
    SoundTouch DSP 0.1 (Intel SSE)
foo_dsp_std.dll (2007-11-22 22:20:02)
    Standard DSP Array 1.0
foo_dumb.dll (2007-02-28 07:47:00)
    DUMB module decoder 0.9.8.4
foo_extm3u.dll (2007-02-02 00:10:27)
    EXTM3U playlist format plugin 1.3
foo_fileops.dll (2007-12-29 15:48:10)
    File Operations 2.0
foo_freedb2.dll (2007-08-16 16:27:44)
    freedb Tagger 0.5.2.1
foo_gep.dll (2007-06-26 18:14:00)
    Game Emu Player 1.5
foo_input_dts.dll (2006-07-22 16:35:00)
    DTS decoder 0.1.7
foo_input_std.dll (2007-12-29 15:50:00)
    Standard Input Array 1.0
foo_menu_addons.dll (2007-10-29 20:42:00)
    Menu Addons 0.4 (Intel SSE)
foo_midi.dll (2007-01-25 13:58:00)
    MIDI synthesizer host 1.7
foo_out_ks.dll (2006-08-04 21:54:00)
    Kernel Streaming Output 1.2.2
foo_rgscan.dll (2007-12-29 15:47:00)
    ReplayGain Scanner 2.0.2
foo_shutdown.dll (2006-12-06 08:59:24)
    Foo Shutdown 0.9.3
foo_sid.dll (2007-08-24 15:58:00)
    sidplay2 1.13
foo_ui_std.dll (2007-12-29 18:06:28)
    Default User Interface 0.9.5
foo_utils_playback.dll (2007-03-10 02:53:00)
    Playback Utilities 1.0

Although that information is a bit useless as those files are always played at 96 kHz, I still would like to display it all the time. Is that behaviour a bug?

Edit: Maybe the forum 3rd Party Plugins - (fb2k) would fit better – I’m not sure if all 3 plugins (MIDI, sidplay, DUMB module decoder) are to blame or if it’s foobar2000.
FLAC.

%samplerate% unknown after jumping to another position

Reply #1
This is a problem with the components, not the player. Sample rate is now reported after every seek.

%samplerate% unknown after jumping to another position

Reply #2
Thanks for the fast response and the updated components!
FLAC.

 
SimplePortal 1.0.0 RC1 © 2008-2020