Skip to main content
Topic: foo_vis_shpeck (Read 586721 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

foo_vis_shpeck

Reply #775
I had the same issues as others here (crash at configuration screen).  I followed viktor's guide for Windows 8.1, x64, and downloaded all his packages. 

I fixed the problem by using the MilkDrop2.25 that Protimus posted a couple pages back.

 

foo_vis_shpeck

Reply #776
I had the same issues as others here (crash at configuration screen).  I followed viktor's guide for Windows 8.1, x64, and downloaded all his packages. 

I fixed the problem by using the MilkDrop2.25 that Protimus posted a couple pages back.


It works. Thank you!

foo_vis_shpeck

Reply #777
I recently installed Foobar, changing from WMP 12. I have used winamp, and both apps are still installed.  I have a licence for G_Force Gold, a recent purchase.

G-Force is operational in my Winamp and in WMP 12, (neither of which I want to use). G-Force runs in stand alone mode (but of course it does not react to the beat, nor does it report my now playing info, both of which I want to have).

I am using Windows 7 fully updated, Foobar2000 v 1.3.2, a copy of Shpeck downloaded today, and I am sorry but I cannot find any way to show which version of G-Force I am running. It is a very recent download. My installation of Winamp is Version 5.666 build 3516 (X86)

I installed Columns UI and Shpeck into Foobar.

Within winamp g-force works, as does AVS.

In Foobar I see both Advanced Visualization Studio v2.82 / Advanced Visualization Studio, and G-Force / G.Force. Both items are as they appear in my 'available plugins' window in Foobar under Visualizations/ Shpeck options.

I can initiate AVS in Shpeck, but I get an error message 'The plugin crashed during initialization.' when I click the start/stop button.

I am comfortable making changes in txt based ini files (and similar) and changing the registry. 

Can you recommend what I should do next to make G-Force work. Thanks

I have also contacted G-Force Dev

Shirley

foo_vis_shpeck

Reply #778
I too would like to raise my concern over G-Force and its brothers (Whitecap and Aeon): it seems none of them work anymore via Shpeck. Morphyre and some Milkdrop builds don't work anymore either. The only things I can get working are Milkdrop 2.2 (old), Geiss (fullscreen only and takes the user hostage by restarting when ended) and AVS (separate window). Things used to work fine a year ago on my Win7 x32, but now on my x64 a year later, it's mayhem.

Does anyone have a definitive "report"/solution on putting visualizers into Foobar? Aside from running the old Milkdrop, I dunno what to do anymore.

foo_vis_shpeck

Reply #779
I too would like to raise my concern over G-Force and its brothers (Whitecap and Aeon): it seems none of them work anymore via Shpeck. Morphyre and some Milkdrop builds don't work anymore either. The only things I can get working are Milkdrop 2.2 (old), Geiss (fullscreen only and takes the user hostage by restarting when ended) and AVS (separate window). Things used to work fine a year ago on my Win7 x32, but now on my x64 a year later, it's mayhem.

Does anyone have a definitive "report"/solution on putting visualizers into Foobar? Aside from running the old Milkdrop, I dunno what to do anymore.


a lot of vis don't work on my win7 x64 either, which is quite a shame

foo_vis_shpeck

Reply #780
I just tried to run Shpeck 0.3.7 with foobar2000 v1.3.4, and in general (ignoring two partial C++ runtime crashes) it worked. AVS 2.81d loads. And it plays some of my old presets.

Some, but not all. Especially not those with SuperScope using getosc() to build a "phase display" ("Color Phaser" variants, "Super Scope Analyzer").

Now I wonder if it is related to Shpeck emulating something incompletely, or a specific version of AVS failing on a few specific features. I found in a Nullsoft forum that there had been issues with AVS v2.82, therefore v2.81d was rebuilt from source some day, so this should have been the more reliable version...

Are there any other WinAmp vis plugins for foobar2000? Their website doesn't list any other than Shpeck.
__

Ah, well, it doesn't work in WinAmp either. So AVS 2.81d seems to have issues with more modern Windows versions (here: Windows 7 64-bit) regarding a specific drawing feature.

foo_vis_shpeck

Reply #781
AVS is just quirky in general on most OS since XP (more so on 64-bit versions of Windows).

2.81d is better for XP and 2.82 is better for Vista ans newer, but they all have issues with random crashing or presets don't work the same between the verisons which is due to compiler optimisation differences between those 2 specific versions. All of which still persists even with the two different test versions of AVS 2.9x that appeared a year or two back and is just a fundamental issue with AVS and not helped by the old ape plug-ins that AVS uses which don't play well (and is the main cause of stability issues that i could determine).

and 2.81d pre-dates 2.82 and 2.83 (2.83 was dropped as that was even more unstable compared to 2.82). but the general for how it's officially handed is 2.81d is installed for XP installs and 2.82 is installed for Vista and newer. but how well it works outside of the native Winamp experience is going to vary a lot between different setups and AVS being unstable under it's native Winamp environment is no wonder it's failing to work properly in non-Winamp setups.

foo_vis_shpeck

Reply #782
A simple replacement DLL of AVS 2.81d was available in the Nullsoft forum AVS thread where the release of its source code was announced.

Are there any other AVS versions available "pure" (without completely installing another whole set of WinAmp)? ... Or maybe it's better not to rely on AVS anymore and try to somehow "convert" its presets to a different visualization toolbox. I believe I once tried something similar to my "Super Scope Analyzer" with MilkDrop, but failed rebuilding a phase display.

foo_vis_shpeck

Reply #783
you can just use 7-zip to extract the AVS aspects from the Winamp installer as needed. as we're going to drop AVS from the Winamp installer with 6.x anyway due to all of the stability issues it's got and just provide it as a standalone installer for those still wanting to use it (as we'd changed it from being the default vis plug-in back in 2007 due to Milkdrop just being better and a lot easier to maintain / fix at that time).

foo_vis_shpeck

Reply #784
Ok, I downloaded latest winamp and copied needed milkdrop files in custom location. I patched milkdrop dll to reflect crt version and while milkdrop runs fine inside foobar, I can't launch configuration dialog as it crashes foobar. I'm currently on 32bit Win7. Any ideas?


foo_vis_shpeck

Reply #786
Well not quite... setting sprites raises error and changing font has no effect. I would assume changing anything in config dialog would have any effect.
So again, any ideas?

foo_vis_shpeck

Reply #787
FYI, major problem here was that I put plugins folder in foobar's own folder, which turned out as bad idea because changing settings in milkdrop configuration dialog, requires write access to ini files in same folder. Putting the plugins folder elsewhere (like appdata/foobar2000) resolves the problem.

foo_vis_shpeck

Reply #788
MilkDrop 2.25 package  (Winamp 5.63 Build 3235)

Changelog:
Fixed: [vis_milk2] Presets not reacting to music in localized installs (Milkdrop v2.25)

Download:
MediaFire

RapidShare

Hotfile

MD5:
ED8D7FBA48A6EE6A72F17D16FD7EEFB8

VirusTotal


This worked perfectly for me, foobar2000 1.3.8, by copying the directory winamp under C:\Users\YourUserNameHere\AppData\Roaming\foobar2000 and configuring the plugin to look into that directory. Great job and a big thank you from me.

foo_vis_shpeck

Reply #789
I moved my portable foobar2000 1.3.8 to Windows 10. When i try to start Milkdrop 2.25 inside the vis_shpeck 0.3.7 configuration, i get this error:

---------------------------
DirectX Missing or Corrupt
---------------------------
Failed to initialize DirectX 9.0 or later; it is either missing or corrupt.
The latest version of DirectX must be installed before you can run this plugin!

Would you like to be taken to http://www.microsoft.com/windows/directx
where you can download the latest version of DirectX?

Please click YES to open this page in your default web browser,
or NO to simply return to Winamp.
---------------------------
Yes  No 
---------------------------



And foobar then stats
Plugin's initialization procedure failed.

I guess there are some DirectX files missing in Windows 10 Technical Preview. Some sites say Microsoft is going to release DirectX12 with the final Windows 10 Release, so let's wait.

foo_vis_shpeck

Reply #790
The missing DirectX runtimes have never come with any Windows version. Please install them and try again.

foo_vis_shpeck

Reply #791
Just a couple screenshots of AVS running the EL-VIS visulizations.




foo_vis_shpeck

Reply #792
Love this plug in, every time I even reduce the window though all settings erase and have to be re initiated. Is there any way of saving AVS settings?
Again I love this plaug in and thank you so much for it's development!

foo_vis_shpeck

Reply #793
The missing DirectX runtimes have never come with any Windows version. Please install them and try again.


Can't remember that i ever installed DirectX Runtimes on Windows 7, 8 or 8.1 and i reinstalled it regularly. Is it distributed via Windows Update?



foo_vis_shpeck

Reply #796
Strange, i always install the exact same software. Thunderbird, Google Chrome, IrfanView, foobar2000 Portable, VLC, Microsoft Office, Notepad++ and sometimes WinMerge, Paint.net and TortoiseGIT via the software distribution WPKG which i also use business wise and i am absolutely sure that none of them installs DirectX Runtimes. Ok i will give that installer a try.

foo_vis_shpeck

Reply #797
Milkdrop relies on newer versions of the DX9 runtime and is why it requires the installation of things (which as noted, games often have required being installed as well). it's no more different than having to install the appropriate C++ runtime (which is often auto-installed as needed by the software).

foo_vis_shpeck

Reply #798
I'm using windows 10 64-bit, got it working at last but when I try to configure milkdrop 2.25 foobar crashes, is there a fix or work around?

Out of curioisity, are they are any other similar plugins to shpeck?

foo_vis_shpeck

Reply #799
Hi there,
First off, many thanks for this great component. I've got AVS & Milkdrop 1 working just fine (aside from AVS not remembering its fullscreen resolution setting).

I'm trying to get Milkdrop 2 & have run into a wall at every turn. Tried to compile from source code but couldn't install any version of Visual Studio to do that, for some reason. Tried the precompiled RapidShare & HotFile links in this thread but it redirects me to wheretowatch.com for some mysterious reason, and the one direct HF link no longer had the file.

May I request a direct working link to download Milkdrop 2 please? Preferably on a dependable website like MediaFire.com, Mega.co.nz or even Dropbox.com?

 
SimplePortal 1.0.0 RC1 © 2008-2019