Skip to main content
Topic: foo_rg_trn (Read 14620 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

foo_rg_trn

Reply #25
I am reviving this old topic because it is not the first time when I doubt if this plugin works. But this time I have clear evidence.
My default RG behavior is "track mode" and "apply gain and prevent clipping according to peak". But in RG Override dialog I have set that when I listen to my music in "Repeat (Playlist)" mode, then RG should be working in "album mode". This is not happening. Listening to my brand new Discogs purchase - Robert Henke's "Floating.Point" have revealed this permanently. I have set order to "Repeat (Playlist)". When "Chowning Island" ends and "Plankton" begins, then volume suddenly drops down - because "Plankton" is simply louder at certain points and thus it has smaller track RG values... Is it possible that this plugin will be repaired to still work in foobar 1.2.9 or newer?

foo_rg_trn

Reply #26
I am reviving this old topic because it is not the first time when I doubt if this plugin works.
It is not working for me either. When I change the value in the main RG option, I can see the waveforms adjust. When I make the changes with the radio buttons, nothing happens.

foo_rg_trn

Reply #27
Fun fact - this forum unsubscribes you silently from threads that have been stalled for a year.

It's possible that the mechanism used to request replaygain mode changes is different, or an additional commit step would have helped.
It would also have helped if someone approached me with these problems instead of just venting in a thread and assuming I'm ignoring it for half a year.
Zao shang yong zao nong zao rang zao ren zao.
To, early in the morning, use a chisel to build a bathtub makes impatient people hot-tempered.

foo_rg_trn

Reply #28
Avi: This component assumes it's the only one messing with the global RG settings. It re-applies the radio buttons whenever the playback mode changes. If you change the global settings, it will not be aware of this and not apply the right one.

It will also assume that the settings left since last shutdown are the ones that are in place when starting up, so if you've got something else messing with this then, you're also doomed.

I don't know how to reproduce your problems as the descriptions and tracks mentioned are out of my reach. Does this keep happening with a vanilla installation without any weird script-based UIs and bells and whistles?

I'm trying to get familiar with the code again, but I see nothing out of the ordinary at all, nor am I aware of anything in foobar2000 that would change how something as fundamental as playlist events would be handled.

I need some proper steps to reproduce, preferably in a clean environment. State your assumptions and actions.
Zao shang yong zao nong zao rang zao ren zao.
To, early in the morning, use a chisel to build a bathtub makes impatient people hot-tempered.

foo_rg_trn

Reply #29
I did notice a volume change from track to track when RG was supposed to be using album info instead of track.

I can confirm it's because I was changing the global RG settings without changing playback order.

foo_rg_trn

Reply #30
Just ran into the same issue. If I have RG set to "none" in foobar's output config, none is applied even though foo_rg_trn is set to album mode. Same other playback/gain modes.

foo_rg_trn

Reply #31
Err, scratch that, it's actually working for me. For some reason I've set one mode to "none" and forgot about it...

 
SimplePortal 1.0.0 RC1 © 2008-2020