Skip to main content
Topic: Album Art Downloader XUI (Read 1460846 times) previous topic - next topic
0 Members and 3 Guests are viewing this topic.

Re: Album Art Downloader XUI

Reply #2950
Script updates
[...]
Country-specific overrides to search stores other than the main USA one are available here: iTunes Country-Specific Searches, but will not show up in the online updates "new scripts" notification, or be bundled with the installer. They depend on having the main itunes.boo script installed, and only that main script will need to be updated if future changes are required.
[...]
Alex

This Link does not work anymore.
Are the country specific script files anywhere else on the sourceforge website?
Thomian


Re: Album Art Downloader XUI

Reply #2952
I have a wish for this useful tool: in the search result thumbnail view, could the context menu for every entry be extended by choice Copy source URL to clipboard? Furthermore, if using drag & drop and releasing the image not over a file container, butt text capable container, the source link could be pasted there.

Re: Album Art Downloader XUI

Reply #2953
Hi

For some reason album artwork downloader does not work correctly. The first time I start it it shows me the start screen but nothing after. I can see it running in task manager for a couple of seconds and then stop. If start it after this it does not even even show the start screen. Same task manager results. I had it running with no problems before, but after a fresh install of Windows because my ssd died. It doesn't want to start anymore. Any help would be appreciated.

Re: Album Art Downloader XUI

Reply #2954
Do you get any error reported in the Windows Event Viewer? Or in an errorlog.txt file in the AAD program folder? If not, I can only offer generic advice to try re-installing .net framework 3.5 and hope for the best.

Re: Album Art Downloader XUI

Reply #2955
Hi Alex

Thanks for the quick response. There was no errorlog.txt file in the AAD program folder. But I did check windows event viewer and i do get an error when i try to start aad. (edit): I have now tried re-installing .net framework 3.5. It seems to have done nothing.
Here is the event viewer Log :

Log Name:      Application
Source:        Windows Error Reporting
Date:          07.08.2019 13:40:39
Event ID:      1001
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      DESKTOP-SOAKDO1
Description:
Fault bucket 2068282392258535810, type 5
Event Name: CLR20r3
Response: Not available
Cab Id: 0

Problem signature:
P1: albumart.exe
P2: 1.0.3.0
P3: 5a9aaeb0
P4: mscorlib
P5: 2.0.0.0
P6: 5c9ef717
P7: 284f
P8: 41
P9: System.ArgumentException
P10:

Attached files:
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER8D58.tmp.WERInternalMetadata.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER8D68.tmp.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER8D87.tmp.csv
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER8D97.tmp.txt

These files may be available here:
\\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_albumart.exe_b36ea21ab8a9c6cdebba854f0a4495db253c8e2_00000000_d1181644-1153-45d5-80eb-a8549d004c25

Analysis symbol:
Rechecking for solution: 0
Report Id: d1181644-1153-45d5-80eb-a8549d004c25
Report Status: 268435456
Hashed bucket: b323ca8557ebc7284cb403e0a5c3e182
Cab Guid: 0
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Windows Error Reporting" />
    <EventID Qualifiers="0">1001</EventID>
    <Level>4</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2019-08-07T11:40:39.702851200Z" />
    <EventRecordID>2842</EventRecordID>
    <Channel>Application</Channel>
    <Computer>DESKTOP-SOAKDO1</Computer>
    <Security />
  </System>
  <EventData>
    <Data>2068282392258535810</Data>
    <Data>5</Data>
    <Data>CLR20r3</Data>
    <Data>Not available</Data>
    <Data>0</Data>
    <Data>albumart.exe</Data>
    <Data>1.0.3.0</Data>
    <Data>5a9aaeb0</Data>
    <Data>mscorlib</Data>
    <Data>2.0.0.0</Data>
    <Data>5c9ef717</Data>
    <Data>284f</Data>
    <Data>41</Data>
    <Data>System.ArgumentException</Data>
    <Data>
    </Data>
    <Data>
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER8D58.tmp.WERInternalMetadata.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER8D68.tmp.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER8D87.tmp.csv
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER8D97.tmp.txt</Data>
    <Data>\\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_albumart.exe_b36ea21ab8a9c6cdebba854f0a4495db253c8e2_00000000_d1181644-1153-45d5-80eb-a8549d004c25</Data>
    <Data>
    </Data>
    <Data>0</Data>
    <Data>d1181644-1153-45d5-80eb-a8549d004c25</Data>
    <Data>268435456</Data>
    <Data>b323ca8557ebc7284cb403e0a5c3e182</Data>
    <Data>0</Data>
  </EventData>
</Event>


 

Re: Album Art Downloader XUI

Reply #2957
I can't remember what language it was but, after the windows setup i changed it to English (United States).
(edit) Scrap the top part i checked my ISO and it is in en-us.
(edit2x) Well scrap the above again. Looked at the language as suggested and swapped my native language to windows display and back to English(US). Now it works again. Very weird bug.

Re: Album Art Downloader XUI

Reply #2958
Hi Alex. I don't seem to be getting any results from Google Play anymore through the app. I know they've just made a change to the site, I guess it maybe needs an update?

Re: Album Art Downloader XUI

Reply #2959
Sorry for the delay, update to Google Play script is now available at: google-play.boo

Re: Album Art Downloader XUI

Reply #2960
Several people have reported recently an issue where Album Art Downloader XUI crashes out at startup. With assistance from some of those reporting the bug, and some research, I have determined that this is due to a bug in WPF on .NET Framework 3.5 on Windows 10, where it will crash out if the input language is anything in this list: MS-LCID that has the non-specific Language ID of 0x1000. I think that's anything that was first introduced in Windows 10.

To try and work around this, I have re-compiled Album Art Downloader using .NET Framework 4.7.2, which I believe doesn't suffer from the same problem. Of course there may be other problems, so if the current version of AAD is working just fine for you then don't feel any pressure to install the recompiled version!

On the other hand, if you would like to try it, especially if you are running Windows 10, and doubly-especially if you are using some unusual input language locale, then I'd appreciate any reports of it working or not working.

 
SimplePortal 1.0.0 RC1 © 2008-2019