Skip to main content
Topic: Album Art Downloader XUI (Read 1345090 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: Album Art Downloader XUI

Reply #2826
A question about booklets.... I'm downloading from MusicBrainz. For Adele - 25, there are 7 cover art files of type booklet
(https://musicbrainz.org/release/3ce75ee5-4fb0-4209-9bde-8770d17f5fc4/cover-art)

Album Artdownloader only lists 3. There are 4  missing.  Any thoughts?

but not a problem with another Adele booklet - Adele 21
https://musicbrainz.org/release/57440dfc-191c-32bd-ada0-14ac366c2a12/cover-art

Re: Album Art Downloader XUI

Reply #2827
is there a way to set the search for a specific preset such as -front, -back etc without editing manually the path for images?
You can include %preset% in the path for images, but that will look for any preset. If you want it to only find a specific preset then you have to edit the path manually to include that.

For Adele - 25, there are 7 cover art files of type booklet ... There are 4  missing.
There is a limit to the number of results from any given source. By default, this is 10. If you click the little ... at the bottom right of the MusicBrainz source you can change this.

Re: Album Art Downloader XUI

Reply #2828
Thanks for the clue on the limited number of results.

Re: Album Art Downloader XUI

Reply #2829

Hi Alex

I was using the edit-presets UI to add more presets when AlbumArt crashed - see attached log.

Details:
1. I had edited the built-in ones to remove "Folder-" from each of the save names. So CDs are saved as cd.jpg etc
2. I added two more presets without issue. Booklet-1 and Booklet-2.
3. When I click on the Add button to add the third one, the program crashes.
4. I can reproduce this at will. Have rebooted several times. I'm using windows 10.

Hope this is enough for a fix.
David

Re: Album Art Downloader XUI

Reply #2830
Thanks for reporting this. It seems to be the same issue JWiels reported: #2803

Unfortunately I was unable to reproduce it, or to determine any likely reason it might happen. The best I was able to do was give some guidance on how to edit the AAD config file manually: #2806. Not very satisfactory, really, but unless I can find a way to trigger this crash locally with a debugger I don't think I'll be able to fix it.

Re: Album Art Downloader XUI

Reply #2831
Thanks for reporting this. It seems to be the same issue JWiels reported: #2803

Unfortunately I was unable to reproduce it, or to determine any likely reason it might happen. The best I was able to do was give some guidance on how to edit the AAD config file manually: #2806. Not very satisfactory, really, but unless I can find a way to trigger this crash locally with a debugger I don't think I'll be able to fix it.

Thanks for the reference to the configuration file. I was able to use that and able to add 6 more presets. I was also able to use them with Save-As.

More info on Edit Presets.

1. I click on Edit Presets and the list of all presets is displayed.
2. If I use the vertical scroll bar and move the view to the bottom, and then click Add, it works.
3. If I do not use the vertical scroll bar and click Add, then AlbumArtDownloader crashes.

Hope this helps.
David

Re: Album Art Downloader XUI

Reply #2832

A seperate issue is that when i right click on save-as, the list is limited to 11 entries. I have 12 in the xml file. Please can you make it longer?

Re: Album Art Downloader XUI

Reply #2833
Thanks, that vertical scrollbar clue is helpful, I'll investigate further.

The preset popup menu is not limited, unless it is somewhere else you were referring to?

Re: Album Art Downloader XUI

Reply #2834
You are right about the number of presets. I added more and it works. No idea why it didn't last time! Apologies.

Re: Album Art Downloader XUI

Reply #2835
1. I click on Edit Presets and the list of all presets is displayed.
2. If I use the vertical scroll bar and move the view to the bottom, and then click Add, it works.
3. If I do not use the vertical scroll bar and click Add, then AlbumArtDownloader crashes.
Could you give the attached 1.03 a try and let me know if you see any more preset crashes? It should fix the crash when the newly added preset is not within the visible scroll area, but I don't know if that's the only cause. It wasn't mentioned by the previous person to report it.

Thanks,

Alex

Re: Album Art Downloader XUI

Reply #2836
Could you give the attached 1.03 a try and let me know if you see any more preset crashes? It should fix the crash when the newly added preset is not within the visible scroll area, but I don't know if that's the only cause. It wasn't mentioned by the previous person to report it.

Thanks,

Alex

That seems to have fixed it. Thanks!
Sorry for the delay in testing

David


Re: Album Art Downloader XUI

Reply #2838
Just a minor thing....... the site URL under the Help-> 'About..... ' is faulty

Re: Album Art Downloader XUI

Reply #2839
Just a minor thing....... the site URL under the Help-> 'About..... ' is faulty
Thanks. Looks like Sourceforge has lost the wiki with the documentation in it. Oh well, I've fixed it at least to redirect to the main project page now. Better than a 404.

Re: Album Art Downloader XUI

Reply #2840
The great thing about Album Art Downloader is how well it works finding covers for a bunch of random songs (not in a album)

The most frustrating thing is seeing all those covers and having to manually give a unique name to each before saving.

I just don't do albums.  All my music is saved as individual mp3 files where I want to embed cover art (and no, I don't expect Art Downloader to do the embedding).  All I want is to point Art Downloader to a folder containing a large number of random songs with proper ID3 tagging and then save all the covers found by Art Downloader into another folder with each cover uniquely named with the associated song.   It seems so basic but I have yet to see how to do it.

Re: Album Art Downloader XUI

Reply #2841
All I want is to point Art Downloader to a folder containing a large number of random songs with proper ID3 tagging and then save all the covers found by Art Downloader into another folder with each cover uniquely named with the associated song.
Is the problem that you have several songs with the same album tag, and you want to download covers for each song? If that's the case, then I think it would be possible by using file path pattern matching instead of ID3 tag matching, so you could define the track name as the 'album'. For example: "\%album%.mp3". It is not generally necessary to split out the artist and album - almost all search sources combine them for the search anyway.

The second part of your usage, to save the covers into another folder uniquely named, is not a problem. In the "Specify path to find images", just include the folder name where you want it to put the art. For example: "Art\%artist%-%album%.%extension%" would create a subfolder of your music folder called "Art", and save covers in that named by artist and album (where album is whatever has been defined in the search, it doesn't have to be the ID3 tag)

Re: Album Art Downloader XUI

Reply #2842
Is the problem that you have several songs with the same album tag, and you want to download covers for each song? If that's the case, then I think it would be possible by using file path pattern matching instead of ID3 tag matching, so you could define the track name as the 'album'. For example: "\%album%.mp3". It is not generally necessary to split out the artist and album - almost all search sources combine them for the search anyway.

Yes, sometimes in a list of random songs there are more than one songs which should have the same album cover embedded.   Anyway, I think ID3 tag matching was working since out of 100 songs, it found album covers for all.

The second part of your usage, to save the covers into another folder uniquely named, is not a problem. In the "Specify path to find images", just include the folder name where you want it to put the art. For example: "Art\%artist%-%album%.%extension%" would create a subfolder of your music folder called "Art", and save covers in that named by artist and album (where album is whatever has been defined in the search, it doesn't have to be the ID3 tag)

Ok, this was the key.  What is very confusing to me is the statement: "Specify path to find images".  It seems like it should say "Specify path to SAVE images".  Making your recommended entry for that option worked.

Re: Album Art Downloader XUI

Reply #2843
Ok, this was the key.  What is very confusing to me is the statement: "Specify path to find images".  It seems like it should say "Specify path to SAVE images".  Making your recommended entry for that option worked.
Great, thanks for letting me know. I take your point about the confusing wording - the intention is to define the path where images belong. It will search there for image files, and of course save them there too (if there are multiple places to search defined, it saves them in the first one).




Re: Album Art Downloader XUI

Reply #2847
It is available in the usual place at https://sourceforge.net/projects/album-art/files/album-art-xui/AlbumArtDownloaderXUI-1.03.exe/download
Thanks.
I followed the link and downloaded it.
I get a compilation error which I did not get with version 1.02:
Quote
"Searching for scripts...
...
Compiling scripts...
amazon-audiobooks-com.boo(14,106): error BCE0005: Unknown identifier: 'PageEncoding'.
amazon-audiobooks-com.boo(14,152): error BCE0005: Unknown identifier: 'PageEncoding'.

Re: Album Art Downloader XUI

Reply #2848
I don't understand why there should be a compilation error, particularly as the amazon-audiobooks-com.boo script doesn't have PageEncoding anywhere in it. The only script with a PageEncoding in it is amazon-mp3-com.boo. That one doesn't cause compilation errors for me either, but had stopped returning results, so I've uploaded a fixed version of it.

Re: Album Art Downloader XUI

Reply #2849
I don't understand why there should be a compilation error, particularly as the amazon-audiobooks-com.boo script doesn't have PageEncoding anywhere in it.
Thanks. I now had a look an the script and there was PageEcoding in it.
During install of 1.,03 I had not checked this script and there must been an older script with PageEcoding that remained in the folder.
After checking the scripts to install all is fine.

 
SimplePortal 1.0.0 RC1 © 2008-2018