Skip to main content
Topic: ID3 "title" field fail utf8 support in v.38, v.39a (Read 2203 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

ID3 "title" field fail utf8 support in v.38, v.39a

In version .36, foobar2000 could read all Chinese characters from ID3 tags, but after I updated it to version 0.38, it failed to read characters from ID3 "title" field, while other fields were good. Version 0.39a exhibits the same symptom.

ID3 "title" field fail utf8 support in v.38, v.39a

Reply #1
ID3 tag reading bug is fixed in 0.39, try forcing re-read for the tags by selecting 'Database' -> 'Reload info from file' from right click context menu.

ID3 "title" field fail utf8 support in v.38, v.39a

Reply #2
I tried "selecting 'Database' -> 'Reload info from file' from right click context menu" but it still didnt work. I'm using FooBar2K 0.39a.

ID3 "title" field fail utf8 support in v.38, v.39a

Reply #3
Yeah, it is fixed after I chose "reload file info".
I am using 0.39a on WinMe.

I'll try it on WinXP, where I first found this problem.

ID3 "title" field fail utf8 support in v.38, v.39a

Reply #4
Quote
Yeah, it is fixed after I chose "reload file info".
I am using 0.39a on WinMe.

I'll try it on WinXP, where I first found this problem.

Hi there, I'm running Foobar2K 0.4 on WinXP and im still having problems displaying chinese characters in the playlist. I can read the characters under "show file info" and on my taskbar where it shows the title Foobar2K is playing, but it just dosent show up on the playlist. Any help will be greatly appreciated.

 
SimplePortal 1.0.0 RC1 © 2008-2019