Skip to main content
Topic: OGG files crash system. (Read 4989 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

OGG files crash system.

We have created a software that uses OGG files.  In it you can play several sound files in a row if you choose.  Only on certain computers the DirectShow Filter icon shows up in the Systray for each time an OGG file plays.  The icon does not go away when a particular sound file is finished playing (until you shut down the whole program).  If you play, variably 5 to 8 different OGG files, you will see 5 to 8 DirectShow Filter icons in the systray and it will freeze the computer.  Sometimes not allowing Ctrl-Alt-Del to shut down the program and you have to hit the big switch.  On other computers, it runs fine, a DirectShow Filter icon is never seen in the systray at any time and it never locks up no matter how many OGG files you listen to. 
Any ideas?  Thank you!

 

OGG files crash system.

Reply #1
I think the problem is a poor quality codec pack. Uninstall that and install some recommended by Xiph.org, like these -> http://www.illiminable.com/ogg/
I had never seen the DirectShow icon on my system when I used Windows. I was using the Gordian Knot codec pack.

OGG files crash system.

Reply #2
This is a problem most likely caused by the useless media preview 'feature' in windows xp.

the fix:
start,
run,
regsvr32 /u c:\windows\system32\shmedia.dll

where c: is the drive your windows is on.

Vorbis-q0-lowpass99
lame3.93.1-q5-V9-k-nspsytune

OGG files crash system.

Reply #3
You are correct, gameplaya.

It has nothing to do with the codecs, the reason that bug^Wfeature never affected any of my systems is that I always turned off that Explorer sidebar that shows "common tasks" and media previews.
I did still get the infamous "permission denied" errors when renaming/moving/deleting media files in Explorer, though. The fix you posted supposedly helps with that, too.

Let us know how that worked out for you, DooDad.

OGG files crash system.

Reply #4
I apologize for my long absence and hope someone is there to check out this old thread.

Thank you for the ideas.  I had hopes on unregistering the shmedia thing.  The unregister succeeded, but I am still getting the same problem with no change.  One difference is that the first time I tried the software that plays an OGG file, it started to show the offening icons in the systray and it then said that the software had encountered a problem and would be shut down.  The second time I tried, it was back to business/problems as usual. 

The idea that something else, such as the shmedia thing is running and is interfering some way makes sense as it only happens on certain computers and not others. 

Any ideas on how to pursue this further.  Thanks so much for the previous help.

DooDad
=-=-=-=-=-=-=-=-=-=-=

You are correct, gameplaya.

It has nothing to do with the codecs, the reason that bug^Wfeature never affected any of my systems is that I always turned off that Explorer sidebar that shows "common tasks" and media previews.
I did still get the infamous "permission denied" errors when renaming/moving/deleting media files in Explorer, though. The fix you posted supposedly helps with that, too.

Let us know how that worked out for you, DooDad.

 
SimplePortal 1.0.0 RC1 © 2008-2020