Skip to main content

Notice

If you are using a Hotmail or Outlook email address, please change it now, as Microsoft is rejecting all email from our service outright.
Topic: Introducing Omni Encoder (Read 31831 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Introducing Omni Encoder

Reply #25
I should clarify that I don't care what your preferences are, I want to know what people can and do use, period. Do people still use APE tags on vorbis/MP3s? are they ape version 1 or 2?

I'm not going to FORCE their use, but i'm going to add the option if it is used by anyone here. Make sense?

Introducing Omni Encoder

Reply #26
Vorbis files with any kind of APE or ID3 tag are simply corrupt and unusable.

As far as I know, foobar2000 was one of the only things to support APEv1/v2 on MP3 at some point, and it no longer does.

Introducing Omni Encoder

Reply #27
I should clarify that I don't care what your preferences are, I want to know what people can and do use, period. Do people still use APE tags on vorbis/MP3s? are they ape version 1 or 2?

I'm not going to FORCE their use, but i'm going to add the option if it is used by anyone here. Make sense?
I still use ape2 on mp3. I think there are plenty of other foobar2k users who still prefer ape2 tags.

As far as I know, foobar2000 was one of the only things to support APEv1/v2 on MP3 at some point, and it no longer does.

It still does, it just no longer uses them by default for stuff like replaygain. The option to use ape by default is hidden, but still there.

Introducing Omni Encoder

Reply #28
Well then, that settles it, no?

Both ID3v1 and ID3v2 for MP3's, Vorbis Comment for OggVorbis and FLAC, don't know what for others.

Anyways, those people using APEv2 can use TagScanner (or MP3Tag) to copy the ID3v2 tags into APEv2 tags.

Introducing Omni Encoder

Reply #29
Hi

Just downloaded version 0.1.1.0 . i have a few questions:


1. You mentioned that AAC support is available in beta, however the only encoders i'm allowed to select are Wave and MP3 (Lame). I tried the "get additional modules" but couldn't get AAC. Am i missing something? I even tried pasting the neroaacenc.exe in the omni encoder folder (using the non-installer version btw), but nothing happened.

2. Under MP3 Codec settings, is it possible for me to get ABR files? Right now i can only see options to get CBR and VBR. Is ABR support planned?

BTW,
I use ID3v1 + APEv2 for my MP3 files. regarding implementation, maybe you can do something like Foobar (three check boxes: id3v1, id3v2, and apev2). Also, it seems that APEv2 tag reading is not supported at present (i'll look into it in further detail soon). Even if you don't support writing APE tags, i hope you support reading them.

Thanks for your effort.

kanak

Introducing Omni Encoder

Reply #30
Hi

Just downloaded version 0.1.1.0 . i have a few questions:


1. You mentioned that AAC support is available in beta, however the only encoders i'm allowed to select are Wave and MP3 (Lame). I tried the "get additional modules" but couldn't get AAC. Am i missing something? I even tried pasting the neroaacenc.exe in the omni encoder folder (using the non-installer version btw), but nothing happened.

2. Under MP3 Codec settings, is it possible for me to get ABR files? Right now i can only see options to get CBR and VBR. Is ABR support planned?

BTW,
I use ID3v1 + APEv2 for my MP3 files. regarding implementation, maybe you can do something like Foobar (three check boxes: id3v1, id3v2, and apev2). Also, it seems that APEv2 tag reading is not supported at present (i'll look into it in further detail soon). Even if you don't support writing APE tags, i hope you support reading them.

Thanks for your effort.

kanak


1. Read the notes in the installer, or the readme in the install dir. I can't include the nero exe's due to licensing issues. Just put them in the install directory.

2. Yeah, abr is the "bitrate" option. you have to check the "force constant bitrate" button to use cbr.

In regards to ape tags on mp3s... i'm going to disclude them for now. Allowing ape tags on mp3s, due to the way i designed the API, would require a tagging system overhaul I don't really feel like doing just to implement something i'll frankly never use, personally. Sorry! Thanks for everyone's feedback... 0.2 might be out in the next couple days.

Introducing Omni Encoder

Reply #31
Hi Jebus

Thanks for your reply.

1. Sorry but i have another newbie question. I have an SSE capable processor. How do I use neroAacEnc_SSE2.exe instead of neroAACenc.exe ? Is renaming aacenc_sse2 to aacenc enough? (just want to know the official way to do this).

2. I got this "error" while configuring neroaacenc:

[a href="http://img72.imageshack.us/my.php?image=errormh6.png" target="_blank"]

5. Do you plan to include the ability to select "high quality" encoder engine setting for Lame?

6. Do you plan to include a "downmix to mono" option?

7. Feature Request: Queuing tasks. If you could add support for queuing, the program would be real powerful. E.g. It could be a "replacement" for Mareo and the like. We could select a bunch of files, and add a task to convert them to Flac/WavPack/etc, and then add another task to convert them to MP3/OGG. It'd be really awesome.

I thank you for your effort. Eagerly awaiting the next version (although i can make serious use of it only when WavPack support is implemented).

Thanks Mate!

Introducing Omni Encoder

Reply #32
In regards to ape tags on mp3s... i'm going to disclude them for now. Allowing ape tags on mp3s, due to the way i designed the API, would require a tagging system overhaul I don't really feel like doing just to implement something i'll frankly never use, personally. Sorry! Thanks for everyone's feedback... 0.2 might be out in the next couple days.

Well, I guess people who use ape tags on mp3 are probably not your target audience. I didn't mean to demand support in my post above, just to mention that ape lovers are still around. (Um, that sounds wrong. But you know what I mean.)

4. A Gripe regarding the "progress bars". At present, the progress bar moves only when it completes the task on the file it's working on (it jumps). Is it possible for you to implement two progress bars? (one representing progress on current task, and another representing the total progress --  like in foobar) I seriously thought my coumputer was hanged
How does foobar do that anyways? Does it watch the console output of the encoder and scrape the percent done from that? That must have been annoying to code, you'd have to customize it for every encoder...

Introducing Omni Encoder

Reply #33
How does foobar do that anyways? Does it watch the console output of the encoder and scrape the percent done from that? That must have been annoying to code, you'd have to customize it for every encoder...

foobar uses piped outputs to feed data to the encoder.  I think that's how it knows how much data LAME / whatever has processed.

Introducing Omni Encoder

Reply #34
Hi Jebus

Thanks for your reply.

1. Sorry but i have another newbie question. I have an SSE capable processor. How do I use neroAacEnc_SSE2.exe instead of neroAACenc.exe ? Is renaming aacenc_sse2 to aacenc enough? (just want to know the official way to do this).

2. I got this "error" while configuring neroaacenc:

[a href="http://img72.imageshack.us/my.php?image=errormh6.png" target="_blank"]

5. Do you plan to include the ability to select "high quality" encoder engine setting for Lame?

6. Do you plan to include a "downmix to mono" option?

7. Feature Request: Queuing tasks. If you could add support for queuing, the program would be real powerful. E.g. It could be a "replacement" for Mareo and the like. We could select a bunch of files, and add a task to convert them to Flac/WavPack/etc, and then add another task to convert them to MP3/OGG. It'd be really awesome.

I thank you for your effort. Eagerly awaiting the next version (although i can make serious use of it only when WavPack support is implemented).

Thanks Mate!


1. Yes, renaming it should work fine since the commands and output should be identical. Haven't tried it though. I'll add that to the readme as well.

2. Wish I knew what was under the "details" button... is that Windows Vista? Haven't tried on it yet.

3. Thanks.

4. Agreed - see my response below.

5. No. High quality (-h, or -q 3) is already selected by default, and no one has proved any value in setting this higher.

6. Possibly, if people really want it.

7. Good idea. Definitely a post-1.0 idea though.

I'll add #3, #4, #6 and #7 to the bug tracker. Thanks for your feedback!

4. A Gripe regarding the "progress bars". At present, the progress bar moves only when it completes the task on the file it's working on (it jumps). Is it possible for you to implement two progress bars? (one representing progress on current task, and another representing the total progress --  like in foobar) I seriously thought my coumputer was hanged
How does foobar do that anyways? Does it watch the console output of the encoder and scrape the percent done from that? That must have been annoying to code, you'd have to customize it for every encoder...


That's how it works, and it isn't too annoying (except that its broken - .NET is supposed to fire an event every time it receives a new line of output, but instead fires them all at once when some internal, undocumented buffer fills up... around 150 lines at once! So it would be jumpy and I disabled it for now).

I could use piped i/o, but then 2-pass encoders, and LAME VBR header writing wouldn't work.

Introducing Omni Encoder

Reply #35
Quote
' date='Aug 3 2006, 21:15' post='417598']
How does foobar do that anyways? Does it watch the console output of the encoder and scrape the percent done from that? That must have been annoying to code, you'd have to customize it for every encoder...
foobar uses piped outputs to feed data to the encoder.  I think that's how it knows how much data LAME / whatever has processed.
I do think so. When I try 2-pass mode of Nero encoder, which requires an output file instead of pipe, the progress indicator jumps.

Introducing Omni Encoder

Reply #36
Hi


I was able to get that "error" again. It happens when the program tries to connect to the internet and either the connection is not there, or if a firewall blocks it (I got the error when i clicked the "get more encoders", but blocked that request through my firewall. The previous time was when it was trying to get an albumart, but i wasn't connected to the internet).

(that's windows xp btw, just skinned)

here's the error i got when i blocked it's request to connect to the internet through Sunbelt Kerio Firewall:



and here's the "details":

Code: [Select]
----------------------------------------
OmniEncoder
    Assembly Version: 0.1.1.0
    Win32 Version: 0.1.1.0
    CodeBase: file:///D:/Live%20Programs/OmniEncoder-0.1.1/OmniEncoder.exe
----------------------------------------
System.Windows.Forms
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Runtime.Remoting
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
ID3Module
    Assembly Version: 0.1.1.0
    Win32 Version: 0.1.1.0
    CodeBase: file:///D:/Live%20Programs/OmniEncoder-0.1.1/ID3Module.DLL
----------------------------------------
LAMEModule
    Assembly Version: 0.1.1.0
    Win32 Version: 0.1.1.0
    CodeBase: file:///D:/Live%20Programs/OmniEncoder-0.1.1/LAMEModule.DLL
----------------------------------------
NeroModule
    Assembly Version: 0.1.1.0
    Win32 Version: 0.1.1.0
    CodeBase: file:///D:/Live%20Programs/OmniEncoder-0.1.1/NeroModule.DLL
----------------------------------------
System.Configuration
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
Accessibility
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------
System.Web.Services
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Web.Services/2.0.0.0__b03f5f7f11d50a3a/System.Web.Services.dll
----------------------------------------
exq8rtgj
    Assembly Version: 0.1.1.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.


Thanks for your replies and your effort.

Introducing Omni Encoder

Reply #37
I can't get monkey's audio files to even be recognized by omni encoder.

Introducing Omni Encoder

Reply #38
I can't get monkey's audio files to even be recognized by omni encoder.


I haven't added a module for Monkey's yet!

Introducing Omni Encoder

Reply #39
I notice this project's homepage is inactive, has there been any further development?

Introducing Omni Encoder

Reply #40
Soon... just moved, that's why the page was down. Personal shit has gotten in the way, but i'll get back on the coding wagon this week some time. I still want this tool for myself, and I have a lot of ripping to do!

Introducing Omni Encoder

Reply #41
Progress Report

Version 1.0 is going to be finished really-soon-now. The web page will be back for the release.

FLAC, MP3, AAC (Nero and iTunes), Apple Lossless and Ogg Vorbis are all currently working, and I think I'll throw in an MPC encoder now that development has restarted.

Album art is handled better now, and the encoding loop is a bit smarter. Crash bugs in the EAC encoder have been fixed or at the very least "fixed", if you coders know what I mean . Fixed the firewall crash mentioned above, as well.

I have 3 things to do before release:
  • Add more verbosity to the encoding dialog box, such as progress on the task bar, encoder used, current album being processed etc.
  • Switch the iTunes frontend to use late binding, so that it for example doesn't crash the whole program when you DON'T have iTunes 7.0.2.16 installed . I think iTunes 7+ will still be required, but I'll make sure it works with the lowest possible version supporting the functions I use. (I know some people don't like 7).
  • Change the way file auto-deletion works, so you don't accidentally blow away your entire lossless backup library (oops  ).
I'm using it right now to back up my whole collection first to FLAC, then transcode overnight to album gain'd iTunes AAC for my iPod. works great!

Introducing Omni Encoder

Reply #42
Progress Report
Version 1.0 is going to be finished really-soon-now. The web page will be back for the release.


0.1.1 didn't CBR (i tried to encode a book at 80-kb).  it went through the motions but there was no mp3 file created at the end.  ABR & V-2 worked great using LAME 3.97.

Introducing Omni Encoder

Reply #43
0.1.1 didn't CBR (i tried to encode a book at 80-kb).  it went through the motions but there was no mp3 file created at the end.  ABR & V-2 worked great using LAME 3.97.


Thanks for catching that. Fixed.

I will be releasing Version 1.0 this weekend after a bit more testing. A lot has changed/been improved since the betas last summer. Please check it out! (a news item will be submitted).

Introducing Omni Encoder

Reply #44
Okay, its done, but there is still a showstopper bug in the iTunes module (seems to choke on some files... not sure why). I hope I can fix it tonight and upload a release candiate at that time. Stay tuned (if anyone is still reading this)

Introducing Omni Encoder

Reply #45
I sure am!

 

Introducing Omni Encoder

Reply #46
Version 1.0 Released

I still don't have icons though... we'll see if people like it enough to create some!

There might still be some bugs in there, but it seems pretty robust now, at least to me and a few friends posing as beta testers.

Anyhow, I guess this topic can die now.

 
SimplePortal 1.0.0 RC1 © 2008-2020