Skip to main content
Topic: I cannot play or rip audio CDs with Foobar (Read 8214 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

I cannot play or rip audio CDs with Foobar



That's the error window that pops up any time I try to rip or play an audio CD, regardless of what CD it is. I'm on Windows XP(SP2), and my optical drive is a Slimtype - COMBO SOSC-2483K which came with my Acer TravelMate laptop. It's an external drive if that makes any difference at all.

I've tried to alter the drive settings options in multiple combinations that are presented to me after choosing to open an audio CD in Foobar(including putting in the correct offset), but to no avail. Any help would be very much appreciated. Thank you.

I cannot play or rip audio CDs with Foobar

Reply #1
First of all: Are the Files shwon in playlist?
Seems to me that Foobar wants to geht the Information abaout the music from CD  because it says couldn't load info.

I myself use WinXP2 And I have also a combo Cd drive but it is not external.

How do you add cd to playlist?

I cannot play or rip audio CDs with Foobar

Reply #2
You can see from the image that (s)he seems to use the standard Open Audio CD dialog. But look at the track numbers referenced in the console! Are you sure that the CD contains any tracks numbered between 16 and 85?

I cannot play or rip audio CDs with Foobar

Reply #3
You can see from the image that (s)he seems to use the standard Open Audio CD dialog. But look at the track numbers referenced in the console! Are you sure that the CD contains any tracks numbered between 16 and 85?


I get this same error when I try and add the CD to a playlist. And the last CD I tried didn't have any tracks between 16 and 85. I'll have to check and see if any others do. This really baffles me, as the problem does not exist on my desktop PC.

Edit - OK, I tried several more CDs, and all had the same problem, with seemingly random track numbers unable to load, but in every case higher track numbers than what was even on the CD. Strangely though, one CD - after letting it load up the computer bonus content upon putting it into my drive - DID work. But only once. So, if I tried to open it again I'd get the same error as every other CD. The only way I was able to open it again was to eject it from my drive, re-insert it, and let the computer bonus content load up again.

I've always had this problem with Foobar, but since I mainly rip CDs with EAC and rarely play an actual audio CD, I ignored it. In the past though, I WAS able to play a CD if I selected 'play audio CD with Foobar' from a Windows dialog box upon initially inserting the disc. Also, this problem does not exist with other media players, even the dumb ones. I am baffled.

I cannot play or rip audio CDs with Foobar

Reply #4
Have you tried to name your external drive with for examlpe e:\?
Is it the option play audio CD with Foobar available?
Quote
In the past though, I WAS able to play a CD if I selected 'play audio CD with Foobar' from a Windows dialog box upon initially inserting the disc.

When did this behaviour change?

Have you updated your firmware for this drive?

See here: http://www.liteonit.com/global/index.php?o...&Itemid=154

I cannot play or rip audio CDs with Foobar

Reply #5
Have you tried to name your external drive with for examlpe e:\?
Is it the option play audio CD with Foobar available?
Quote
In the past though, I WAS able to play a CD if I selected 'play audio CD with Foobar' from a Windows dialog box upon initially inserting the disc.

When did this behaviour change?

Have you updated your firmware for this drive?

See here: http://www.liteonit.com/global/index.php?o...&Itemid=154


Honestly I have no idea how to rename the drive. No, the option to 'play audio CD with Foobar' is no longer available upon inserting a CD into the drive, but even when it was that was the only way I could play a CD. I don't know why I'm not presented with that option anymore, but I did go into my 'AutoPlay' settings and didn't see any way to add the Foobar option back.

Thanks for the link, but when I go to update my firmware(I haven't updated it at all) it tells me "No matched drive detected! This utility is only for Slimtype COMBO SOSC-2483k drive. Detected drives: 2-0-0-0 D: Slimtype COMBO SOSC-2483K KCK2".

This is incredibly frustrating and I know I'm not alone; someone else on another forum I frequent can't play audio CDs with Foobar either, and gets a similar error message. I hope a Foobar developer reads this.

I cannot play or rip audio CDs with Foobar

Reply #6
Okay I know from a german discussion board how to rename a drive.But I don't know how Windows terms in English are. Hopefully you will understand what I mean.

Workplace-> computer administration-> click right on your drive-> change drive character-> so you can change manually the character of the drive.

I don't know if this will help. Actually I believe not.

The other rippers have no problem.

Are there more people outside who have external CD drives?
Maybe It is a special problem with this drive but maybe foobar has in general problem with these kinds of drives. If the second option is true this would be really bad.

Maybe you could send Peter (developer of Foobar) a PM? I think that he is the person who can say what the problem is.

I cannot play or rip audio CDs with Foobar

Reply #7
Quote
No matched drive detected! This utility is only for Slimtype COMBO SOSC-2483k drive. Detected drives: 2-0-0-0 D: Slimtype COMBO SOSC-2483K

That suggests a problem with the drive to me, but I don't want to say for sure. It is weird, though!

I cannot play or rip audio CDs with Foobar

Reply #8
This may be a stupid question, but do you have foo_cdda.dll?
Is over the of = % over 100

I cannot play or rip audio CDs with Foobar

Reply #9
Quote
No matched drive detected! This utility is only for Slimtype COMBO SOSC-2483k drive. Detected drives: 2-0-0-0 D: Slimtype COMBO SOSC-2483K

This should be the same, shouldn't it?
Slimtype COMBO SOSC-2483k should be Slimtype COMBO SOSC-2483K

I cannot play or rip audio CDs with Foobar

Reply #10
To be honest, yes, I think the firmware update should work, but I really don't think that's the issue. I have no problems ripping and playing audio CDs with ANY other media player.

And yes, I have foo_cdda. If that were the problem I would have punched myself in then face the poked myself in the eye with a hot fork  . And just for the hell of it, I deleted my foo_cdda and put a new one in and it didn't make a difference. And in Googling around looking for another one, I came across this. I saw a few other similar things, and it seems the problem might have something to do with the fact that my optical drive connects via firewire. I tried the patch out but of course it's for an older version of Foobar. If anyone would like to patch the current foo_cdda, that would be awesome.

I cannot play or rip audio CDs with Foobar

Reply #11
Maybe you could write to the person who wrote that patched version. Or make a request  in devellopment section.

I cannot play or rip audio CDs with Foobar

Reply #12
Well, I made Foobar my default player of audio CDs, and now the little Windows AutoPlay window pops up again when I insert a CD. I'm able to play and rip CDs if I import them into Foobar that way.


I cannot play or rip audio CDs with Foobar

Reply #13
Maybe you could write to the person who wrote that patched version. Or make a request  in devellopment section.
The development subforum is for discussion about developing foobar2000 components, not for feature requests or problem reports for foobar2000 or existing components.

I cannot play or rip audio CDs with Foobar

Reply #14
Any chance I can get a developer to chime in on this? Will this ever be fixed? Or will I have to always deal with a partially-functional player and occasionally use other players instead?

It must be a little insulting to the Foobar devs that their "most advanced player" fails where software as dumb as iTard and WMP succeeds. I love Foobar, I really wish I could rip and play CDs with it!

I cannot play or rip audio CDs with Foobar

Reply #15
Well, I made Foobar my default player of audio CDs, and now the little Windows AutoPlay window pops up again when I insert a CD. I'm able to play and rip CDs if I import them into Foobar that way.




Hello

JadeE  my memory has gone on me, how do you make Foobar the default player?

cheers


I cannot play or rip audio CDs with Foobar

Reply #17

Well, I made Foobar my default player of audio CDs, and now the little Windows AutoPlay window pops up again when I insert a CD. I'm able to play and rip CDs if I import them into Foobar that way.




Hello

JadeE  my memory has gone on me, how do you make Foobar the default player?

cheers


Go into your preferences -> file types.

Dandruff: You are not alone.


I cannot play or rip audio CDs with Foobar

Reply #19
Well, using the 'add files' function works fine, then I can convert them and it will rip the CD and encode the files. I still wish this would get fixed, though.

 
SimplePortal 1.0.0 RC1 © 2008-2019