Skip to main content

Notice

If you are using a Hotmail or Outlook email address, please change it now, as Microsoft is rejecting all email from our service outright.
Topic: REACT 2 Released (Read 1040207 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

REACT 2 Released

Reply #1725
I've also edited the ini so that I get -v0 for the mp3s.
I'm just in the process of formatting my E drive, then I'll test out the new ini and hopefully that'll be that.

I have looked in task manager and, yeah, albumart.exe isn't the quickest process to close but even after it does, it still takes a wee while before the gap detection starts.

REACT 2 Released

Reply #1726
Wee while? Couple of seconds? I just tested it myself and my CD drive kicks into action exactly when the AAD process closes. How fast the drive "comes up" could add the pause in your case. Remember that it doesn't start until EAC window has focus back. The focus don't come back to EAC after AAD closes if you have opened or switched to other programs after AAD started. I'll make REACT to automatically focus to EAC after AAD closes in the next version. I might add a "splash" dialog too when starting/running AAD since AAD might take some time to open (I just witnessed a situation where after pushing F4, nothing happened for many many seconds (AAD was starting very slow without showing the GUI)). Not very ideal to have no GUI "response" when a user commands it to do something.

REACT 2 Released

Reply #1727
Remember that it doesn't start until EAC window has focus back. The focus don't come back to EAC after AAD closes if you have opened or switched to other programs after AAD started.

Ah, that'd be it then.
One time I must've opened something else, causing EAC to lose focus then, after that, I kept opening up Task Manager to see if the problem was AAD not closing down and, in doing so, taking the focus away from EAC...

I just tried it again without taking the focus away and it was fine.



One last point though, is it possible to automatically delete the two folder.jpg files?
I have no use for them, I just wanted the album art embedded into the mp3s.



And, finally, thank you to everyone who's helped out, especially you Akkurat.
I owe a number of people a large drink.

REACT 2 Released

Reply #1728
You'll have to edit the "REACT-track.cfg" file. Open it up in notepad and push Ctrl-H, and then:
Find what:
Code: [Select]
IF %have_cover%==1 IF NOT EXIST folder.jpg COPY "@cover@" folder.jpg

Replace with:
Code: [Select]
REM IF %have_cover%==1 IF NOT EXIST folder.jpg COPY "@cover@" folder.jpg

And push "replace all" once. Then save the file and it's done, no folder images at all.

No problem, good to see a new REACT user. Happy REACTing.  No need to buy a drink, I just pampered myself with a good dosage of a peaty Lagavulin from the southeastern coast of Islay, the place where my favorite whiskeys are made, Laphroaig being #1.

REACT 2 Released

Reply #1729
There's one of my CDs that doesn't seem to want to rip to flac.
I've tried three times now and whilst it creates the folder the songs should be placed into, the files never appear.

However, it does rip to mp3.

It's really weird and I can't understand why.

REACT 2 Released

Reply #1730
It seems that I celebrated too early. Everything else works but no FLAC files? Encoding problem perhaps? Can you catch what the cmd line console says? If not, open "REACT-track.cfg" and type PAUSE on the #111 line of that file (after a line that says: :end_flac_tracks). Now rip a single track again and see what the FLAC encoding part outputs to the console.

REACT 2 Released

Reply #1731
Everything works for every other CD so far, the problem only affects this CD (the Blues Brothers OST album).


This is what the console says:

Code: [Select]
E:\The Blues Brothers\Music from the Soundtrack>C:\PROGRA~2\EXACTA~1\REACT\tools
\flac.exe -5 -f --picture="|image/jpeg|||C:\Documents and Settings\Administrator
\My Documents\My Music\Music from the Soundtrack.jpg"  -T artist="The Blues Bro
thers" -T album="Music from the Soundtrack" -T tracknumber="9/11" -T title="Minn
ie the Moocher" -T date="1980" -T genre="Blues" -T comment="Created with EAC/REA
CT v2.0.akku.b04, 2010-03-23" -T encoded-by="Administrator" -T encoding="Flac 1.
2.1b -5 -f" "C:\Documents and Settings\Administrator\My Documents\My Music\Ttmp1
!542.wav" -o "The Blues Brothers - Minnie the Moocher.flac"
ERROR: (--picture) unable to extract resolution and color info from file, user m
ust set explicitly
Type "flac" for a usage summary or "flac --help" for all options
Press any key to continue . . .


Does that mean I need to try using a different image in AAD?


edit: I don't know why but every file I tried downloading through AAD for this album refused to work.
So I manually downloaded and named an image of the album cover and it worked.

Odd and confusing but problem solved.

REACT 2 Released

Reply #1732
I kind of suspected this. It seems that the picture is not a proper jpg. You could open the image in some editor (GIMP?) and save it to jpg. Just put the image to "C:\Documents and Settings\Administrator\My Documents\My Music\Music from the Soundtrack.jpg" and REACT will automatically pick it from there when you start ripping (not launching AAD).

EDIT: didn't see your edit.. odd indeed, every image? I haven't heard of AAD XUI image saving problems. You seem to bump into lots of problems.

EDIT2: I just downloaded 10 images (same search parameters) and tried to encode FLAC's. 2 of those images failed like yours. Opened them in notepad and they start like this (1st row): ‰PNG. Case solved. Saved as png's but filenames changed to jpg's.

REACT 2 Released

Reply #1733
[quote author= Changelog for REACT 2.0.akku.b04 link=msg=0 date=]Changed REACT configuring (Ctrl-F2):

    [...]
    * REACT now waits for the EAC process to close completely before configuring.
          o Added splash window while closing the process because it could take some time.[/quote]

I tried to use REACT2.0.akku.b04 with EAC 0.99pb5 on Vista Business but there seems to be some problems:


Pressing Ctrl-F2 to configure EAC for use with REACT I get this message:

"Closing EAC process, please wait."

But after some time I get this message:

"Error! Cannot close EAC!"

REACT is closed after that. The EAC window is closed, too but there is still an EAC process running (using up a core).
Starting REACT once again and "Ctrl-F2" there are 2 processes left, next time 3 and so on ...
Same for running it as Admin or as restricted user ...

What can I do to fix this problem?
Running EAC directly and closing it, leaves an EAC process which has to be closed via task manager - so it seems to be an EAC problem ...
After uninstalling and reinstalling EAC this remaining EAC process problem is still there 

BTW When I tried it yesterday the first time, it worked and the EAC was configurated with "CTRL-F2" but today it doesn't work anymore. 

Thanks.
Ryushi

REACT 2 Released

Reply #1734
Quote
Running EAC directly and closing it, leaves an EAC process which has to be closed via task manager - so it seems to be an EAC problem

Without a doubt, an EAC problem running in your Vista. Sorry to say this but I've no idea why EAC acts like that. I always thought that I wouldn't (solely) suggest this but, have you tried rebooting? Aaargh, that sounds so stupid.  Do you know any Vista/general sites/forums where you could get help with your problem with EAC? Or try EAC forum. Sorry that I'm not able to help you out more.

REACT 2 Released

Reply #1735
Hi All,

I spent all day yesterday delving through this thread and setting up my new Windows 7 machine.  I have EAC with REACT 2.0.akku.b04.  I am using it to copy my CD Collection and have configured it to copy MP3 files to my hard drive and then archive FLAC files to an external hard drive.  Everything is working fine, except I can't get it to create a Cue sheet.  Here is my .ini:
Code: [Select]
[Settings]
Version=2.0.akku.b04
ImageExt=wav
ImageNaming=$artist$ - [$year$] $album$
ImageHotKey={F10}
TracksHotKey={F4}
TracksHotVal=+{F5}
VA=Various Artists
CreateCuesheet=mg
RunCoverDownloader=1
CoverDownloader=C:\Users\Tim\Audio\REACT\coverdownloader\albumart.exe
CoverDownloaderXUI=0
CoverDownloaderLocalPath=
OpenAddMetaDataDiag=0
EAC=C:\Users\Tim\Audio\Exact Audio Copy\EAC.exe
Tools=C:\Users\Tim\Audio\REACT\tools
MinimizeCompressionWindow=1
ProcessPriority=1
Sla_Bks_Col_Qst_Bar_Quo_Ast_Lt_Gt=-|-|-||!|'|#|[|]
Test=0

[UserTrackFormats]
Flac=1
Wavpack=0
LameMP3=1
NeroAac=0
iTunesAac=0
OggEnc2=0
Tak=0

[UserOutputNames]
OutRoot=@mymusic@\EAC
ImageDir_Flac=G:\CD Collection\FLAC-images\$cdartist$
ImageDir_Wavpack=@OutRoot@\WV-images\$cdartist$
ImageDir_MP3=@OutRoot@\MP3-images\$cdartist$
ImageDir_Tak=@OutRoot@\TAK-images\$cdartist$
TrackDir_Flac=G:\CD Collection\FLAC\$cdartist$\[$year$] $album$
TrackDir_Wavpack=@OutRoot@\WV\$cdartist$\[$year$] $album$
TrackDir_MP3=@OutRoot@\MP3\$cdartist$\[$year$] $album$
TrackDir_AAC=@OutRoot@\AAC\$cdartist$\[$year$] $album$
TrackDir_OGG=@OutRoot@\OGG\$cdartist$\[$year$] $album$
TrackDir_Tak=@OutRoot@\TAK\$cdartist$\[$year$] $album$
TrackName_SA=$track$ - $title$
TrackName_VA=$track$ - $title$ [$artist$]
TrackName_SA_acdir=$n - $~t
TrackName_VA_acdir=$n - $~t [$~a]

[UserSettings]
DebugMode=0
Debug=0
Comment=Created with EAC/@reactversion@, @curdate@
EmbedCover=1
ReplayGain=1
ApplyAlbumGain=1
AdjustAlbumGain_dB=+3.0
AddCuesheetAG=0
UseWaveGainAG=0
Opt_Flac=-5 -f
Opt_Wavpack=-hmy
Opt_LameMP3=-V5 --noreplaygain --nohist
Opt_NeroAac=-lc -q 0.21
Opt_iTunesAac=-d -s 2000
Opt_OggEnc2=-q 3.0
Opt_Tak=-pN -overwrite
Ver_Flac=1.2.1b
Ver_Wavpack=4.40
Ver_LameMP3=3.98.2
Ver_NeroAac=1.0.0.2
Ver_OggEnc2=2.83 Lancer aoTuV b5
Ver_Tak=1.0.1

[DefaultMetaData]
discnumber=1
totaldiscs=1
discname=
Any ideas?

REACT 2 Released

Reply #1736
Random987, Tim, check this post, and concentrate on the following points:

- Whole 3. about Album Art Downloader XUI.. if you want to use the newest & best (and basically only working) tool.
- 4.3. about Amending Cuesheet File References, that guide has also necessary changes to copy the generated cues to target folders. (it works only in track mode)
- Pay attention to 5.3., with the limited info you gave it's hard to tell whether you used correct keys to rip or not, but I've a hunch that you didn't. Sorry if it's not the case.

HTH.

REACT 2 Released

Reply #1737
I think I did everything correctly.  Now, I am having an additional problem....it is not saving the files in MyMusic/EAC, rather it is saving MP3 files directly in the MyMusic directory (for example - Toto - Past To Present 1977-1990 - 01 - Love Has The Power)  and it is not saving a .flac copy on my external drive.  Yesterday, I was able to get it to do this (without a cue sheet). 

I don't really care about the Album Art Downloader, so I switched that to 0. 

Thanks for your quick response. 




Random987, Tim, check this post, and concentrate on the following points:

- Whole 3. about Album Art Downloader XUI.. if you want to use the newest & best (and basically only working) tool.
- 4.3. about Amending Cuesheet File References, that guide has also necessary changes to copy the generated cues to target folders. (it works only in track mode)
- Pay attention to 5.3., with the limited info you gave it's hard to tell whether you used correct keys to rip or not, but I've a hunch that you didn't. Sorry if it's not the case.

HTH.


REACT 2 Released

Reply #1738
Quote
rather it is saving MP3 files directly in the MyMusic directory

I believe that those are WAV files, right? The "My music" folder is used to hold temporary files when REACT runs.

Quote
Yesterday, I was able to get it to do this (without a cue sheet).

That is odd. Were you logged in as an admin? Have you checked this? It applies to Win7 too of course.

And if you're using 64bit OS, copy the CHCP.com from "system32" folder to "SysWOW64" folder.

Sorry about this, REACT is a bit of a "mess" currently. It works ok, but it takes nerves & a while to set it up.

REACT 2 Released

Reply #1739
You are correct, they are .wav files.  So it appears they aren't getting processed into MP3 and .flac files. 

I am logged in the same as I was yesterday. 

I tried copying the CHCP, but there was already one existing in SysWOW64. 


The frustrating thing was that it was working partly yesterday (without cue sheets).  Not it is only creating .wav files. 


Is there a new program out there that would be more beneficial?  I only want to archive my CD collection to MP3 files on the internal drive and flac files (with cue) on an external. 

Thanks again


Quote
rather it is saving MP3 files directly in the MyMusic directory

I believe that those are WAV files, right? The "My music" folder is used to hold temporary files when REACT runs.

Quote
Yesterday, I was able to get it to do this (without a cue sheet).

That is odd. Were you logged in as an admin? Have you checked this? It applies to Win7 too of course.

And if you're using 64bit OS, copy the CHCP.com from "system32" folder to "SysWOW64" folder.

Sorry about this, REACT is a bit of a "mess" currently. It works ok, but it takes nerves & a while to set it up.


REACT 2 Released

Reply #1740
Quote
I am logged in the same as I was yesterday.
And that was as an admin? If not, scrap that (I've a feeling that even with an admin login, it might not work.. this is totally feeling based, so please try not to mock me too much ), try the link I posted if you haven't tried it yet. Also, remember to set permissions for the external drive folder ("G:\CD Collection\", right?).

Does a cmd console window pop up after a track is ripped in EAC? Does it close instantly or do you see something happening in there? (the window is minimized by default)

Quote
Is there a new program out there that would be more beneficial?
Not that I'm aware of.

P.S. no need to quote whole posts..

REACT 2 Released

Reply #1741
Mea culpa!  In trying to solve the .cue sheet issue, I installed EAC and react in my user directory (as opposed to program files (x86) directory).  EAC was still pointing its external compression to the old directory.  I can now copy to the requested directories. 

So, I am now back to the original problem, still no .cue sheet. 

I installed GSAR, but I am not sure what file/how I should edit the REACT files.  I am not a computer program, but I play one on the internet. 


REACT 2 Released

Reply #1742
I'm not totally following what you've done.. anyways, here's the modified config file for you, just select all below text in the codebox and replace all contents in the "REACT-track.cfg" file in your REACT install folder:

Code: [Select]
@ECHO OFF
CHCP 1252 | PROMPT
TITLE @track@/@numtracks@ - "@album@"

REM Copyright © Tycho, 2006
REM
REM ** Create compressed audio tracks from ripped .wav tracks.
REM **
REM ** You may consider using image mode (F10)
REM ** as it supports creating tracks via acdir.exe,
REM ** and post-processing will always work (see below).
REM **
REM ** Flac requires flac.exe/metaflac.exe (v1.1.3)
REM ** NeroAac requires NeroAacEnc.exe/NeroAacTag.exe/AacGain.exe.
REM ** OggEnc2 requires OggEnc2.exe/VorbisGain.exe.
REM **
REM ** I prefer applying album gain 92dB to get a reasonable
REM ** volume for my DAP. The RG tags are still relative
REM ** to 89dB SPL, i.e. album gain will be about -3.0dB.


REM ============== Begin Main Script ==================


IF @Debug@==1 ECHO ON

REM ** Workaround for multi-processing, added by nago.
ECHO > processing[@track@].tmp

REM ** Create Disc-related tags if we have a set

SET discNumberInPath=0

REM ** Ensure that we have numeric values
SET /A discNumber = @discnumber@ + 0
SET /A totalDiscs = @totaldiscs@ + 0

REM ** If a valid disc number and total number of discs has been provided
IF %totalDiscs% LEQ 1 GOTO :end_discnumber
IF %discNumber% LEQ 0 GOTO :end_discnumber

    REM ** Set tagging switches
    SET Disc_Flac=-T "discnumber=@discnumber@" -T "totaldiscs=@totaldiscs@"
    SET Disc_Wavpack=-w "discnumber=@discnumber@" -w "totaldiscs=@totaldiscs@"
    SET Disc_MP3=--frame TPOS:"@discnumber@/@totaldiscs@"
    SET Disc_NeroAac=--disk "@discnumber@/@totaldiscs@"
    SET Disc_OggEnc2=-c "discnumber=@discnumber@" -c "totaldiscs=@totaldiscs@"
    SET Disc_Tak=-t "discnumber=@discnumber@" -t "totaldiscs=@totaldiscs@"

    REM ** Add disc number to folder path
    SET trackDir=%trackDir%\Disc @discnumber@
SET discNumberInPath=1

:end_discnumber

REM ** If a disc name has been provided
IF "@discname@" EQU "" GOTO end_discname
SET discName=discname
SET discName=@%discname%@
IF "@discname@" EQU "%discName%" GOTO end_discname

    REM ** Set tagging switches
    SET Disc_Flac=%Disc_Flac% -T "discname=@discname@"
    SET Disc_Wavpack=%Disc_Wavpack% -w "discname=@discname@"
    SET Disc_MP3=%Disc_MP3% --frame "TXXX[setsubtitle]:@discname@"
    SET Disc_OggEnc2=%Disc_OggEnc2% -c "discname=@discname@"
    SET Disc_Tak=%Disc_Tak% -t "discname=@discname@"

    REM ** Add disc name to folder path
IF %discNumberInPath%==0 SET trackDir=%trackDir%\$discname$
IF %discNumberInPath%==1 SET trackDir=%trackDir% ($discname$)

:end_discname


SET TrackDir_Flac="@TrackDir_Flac@%trackDir%"
SET TrackDir_Wavpack="@TrackDir_Wavpack@%trackDir%"
SET TrackDir_MP3="@TrackDir_MP3@%trackDir%"
SET TrackDir_AAC="@TrackDir_AAC@%trackDir%"
SET TrackDir_OGG="@TrackDir_OGG@%trackDir%"
SET TrackDir_Tak="@TrackDir_Tak@%trackDir%"


SET TrackName=@trackname@

SET have_cover=0
SET embed_cover=0

IF EXIST "@cover@" (
    SET have_cover=1
    SET embed_cover=@EmbedCover@
)



REM ---- Track ----


IF NOT @Flac@==1 GOTO end_flac_tracks
    IF NOT EXIST %TrackDir_Flac% MKDIR %TrackDir_Flac%
    PUSHD %TrackDir_Flac%
        IF @various@==1 SET VA_tag=-T "album artist=@VA@"
        IF %embed_cover%==1 SET Cover_tag=--picture="|image/jpeg|||@cover@"
        ECHO ON
        @tools@\flac.exe @Opt_Flac@ %Cover_tag% %VA_tag% %Disc_Flac% -T artist="@artist@" -T album="@album@" -T tracknumber="@track@/@numtracks@" -T title="@title@" -T date="@year@" -T genre="@genre@" -T comment="@comment@" -T encoded-by="%USERNAME%" -T encoding="Flac @Ver_Flac@ @Opt_Flac@" "@source@" -o "%TrackName%.flac"
        @ECHO OFF
        SET trackCueFile="$cdartist$ - $album$.cue"
        IF NOT EXIST %trackCueFile% (
            COPY "@albumfile@.[mg].cue" %trackCueFile%
            ECHO CHCP 1252 ^| PROMPT>>update-cuesheet.bat
        )
        ECHO @tools@\GSAR.EXE "-s@basename@.wav" "-r%TrackName%.flac" -o %trackCueFile%>>update-cuesheet.bat
        IF @Debug@==1 ECHO ON
        IF %have_cover%==1 IF NOT EXIST folder.jpg COPY "@cover@" folder.jpg
    POPD
:end_flac_tracks


IF NOT @Wavpack@==1 GOTO end_wavpack_tracks
    IF NOT EXIST %TrackDir_Wavpack% MKDIR %TrackDir_Wavpack%
    PUSHD %TrackDir_Wavpack%
        IF @various@==1 SET VA_tag=-w "album artist=@VA@"
        ECHO ON
        @tools@\wavpack.exe @Opt_Wavpack@ %VA_tag% %Disc_Wavpack% -w artist="@artist@" -w album="@album@" -w track="@track@/@numtracks@" -w title="@title@" -w year="@year@" -w genre="@genre@" -w comment="@comment@" -w encodedby="%USERNAME%" -w encodersettings="Wavpack @Ver_Wavpack@ @Opt_Wavpack@" "@source@" "%TrackName%.wv"
        @ECHO OFF
IF @Debug@==1 ECHO ON
        IF %have_cover%==1 IF NOT EXIST folder.jpg COPY "@cover@" folder.jpg
        TITLE @track@/@numtracks@ - "@album@"
    POPD
:end_wavpack_tracks


IF NOT @Tak@==1 GOTO end_tak_tracks
    IF NOT EXIST %TrackDir_Tak% MKDIR %TrackDir_Tak%
    PUSHD %TrackDir_Tak%
        IF @various@==1 SET VA_tag=-t "album artist=@VA@"
        ECHO ON
        @tools@\takc.exe -e -overwrite @Opt_Tak@ "@source@" "%TrackName%.tak"
        @tools@\tag.exe %VA_tag% %Disc_Tak% -t artist="@artist@" -t album="@album@" -t track="@track@/@numtracks@" -t title="@title@" -t year="@year@" -t genre="@genre@" -t comment="@comment@" -t encodedby="%USERNAME%" -t encodersettings="TAK @Ver_Tak@ @Opt_Tak@" "%TrackName%.tak"
        @ECHO OFF
IF @Debug@==1 ECHO ON
        IF %have_cover%==1 IF NOT EXIST folder.jpg COPY "@cover@" folder.jpg
        TITLE @track@/@numtracks@ - "@album@"
    POPD
:end_tak_tracks


IF NOT @LameMP3@==1 GOTO end_lame_tracks
    IF NOT EXIST %TrackDir_MP3% MKDIR %TrackDir_MP3%
    PUSHD %TrackDir_MP3%
        IF @various@==1 SET VA_tag=--frame "TXXX[album artist]:@VA@" --frame "TPE2:@VA@"
        IF %embed_cover%==1 SET Cover_tag=--frame "APIC{3}:@cover@"
        ECHO ON
        @tools@\lame.exe @Opt_LameMP3@ "@source@" "%TrackName%.mp3"
        @tools@\metamp3.exe %Cover_tag% %VA_tag% %Disc_MP3% --artist "@artist@" --album "@album@" --track @track@/@numtracks@ --title "@title@" --year "@year@" --genre "@genre@" --comment "@comment@" --frame TENC:"%USERNAME%" --frame TSSE:"LAME @Ver_LameMP3@ @Opt_LameMP3@" "%TrackName%.mp3"
        @ECHO OFF
IF @Debug@==1 ECHO ON
        IF %have_cover%==1 IF NOT EXIST folder.jpg COPY "@cover@" folder.jpg
    POPD
:end_lame_tracks


IF NOT @iTunesAac@==1 GOTO end_itunes_aac_tracks
    IF NOT EXIST %TrackDir_AAC% MKDIR %TrackDir_AAC%
    PUSHD %TrackDir_AAC%
        IF %embed_cover%==1 SET Cover_tag=-r "@cover@"
        ECHO ON
        @tools@\iTunesEncode.exe @Opt_iTunesAac@ -e "AAC Encoder" %Cover_tag% -x @various@ -a "@artist@" -l "@album@" -n "@track@" -m "@numtracks@" -t "@title@" -y "@year@" -g "@genre@" -c "@comment@" -i "@source@" -o "%TrackName%.m4a"
        @ECHO OFF
IF @Debug@==1 ECHO ON
        IF %have_cover%==1 IF NOT EXIST folder.jpg COPY "@cover@" folder.jpg
    POPD
    GOTO end_nero_aac_tracks
:end_itunes_aac_tracks


IF NOT @NeroAac@==1 GOTO end_nero_aac_tracks
    IF NOT EXIST %TrackDir_AAC% MKDIR %TrackDir_AAC%
    PUSHD %TrackDir_AAC%
        IF @various@==1 SET VA_tag=--albumArtist "@VA@" --compilation true
        IF %embed_cover%==1 SET Cover_tag=--artwork "@cover@"
        ECHO ON
        @tools@\neroAacEnc.exe @Opt_NeroAac@ -if "@source@" -of "%TrackName%.m4a"
        @tools@\AtomicParsley.exe "%TrackName%.m4a" -o REACT_tmp.m4a %Cover_tag% %VA_tag% %Disc_NeroAac% --artist "@artist@" --album "@album@" --tracknum "@track@/@numtracks@" --title "@title@" --year "@year@" --genre "@genre@" --comment "@comment@" --encodingTool "neroAacEnc @Ver_NeroAac@ @Opt_NeroAac@"
        @ECHO OFF
IF @Debug@==1 ECHO ON
        MOVE /Y REACT_tmp.m4a "%TrackName%.m4a"
        IF %have_cover%==1 IF NOT EXIST folder.jpg COPY "@cover@" folder.jpg
    POPD
:end_nero_aac_tracks


IF NOT @OggEnc2@==1 GOTO end_oggenc_tracks
    IF NOT EXIST %TrackDir_OGG% MKDIR %TrackDir_OGG%
    PUSHD %TrackDir_OGG%
        IF @various@==1 SET VA_tag=-c "album artist=@VA@"
        ECHO ON
        @tools@\oggenc2.exe @Opt_OggEnc2@ %VA_tag% %Disc_OggEnc2% -c artist="@artist@" -c album="@album@" -c tracknumber="@track@/@numtracks@" -c title="@title@" -c date="@year@" -c genre="@genre@" -c comment="@comment@" -c encoded-by="%USERNAME%" -c encoding="OggEnc @Ver_OggEnc2@ @Opt_OggEnc2@" "@source@" -o "%TrackName%.ogg"
        @ECHO OFF
IF @Debug@==1 ECHO ON
        IF %have_cover%==1 IF NOT EXIST folder.jpg COPY "@cover@" folder.jpg
    POPD
:end_oggenc_tracks


REM ** Delete the source .wav
DEL "@source@"

REM ** More multiprocessing workaround --nago
DEL processing[@track@].tmp


REM ---- Post-processing ----


REM ** Scan and compute ReplayGain and add cover picture for supported formats.
REM ** NB: The following will only work if at least the last track is selected.

IF NOT @track@==@numtracks@ GOTO end_post_process

    REM ** More multiprocessing. Last edit. --nago
    :checktmp
    IF NOT EXIST processing[*].tmp GOTO allProcsClear
      ECHO Waiting for all other processes to clear...
      ECHO If REACT hangs here and there are no other tracks being encoded,
      ECHO please delete all processing[#].tmp files in
      ECHO "@sourcedir@"
      PING 1.1.1.1 -n 1 -w 10000 >NUL
    GOTO checktmp
    :allProcsClear

REM ** Ensure that the EAC log is available
:CheckForLog
IF NOT EXIST "@eaclog@" GOTO Pause

    SET add_rg=@ReplayGain@
    SET aac_enc=@NeroAac@
    IF @iTunesAac@==1 SET aac_enc=1

    IF NOT @ReplayGain@==1 GOTO end_RG
        SET RG_MetaFlac=--add-replay-gain
        SET RG_MetaMP3=--replay-gain
    :end_RG

    IF NOT @ApplyAlbumGain@==1 GOTO end_apply_AG
        SET RG_MetaMP3=--apply-gain album@AdjustAlbumGain_dB@
        SET RG_AacGain=/a /o /c /d @AdjustAlbumGain_dB@
        SET add_rg=1
    :end_apply_AG


    REM ** Audio Formats:

    IF @Flac@==1 (
        PUSHD %TrackDir_Flac%
            IF %add_rg%==1 @tools@\Glob.exe -v -c @tools@\metaflac.exe %RG_MetaFlac% *.flac
            REM COPY /Y "@eaclog@" "EAClog.txt"
            @tools@\GSAR.EXE -s%% -r%%%% -o update-cuesheet.bat
            CALL update-cuesheet.bat
            DEL update-cuesheet.bat
        POPD
    )

    IF @Wavpack@==1 (
        PUSHD %TrackDir_Wavpack%
            IF %add_rg%==1 @tools@\wvgain.exe -a *.wv
            REM COPY /Y "@eaclog@" "EAClog.txt"
        POPD
    )

    IF @LameMP3@==1 (
        PUSHD %TrackDir_MP3%
            IF %add_rg%==1 @tools@\Glob.exe -v -c @tools@\metamp3.exe %RG_MetaMP3% *.mp3
            REM COPY /Y "@eaclog@" "EAClog.txt"
        POPD
    )

    IF %aac_enc%==1 (
        PUSHD %TrackDir_AAC%
            IF %add_rg%==1 @tools@\aacgain.exe %RG_AacGain% *.m4a > "gainlog.txt"
            REM COPY /Y "@eaclog@" "EAClog.txt"
        POPD
    )

    IF @OggEnc2@==1 (
        PUSHD %TrackDir_OGG%
            IF %add_rg%==1 @tools@\vorbisgain.exe -a *.ogg
            REM COPY /Y "@eaclog@" "EAClog.txt"
        POPD
    )


    REM ** Cleanup

    DEL "@eaclog@"
    DEL "@albumfile@.[*].cue"
    DEL "@cover@"

:end_post_process


REM ================ End Main Script ===================


IF @Debug@==1 (
    PAUSE
    EXIT
)

REM ** Delete this .bat file:
DEL %0 &EXIT


GOTO :EOF

REM ** Pause for 2000 milliseconds and return to :CheckForLog
:Pause
@ECHO Waiting for EAC log file...
PING 1.1.1.1 -n 1 -w 2000 >NUL
GOTO CheckForLog

REACT 2 Released

Reply #1743
Everything works perfectly!  Thanks for the help.

REACT 2 Released

Reply #1744
Phew! You're welcome. 

REACT 2 Released

Reply #1745
Hello!
Please excuse me if this has been answered before, but: How can I rip a CD creating single flac-files per track plus corresponding cue-sheet?
Or do you have a workaround for foobar, which always displays the cue-sheet (single tracks) plus the flac-image (whole cd) at the same time, when having both in the directory? I can exclude cue-sheets from showing up in foobar, but then I need the per-track flac-files.
Bye,
dag0

REACT 2 Released

Reply #1746
How can I rip a CD creating single flac-files per track plus corresponding cue-sheet?

I take it that it's the cuesheet part that you want to get working, right? You already know how to rip tracks with REACT, right? Ok, check this post, and specifically point 4.3. about Amending Cuesheet File References, that has also necessary changes to copy the generated cues to target folders. (NOTE! it works only in track mode)

Or do you have a workaround for foobar, which always displays the cue-sheet (single tracks) plus the flac-image (whole cd) at the same time, when having both in the directory? I can exclude cue-sheets from showing up in foobar, but then I need the per-track flac-files.

Is this question really connected to the first question? I've to admit that I don't fully understand. You have FLAC-image and a cuesheet, not FLAC tracks? And foobar shows it in some odd way that you don't like? Maybe you should ask in the foobar forum, I don't know much about it.

REACT 2 Released

Reply #1747
Hi!
Sorry for my broken english...  and thanks for your link to "amending cuesheet references". I'm trying to get this to work, but after ripping I only have the "update-cuesheet.bat" in my output-directory. During the rip I have a REACT.cue in my working-dir, but there never appears a "$cdartist$ - $album$.cue" nor in the working neither in the output dir.
The cleanup-process after replaygaining tries to delete a "$album$.cue" in the working-directory, which can't be found. debugging.txt says it has been moved to EAC.log (same dir) right at the beginning.

The flac-part in my REACT-track.cfg now looks like that after inserting the part mentioned in your link.

Code: [Select]
IF NOT @Flac@==1 GOTO end_flac_tracks
    IF NOT EXIST %TrackDir_Flac% MKDIR %TrackDir_Flac%
    PUSHD %TrackDir_Flac%
        IF @various@==1 SET VA_tag=-T "album artist=@VA@"
        IF %embed_cover%==1 SET Cover_tag=--picture="|image/jpeg|||@cover@"
        ECHO ON
        @tools@\flac.exe @Opt_Flac@ %Cover_tag% %VA_tag% %Disc_Flac% -T artist="@artist@" -T album="@album@" -T tracknumber="@track@/@numtracks@" -T title="@title@" -T date="@year@" -T genre="@genre@" -T comment="@comment@" -T encoded-by="%USERNAME%" -T encoding="Flac @Ver_Flac@ @Opt_Flac@" "@source@" -o "%TrackName%.flac"
        @ECHO OFF
        SET trackCueFile="$cdartist$ - $album$.cue"
        IF NOT EXIST %trackCueFile% (
        COPY "@albumfile@.[mg].cue" %trackCueFile%
        ECHO CHCP 1252 ^| PROMPT>>update-cuesheet.bat
)
        ECHO @tools@\GSAR.EXE "-s@basename@.wav" "-r%TrackName%.flac" -o %trackCueFile%>>update-cuesheet.bat
        IF @Debug@==1 ECHO ON
        IF %have_cover%==1 IF NOT EXIST folder.jpg COPY "@cover@" folder.jpg
    POPD
:end_flac_tracks

REACT 2 Released

Reply #1748
OK, I forgot to put the code for the execution of the "update-cuesheet.bat". Now this batch-file is deleted at the end, but I still have no cue-sheet. 

REACT 2 Released

Reply #1749
Sorry for the late reply. Have you amended your INI file "CreateCuesheet" setting to "CreateCuesheet=mg"? And just double-checking, did you remember to copy the GSAR application to "REACT\tools" folder as instructed in the wiki guide?

 
SimplePortal 1.0.0 RC1 © 2008-2020