Skip to main content
Topic: PP, Bug Report for 0.3 (Read 6370 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

PP, Bug Report for 0.3

[deleted]

PP, Bug Report for 0.3

Reply #1
you can just encode wavpack or shn to MA or flac.  i'm sure aac/mp4 support will appear eventually, but i don't know whether vqf would be worth the effort.

PP, Bug Report for 0.3

Reply #2
[deleted]

PP, Bug Report for 0.3

Reply #3
I'll abuse this thread to reduce clutter..

Space key can't be used as keyboard shortcut. Same with Return key, numpad Enter and probably some others.

PP, Bug Report for 0.3

Reply #4
Quote
you can just encode wavpack or shn to MA or flac.

Mmmph... some of us have enough archived SHNs that transcoding all of them would be a rather daunting task. Don't get me wrong; I really appreciate FLAC's ability to use OGG tags (very descriptive and user friendly), but when I want to listen to one specific show out of several thousands I don't necessarily want to have to transcode it to something else first!

    - M.

PP, Bug Report for 0.3

Reply #5
[I do not consider the first post as a bugreport, but since it's named so, I'll add some here]

1. changing resampler from fast mode and back (several times in a row) while playing something crashes foo bar.

2. on startup foobar has one thread. when playing it uses 5 (what for?). when you stop it, it still uses 2. when you press open it starts using 6 (if not playing, 9 if playing) and this does not drop down until fb is closed. and memory 'open' hogs is not released, too, I guess.

PP, Bug Report for 0.3

Reply #6
ok i'm looking into this.

about threads - FYI, fb2k has 1 (one) resident thread (that is the main thread), and creates 1 (one) thread for playback (which exits when you stop); even output code doesn't do its own multithreading (unlike all winamp output plugins i wrote). apparently win2k/xp directsound goes nuts with creating multiple threads, though i doubt if it has any user-notceable effects (except for scary numbers in task manager).

Quote
First, 1) I found a Ogg file that doesn't play properly here, that plays fine in Winamp and XMMS. It plays the first 30 seconds, then goes back to the start of the file and plays 25 seconds or so, and does it until it doesn't play anything at all, just eating up 100% of the CPU... I then have to kill the task. Other times on song change I get lockups as well! Would you like this file or files to debug?
can i have a look at this file ?

PP, Bug Report for 0.3

Reply #7
Just one minor request for FB2k 0.3 - an option to turn off the bitrate display. I find that I get paranoid when I see the bitrates for MP3 etc (often placebo sets in). A strange request I know, but it would be good if you can add this feature.

PP, Bug Report for 0.3

Reply #8
posted 0.3a (with new SDK), includes a bunch of hotfixes (SSRC crash in particular)

[edit] bitrate display is scripted using a hardcoded tagz string, i'll make it configurable later.

PP, Bug Report for 0.3

Reply #9
Just a small bug (also in version 0.3a):

when creating a shortcut (global or not) with the key "CTRL + / of the numeric keyboard) it is displayed as that in the 'key' edit box, but when I hit the Add button, the shortcut code is changed into "CTRL + =".

Special thing is probably that I'm using a belgium/french keyboard (azerty)


vha

PP, Bug Report for 0.3

Reply #10
Quote
about threads - FYI, fb2k has 1 (one) resident thread (that is the main thread), and creates 1 (one) thread for playback (which exits when you stop);

that's exactly how I thought it should be.
directsound, you say? so who's it connected with open dialog? ... ugh, noticed that it (+3 threads) happens to any program that uses open dialog under win2k.

btw, what's with AMF support in your foo_mod build? it does not work for me. and why looping is on? (it should be configurable in the future, of course, but OFF by default)

Quote
when creating a shortcut (global or not) with the key "CTRL + / of the numeric keyboard) it is displayed as that in the 'key' edit box, but when I hit the Add button, the shortcut code is changed into "CTRL + =".

for me, it's displayed as 'CTRL + /' (instead of 'CTRL + Num /').

PP, Bug Report for 0.3

Reply #11
What are you keyboard settings? mine are belgian-french (which is azerty)

PP, Bug Report for 0.3

Reply #12
Quote
Just a small bug (also in version 0.3a):

when creating a shortcut (global or not) with the key "CTRL + / of the numeric keyboard) it is displayed as that in the 'key' edit box, but when I hit the Add button, the shortcut code is changed into "CTRL + =".

Special thing is probably that I'm using a belgium/french keyboard (azerty)


vha

Somewhat weird that I can use CTRL-* as a global hotkey, where I can't use CTRL-/ or CTRL--. Peter, you should really figure out what causes this weird sh*t, because it kinda pisses me off

Keyboard layout: United States (International)
Language: Dutch

PP, Bug Report for 0.3

Reply #13
Might as well stick it in here.

Up'd to .3 and find my tags (particularly ID3v1 tracknumber) is not working. Ogg tags seem blown altogether.

FYI, Thanks.

PP, Bug Report for 0.3

Reply #14
posted 0.3b, should fix various memory-related problems (also reduce database memory usage with huge amounts of tags)

PP, Bug Report for 0.3

Reply #15
I have a problem with Next function,
it doesn't work right - it skips to the next song,
but when I press it again it goes back to previous one.
(I have 'Follow cursor' disabled, foobar2000 v0.3c)
Additionally a small memory leak happens when this bug occurs.
I've changed only because of myself.
Remember, when you quote me, you're quoting AstralStorm.
(read: this account is dead)

PP, Bug Report for 0.3

Reply #16
Yeh, "next" actually means "go to selected song". So when Follow Cursor is off, "next" doesn't actually mean "next" .

 

PP, Bug Report for 0.3

Reply #17
Another thing, foobar crashes sometimes, after this bug appears.
I've changed only because of myself.
Remember, when you quote me, you're quoting AstralStorm.
(read: this account is dead)

PP, Bug Report for 0.3

Reply #18
a lil 'bug':
in ver 0.3c - after pressing 'reset all' the volume will change to 0dB, but the display on the right bottom of the player will show the same number as set before reset.

------------------
p.s. some sort of simple peak meter would be nice - could replace the bitrate display in the gui - something that will show max peak for last n seconds - can be text display.
(edit: average bitrate could show up with playlist if wanted)
PANIC: CPU 1: Cache Error (unrecoverable - dcache data) Eframe = 0x90000000208cf3b8
NOTICE - cpu 0 didn't dump TLB, may be hung

PP, Bug Report for 0.3

Reply #19
Hi Peter,

It seems that there is a memory leak with the 0.3c (also with 0.3b) when using the resampling DSP    :

Crossfeed only:
Playing an MP3 file : foobar uses 3488 K memory all the time


With Crossfeed & resampler (48K, Fast mode)
Playing the same MP3 file
8096 K after 10 s playback
11 944K after 20 s playback
15 616 K after 30 s playback
... Crash after playback  of a few songs (not enough memory)

Cheers,

Marc

PP, Bug Report for 0.3

Reply #20
can't reprocude

PP, Bug Report for 0.3

Reply #21
because your dlls are from 0.3b ?

PP, Bug Report for 0.3

Reply #22
I'm unable to reproduce it too with the PC at work - Should be a DLL versions problem (thancks peter). I will do a clean reinstall to my home PC, I'm sure it should work 

Marc

PP, Bug Report for 0.3

Reply #23
Found a new bug:

If you right click on the tray icon and select "Pause" while a song is playing, the song will pause and a little check appears next to "Pause" in the menu.

If you go back into the menu and click "Play", the check disappears but the song does not play.  The only way to get the song to play again is to go back in and reclick "Pause".

- Agent 86

 
SimplePortal 1.0.0 RC1 © 2008-2019