Skip to main content
Topic: Logitech Multimedia Keys & Foobar2000 (Read 108997 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Logitech Multimedia Keys & Foobar2000

Reply #50
Well, Girder solved all my MMKB problems. (Arowana KB with Netropa software, you'r excused if you never heard of those)

Some things i found:

To have foobar respond when it is minimized: for each command, in the Target enable "Match invisible Tasks"

Wparm values for some of the most used foobar actions:

Lparm : 394682
Wparm :
40051 = Previous
40009 = Play
40044 = Pause
40010 = Stop
40011 = Next
40060 = Random song
40045 = Stop after current song
40008 = Exit foobar2000

The main trick to get volume control working (windows mixer master volume) seems to be to enter a big enough Step Size and to have a negative value for volume down (2621 and -2621 in my case).

Logitech Multimedia Keys & Foobar2000

Reply #51
I still don't understand how to get this to work. could you please be more specific, what command should I select (application command?), what do I have to check in settings in the target window?

Anyway, here is a tip how to get the mute key working:
Download the keyboardEX plugin, enable it in the settings (keyboard driver). Create a new group, call it 'OS-blocked keys'. Select the keyboard driver in its plugins tab, click settings. Click learn, hit the mute key, unclick learn. Create a new Eventstring for 'OS-blocked' keys. Right click it and select 'On open Girder'. Save your config and hit F5 (to get the key-blocking working).

Now, to get the mute key working (with OSD), do the following:
- Create a new toplevel group, name it 'Volume Mute'
- In this new toplevel group, create a new multigroup
- for this new multigroup, create 6 new commands and 1 eventstring (which must connect to the multigroup, not to a command... it took me nearly one hour to figure out what I had done wrong... )
- Name the 5th command 'Unmute'
- Name the 6th command 'Mute'
- Name the 1st command 'Check mute state'. Under OS tab, select 'Volume Mute toggle', click 'Volume', select your mastercontrol's mute entry. Make sure that 'Volume Mute toggle' is also enabled in this window. Click OK, step size = 0, check OSD and Register. Click apply.
- Name the 2nd command 'Mute state -> reg24'. Under Girder tab, select 'Variable manipulation script' and click Apply (that's important, if you don't click apply, girder won't remember this)
- Name the 3rd command 'Muted?'. Under Girder tab, select 'Check Reg.', Register = 24, Icon / Device should be '==0' (no quotes, 2x =). Note there are two browse buttons, both with 'name' before them. Click the upper one, and browse for the 'Unmute' command. Click the one on the bottom and browse for the 'Mute' command. Click apply.
- Name the 4th command 'Stop processing'. Under girder tab select 'Stop processing'. Click apply.
- The 5th command should already be named 'Umute'. Under OS tab, select 'Volume mute toggle', step size = 1. Click apply.
- The 6th command should already be named 'Mute'. Under OS tab, select 'Volume mute toggle'. Step size = -1. Click apply.
- Assign the mute key to your eventstring
There is a problem with this method, every time you mute your sound, the volume gets also minimized. If someone can figure this out
Always defragment your MP3s to avoid subtle lack in harmonics.

Logitech Multimedia Keys & Foobar2000

Reply #52
Quote
I found a strange bug on foobar format string.

I have a logitech keyboard internet navigator special edition and a sound blaster Audigy using kxdriver.

I do not use the logitech drivers for my multimedia keys , i use the kxdrivers for managing the multimedia keys.

So everything works fine BUT if i do not put  '['%_foobar2000_version%']' at the end of the main window title formatting my multimedia keys stop working.
If i put  '['%_foobar2000_version%']' at the end of the main window title formatting my multimedia keys go back working.

Is this a foobar bug ?

How exactly did you get this to work with the kX Project drivers. I use them too, so this would be the most interesting solution for me...

Logitech Multimedia Keys & Foobar2000

Reply #53
From the kx driver's menu (via system tray or on the mixer), go to settings and make sure the 'Multimedia Keyboard enabled' is checked.

Unload the iTouch software, if it is running.  Make sure your foobar2000 title bar contain foobar2000 (I appended this at the end w/o version number and it works; my title is %artist% - %title% - foobar2000).

W/o the foobar2000 in the titlebar, the kx mixer program does not detect it's presence (from what I can tell and as previously posted).

There's a hitch to the whole thing though.  It is a global hook as I can't control other media players w/ the keys when foobar2000 is running.

Oh, and you can turn on OSD in the kx settings too.

Logitech Multimedia Keys & Foobar2000

Reply #54
Making Girder commands for Foobar, a more extensive guide.
hopefully this does not contain show stopping errors, and will help you get started.

I have been using it for only one day now, but i found Girder to be a pretty darn neat piece of software. It can capture any keyboard or mouse event (and more if need be), and can convert those in pretty much any command that your windows platform allows, with just about all the configuration options one could imagine.

Disable your current MMKB configuration software (ie exit the systray app and disable startup with windows)

* Girder config:
File > Settings
General:
check "auto load" (the file that you'll create at the end of this thing)
(load Girder on windows startup, hide on startup)
Plugins:
check "auto enable input device"
in plugin list: check keyboard, send message
OK

* Preparations (Girder):
edit > add group
select the group folder you just created
edit > add command
(to rename: select group or command, edit > rename)

* Learn Girder the MMKB event:
click "learn event" (enabled, "all")
press the MM key to which you want to assign a command

* Creating and configuring the command
select the command in the list on the left,
command type tab: "Command"

click "Target":
disable "Send to foreground task"
enable "Match invisible Tasks"
enable "class name": FOOBAR2000_CLASS
enable "executable": foobar2000.exe
OK

(select the command)
Enter the WParm and LParm values for the foobar command:

Lparm : 394682 (typically the same for all commands)
Wparm :
40051 = Previous
40009 = Play
40044 = Pause
40010 = Stop
40011 = Next
40060 = Random

There are more, but these are pretty much guarantied to work. You can use "Capture" to explore and experiment.

(don't forget to properly assign Foobar as target for each command, copy/paste may come in handy)


* Other MM keys:
(put these in a seperate group "volume")

- Mute:
select the group folder
edit > add command (rename to "mute")
(select the command)
click "learn event" (enabled, "all")
press the mute key

(select the command)
command type tab "O.S."
select "Volume Mute Toggle"
click "Volume": your soundcard > Master-volume > Mastercontrols > Master Mute
OK
Step Size 0, Register no, OSD optional

- Master Volume up/down:
select the group folder "volume"
edit > add "Multi Group" (rename: "volume up")
select the group folder
edit > add multi group (rename: "volume down")

select multi group "volume up"
add command "volume up"
tab O.S.
select "Volume Change"
click "Volume": your soundcard > Master-volume > Mastercontrols > Master Volume
OK
Step Size 2621, Register no, OSD optional

select multi group "volume down"
add command "volume down"
tab O.S.
select "Volume Change"
click "Volume": your soundcard > Master-volume > Mastercontrols > Master Volume
OK
Step Size -2621, Register no, OSD optional

select multi group "volume up"
click "learn event" (enabled, "all")
press the volume up key

select multi group "volume down"
click "learn event" (enabled, "all")
press the volume down key

File > Save

done


Thanks to other contributers to this topic
and
online Girder help
http://www.girder.nl/
they offer a bunch of configuration files to download, very usefull to learn from.

PS
Play/Pause is indeed an elusive event. Parak's solution does not work for me.
For now I use Girder to hack my own play/pause command. i've made two commands with the same event (the play/pause key in my KB), using "state settings";
both have state count 2 and begin state 1, one has "execute on all states except 1" disabled and command Wparm 40044 (pause), the other has "execute on all states except 1" enabled and command Wparm 40009 (play).

To have a command run an application: command type "O.S.", select "Execute", enter path and filename, put command line parameters in "step size".

Logitech Multimedia Keys & Foobar2000

Reply #55
Quote
From the kx driver's menu (via system tray or on the mixer), go to settings and make sure the 'Multimedia Keyboard enabled' is checked.

Unload the iTouch software, if it is running.  Make sure your foobar2000 title bar contain foobar2000 (I appended this at the end w/o version number and it works; my title is %artist% - %title% - foobar2000).

W/o the foobar2000 in the titlebar, the kx mixer program does not detect it's presence (from what I can tell and as previously posted).

There's a hitch to the whole thing though.  It is a global hook as I can't control other media players w/ the keys when foobar2000 is running.

Oh, and you can turn on OSD in the kx settings too.

I see it works, but it doesn't when Foobar is minimized to tray. That's the one thing I'm having a problem with. When using Girder, it also works when Foobar is in background, but it doesn't when it's sent to tray. Any solution for this?

[Edit]
It's quite odd, but when adding the MM-keys to 'Keyboard Shortcuts' by just pressing the MM-key and then asign them to a global command, it does work when Foobar is sent to tray, but the key is identified by Foobar as 'G' or 'Q' or 'P' or 'J'. Does this lead to any conflicts?

Logitech Multimedia Keys & Foobar2000

Reply #56
@playerman: Awesome. Thank you and everyone else who contributed.
Always defragment your MP3s to avoid subtle lack in harmonics.

Logitech Multimedia Keys & Foobar2000

Reply #57
I can't get any of this to work either (I've tried everything).  And Girder, for some reason, reports the same code for every multimedia key that I press.  Any suggestions?

-Scott

Logitech Multimedia Keys & Foobar2000

Reply #58
I have to admit I am confused - is there a way to make fb2k 0.7.x work properly with the logitech drivers installed? I downloaded and tried girder several times over the years, but I just don't like the complexity of it and having yet another program in the tray.

It doesn't have to work with fb2k in the try, but with another window in focus.

thanks in advance 

edit:

nevermind. UNchecking Multimedia keyboard support and adding global hotkeys for whatever foobar dispays when pressing the MM keys works just fine if I disable iTouch.
HOWEVER: I have currently assigned the keyboard scroll wheel to "volume down" seeing how unnatural the volume keys are. With iTouch not running, this function is not available, and the scroll wheel acts like a normal scroll wheel. But the Volume down/up buttons still work
Therefore I was wondering if there's any way to make the scroll wheel adjust volume w/o iTouch running, as I have been using this key as my only volume control for ages and can't think of any other method that is this convenient

If anybody has any suggestions other than girder, please come forward 


Logitech Multimedia Keys & Foobar2000

Reply #60
Hello,

I'm using this line in the players.ini:

foobar2000=wac,foobar2000.exe,FOOBAR2000_CLASS,xxx,xxx,xxx,xxx,xxx,xxx,xxx,0,1,Foobar2000

Right, only xxx's - and it works perfect, even if foobar is minimized to the tray.

BTW, the same scheme works for Media Center / Media Jukebox. The only problem arises when you are running multiple players at the same time...

Logitech Multimedia Keys & Foobar2000

Reply #61
Quote
foobar2000=wac,foobar2000.exe,FOOBAR2000_CLASS,xxx,xxx,xxx,xxx,xxx,xxx,xxx,0,1,Foobar2000

Is that another thing that's broken by removing the windows class?

BTW it broke my remote control app, and now I cannot control foobar2000 with it 

Logitech Multimedia Keys & Foobar2000

Reply #62
Hi,

I'm sorry if it put any damage to your system. The line is adapted from other lines in the original players.ini file from Logitech which are intended for other players.
So I guessed it wouldn't be a "brutal" method or anything...

Logitech Multimedia Keys & Foobar2000

Reply #63
Quote
Hi,

I'm sorry if it put any damage to your system. The line is adapted from other lines in the original players.ini file from Logitech which are intended for other players.
So I guessed it wouldn't be a "brutal" method or anything...



Sorry about the confusions, I was not talking about your line, but about the foobar2000 window title - foobar2000_class. See the following topic for more details: http://www.hydrogenaudio.org/forums/index....showtopic=19095

Logitech Multimedia Keys & Foobar2000

Reply #64
yep, i got the same problem since 0.8 - i can't use my logitech keyboard to control foobar anymore. 
is there a workaround?

Logitech Multimedia Keys & Foobar2000

Reply #65
Anyone having a idea how I can change prev/fw buttons to perform Next in history/Previous in history actions? I changed the hotkeys to match my settings in players.ini, but that doesn't work.
I'm using foobar 0.8 and iTouch. All keys work, but I just want to change the action performed by these keys. Maybe it has to be done in foobars config cause in Prefs-keyboard shortcuts I see my mmkeys but can't chage their actions.


Logitech Multimedia Keys & Foobar2000

Reply #67
Quote
try girder (www.girder.nl)...
...and dump those itouch drivers.

But as I understood some posts here Girder doesn't work with all keys?

Logitech Multimedia Keys & Foobar2000

Reply #68
I tried Girder, but it doesn't receive any IR commands when I press one of my MM keys. It works with normal keys

Logitech Multimedia Keys & Foobar2000

Reply #69
I got the media controls working with itouch drivers. I used Winspy to get the fb2k main windows class, which is {DA7CD0DE-1602-45e6-89A1-C2CA151E008E} and used the following line in players.ini:

foobar2000=key,foobar2000.exe,{DA7CD0DE-1602-45e6-89A1-C2CA151E008E},xxx,xxx,X,C,V,Z,B,0,1,Foobar2000

Notice that I use the default winamp controls there.

To make foobar start when I press the play button I changed the Mediaplayer strings value in [HKEY_CURRENT_USER\Software\Logitech\iTouch\CurrentVersion] registry key to the foobar2000 executable path.

The controls stopped working in media player though (not a problem here. I never use the media keys with video players. And mplayer sucks anyways. Use VLC  ). They still work in Winamp. Odd. Probably something to do with the change of the registry key and/or the players.ini and the order of players in it.

EDIT: Forgot to add - this is with version 0.8

Logitech Multimedia Keys & Foobar2000

Reply #70
I just installed the latest version of iTouch in WinXP. Before that, I configured foobar to work with the MM-keys by making them global keys. After installation of iTouch, it still works perfectly, also when foobar is minimized to tray.

Adding
Quote
foobar2000=key,foobar2000.exe,{DA7CD0DE-1602-45e6-89A1-C2CA151E008E},xxx,xxx,X,C,V,Z,B,0,1,Foobar2000
f*cked that up completely though... Removed it, now working perfect again

Conclusion: a possible solution would be to disable iTouch temporary and setting up foobar global hotkeys, test this and after that test it when iTouch is started.

Using foobar2000 v0.8

Logitech Multimedia Keys & Foobar2000

Reply #71
I have a logitech internet navigator keyboard with latest itouch software, and foobar 0.8. All buttons (play/pause, stop, next etc...) work but not the volume slider, anyone have a clue why?

Logitech Multimedia Keys & Foobar2000

Reply #72
hmm, i'm using a multimedia keyboard from cherry. how can i use the multimediakeys with foobar? 

Logitech Multimedia Keys & Foobar2000

Reply #73
In Girder when I click "Learn Event" and then hit the button I wanna set it to, it does nothing...

I'm using a Viewsonic ViewMate Slim KBM KU 201

Logitech Multimedia Keys & Foobar2000

Reply #74
I don't know why, but I I don't need to use this!
I was surprised when I first got Foobar2000, but all of my keys work perfectly!
I have use generic media keys turned on, and am using the latest drivers for everything.

Logitech MX Duo on WIndows XP

Anyone know why this is?
Maybe I could help?

 
SimplePortal 1.0.0 RC1 © 2008-2019