Skip to main content
Topic: A new Foobar 0.9.2 & Multimedia Keyboard BUG? (Read 7702 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

A new Foobar 0.9.2 & Multimedia Keyboard BUG?

I have searched forum and notice the threads exist:
http://www.hydrogenaudio.org/forums/index....84&#entry214684

But It seems the new Foobar2000 0.9.2 now remove the Core property page in the preferences & support Multimedia Keyboard in default setting

It's great but I found the following Multimedia key (capture by MS Spy++) only work when Foobar was a active windows, i.e. it doesn't work in global:

<00001> 0003029A P WM_KEYUP nVirtKey:VK_MEDIA_PLAY_PAUSE cRepeat:1 ScanCode:22 fExtended:1 fAltDown:0 fRepeat:0 fUp:1
<00002> 0003029A P WM_KEYUP nVirtKey:VK_MEDIA_STOP cRepeat:1 ScanCode:24 fExtended:1 fAltDown:0 fRepeat:0 fUp:1
<00003> 0003029A P WM_KEYUP nVirtKey:VK_MEDIA_PREV_TRACK cRepeat:1 ScanCode:10 fExtended:1 fAltDown:0 fRepeat:0 fUp:1
<00004> 0003029A P WM_KEYUP nVirtKey:VK_MEDIA_NEXT_TRACK cRepeat:1 ScanCode:19 fExtended:1 fAltDown:0 fRepeat:0 fUp:1


Is it a bug or I miss something?
ps: I use Microsoft Multimedia Keyboards with IntelliType 5.5 in Windows XP SP2 chinese version.

A new Foobar 0.9.2 & Multimedia Keyboard BUG?

Reply #1
I do not use the microsoft keyboard but I am able to manage multimedia key support for my ITSG IK1052-RP without installing any drivers for the keybaord whatsoever. You may want to explore this approach and see if it will help you:

1. Access the Keyboard Shortcut configuration from Foobar> File> Preferences> General> Keyboard Shortcuts
2. Doublecheck the list to make sure your key is not already added, multimedia keys usually end in "(MM)"
3. Click the [Add New] Button, this will add an empty entry into the list
4. Click on the "Key" field at the bottom of the window, and press the key you wish to configure, such as >>.
- This should change "<unknown>" to "Next (MM)"
5. If you would like the key to control foobar even when foobar is minimized or your are in another program, check the box labeled "Global Hotkey"
6. Repeat the steps for any additional keys and click [Save All] at the bottom

If this does not work with your keyboard, sorry to waste your time.

A new Foobar 0.9.2 & Multimedia Keyboard BUG?

Reply #2
Thanks for response

I failed in step 4, pressed VK_MEDIA_PLAY_PAUSE but nothing happen in forbar2000 ( IntelliType start MS Media Player if it is not started)

Despite this bug, I decide continue to use forbar2000, it is efficient and output mp3 quality is much better than MS player.

A new Foobar 0.9.2 & Multimedia Keyboard BUG?

Reply #3
Yeah I use a logitech media keyboard, I found the drivers pointless, and windows default keyboard drivers accomodate for the standard media keys fairly well.
hi

A new Foobar 0.9.2 & Multimedia Keyboard BUG?

Reply #4
Yeah..
I try to bind the pause key, but when i press it foobar starts playing so its impossible to register at all. And its not in the list. No probs in 0.8

Thats just great..

A new Foobar 0.9.2 & Multimedia Keyboard BUG?

Reply #5
I failed in step 4, pressed VK_MEDIA_PLAY_PAUSE but nothing happen in forbar2000 ( IntelliType start MS Media Player if it is not started)


It sounds like intellitype is intercepting your keybaord calls. Do you need Intellitype, have you explored my previous directions without it?  Is there perhaps a wa to assign your key to the generic windows media functions instead of to launch or control a specific application?  Generally speaking I've found bundled keyboard drivers to cause more trouble than they help.

A new Foobar 0.9.2 & Multimedia Keyboard BUG?

Reply #6
yeah, I found what's wrong and at least we can bypass this BUG now!

Disable "minimize to tray icon" and let foobat2000 work as a normal windows so the local multimedia key will become global.

It seems in the notify area in XP, foobar can't receive the MM key message.

@musko
I guess foobar2000 0.9 already intergrated the MM key so no matter how hard your press, you can't bind a intergrated key ;-)

A new Foobar 0.9.2 & Multimedia Keyboard BUG?

Reply #7
did 0.92 better using than 0.91?
wonderful!!!!!!!!!!
vondafone!!!!!!!!!!
vodafone!!!!!!!!!!!!

A new Foobar 0.9.2 & Multimedia Keyboard BUG?

Reply #8
Ara..I tried disabling the systray part of Foobar and it still doesn't work. The only time Foobar will acknowledge my multimedia keys working is when its in the foreground. The moment I put a window in front of it it doesn't respond to the keys.

Edit: lol noticied something strange. I turned back the tray stuff. And when I right click the tray icon it so it shows the context menu the multimedia keys will be recognized when I press them. Though the moment I click off the context menu they don't work anymore.

A new Foobar 0.9.2 & Multimedia Keyboard BUG?

Reply #9
If you have Logitech keyboards, install this http://www.ida.net/users/oe1k/uberOptions/ !!

It works wonders  I use it to remap my multimedia keys to keyboard shortcut's. In foobar I just make the shortcut's global and hotkey's work all the time

A new Foobar 0.9.2 & Multimedia Keyboard BUG?

Reply #10
Yeah I've done that before. Problem is it disables all my other media players (like VLC). Unless there's a way to change it for each so VLC and all recognize the same command as play/pause.

Or maybe an AutoHotKey script that intercepts the signal and translates it..

A new Foobar 0.9.2 & Multimedia Keyboard BUG?

Reply #11
yeah, I found what's wrong and at least we can bypass this BUG now!

Disable "minimize to tray icon" and let foobat2000 work as a normal windows so the local multimedia key will become global.

It seems in the notify area in XP, foobar can't receive the MM key message.

@musko
I guess foobar2000 0.9 already intergrated the MM key so no matter how hard your press, you can't bind a intergrated key ;-)


Is there a way to globalise the integrated mm keys then?

A new Foobar 0.9.2 & Multimedia Keyboard BUG?

Reply #12
A response/solution from another forum:

Unparagoned says:
Quote
Hi, I found a solution to a problem some of you may have faced as well. The multimedia keys on my microsoft natural pro keyboard did not work when foobar was minimised. To fix this, close itype.exe, now you can go to preferences and go to keyboard shortcuts, and now foobar will be able to recognise the multimedia buttons, so assign them to the the right ones, check the global hotkey button. Now even with itype.exe running, the multimedia keys will work with foobar minimised.

A new Foobar 0.9.2 & Multimedia Keyboard BUG?

Reply #13
yeah, I found what's wrong and at least we can bypass this BUG now!

Disable "minimize to tray icon" and let foobat2000 work as a normal windows so the local multimedia key will become global.

It seems in the notify area in XP, foobar can't receive the MM key message.


I get this problem too. Is this a bug? Media buttons work fine when foobar2000 is minimized to the taskbar, but they stop working when minimized to the notification area.

A new Foobar 0.9.2 & Multimedia Keyboard BUG?

Reply #14
A response/solution from another forum:

Unparagoned says:
Quote
Hi, I found a solution to a problem some of you may have faced as well. The multimedia keys on my microsoft natural pro keyboard did not work when foobar was minimised. To fix this, close itype.exe, now you can go to preferences and go to keyboard shortcuts, and now foobar will be able to recognise the multimedia buttons, so assign them to the the right ones, check the global hotkey button. Now even with itype.exe running, the multimedia keys will work with foobar minimised.


Yes. It helps.

A new Foobar 0.9.2 & Multimedia Keyboard BUG?

Reply #15
A response/solution from another forum:

Unparagoned says:
Quote
Hi, I found a solution to a problem some of you may have faced as well. The multimedia keys on my microsoft natural pro keyboard did not work when foobar was minimised. To fix this, close itype.exe, now you can go to preferences and go to keyboard shortcuts, and now foobar will be able to recognise the multimedia buttons, so assign them to the the right ones, check the global hotkey button. Now even with itype.exe running, the multimedia keys will work with foobar minimised.



this worked for me, thanks!

 
SimplePortal 1.0.0 RC1 © 2008-2020