Skip to main content
Topic: C++ Runtime Crash in Vista build 5381 (Read 17993 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

C++ Runtime Crash in Vista build 5381

Reply #25
I don't expect it matters much, but incase availability was the only thing stopping the devs this would clear up that issue.
As I already pointed out, it is neither the only nor the most important reason.

As far as good news go, Peter has a suspicion about a particular runtime function that might have a bug in Vista. He plans to add more specific error messages to test this theory in the next beta.

C++ Runtime Crash in Vista build 5381

Reply #26
disable the "execution prevention" system. adding foobar to the exception list will not do.

bcdedit.exe /set {current} nx AlwaysOff

reboot


I tried this with the latest version of foobar and it did not work.

But I did then try 0.8.3 and foobar now works.  Now I just need to figure out how to use this thing (where is the frickin' volume control?).

Thanks everybody!

C++ Runtime Crash in Vista build 5381

Reply #27
I tried this with the latest version of foobar and it did not work.
I can confirm that. As I'm currently under XP I cannot check it, but it may be related to one or more of the 3rd party components. Let me explain:

Before deactivating DEP I tried a fresh installation of foobar2000 0.9.2. It started properly but caused an error when trying to start playback. After deactivating DEP I only tried my old installation of the same version which had many 3rd party components installed. Now a crash occured during each start of the program. I will check on this later in more detail.

C++ Runtime Crash in Vista build 5381

Reply #28
Okay, the startup error doesn't occur when only stock components are loaded. But the playback error persists even when only minimal components are active (foo_input_std, foo_ui_std) and null output is used.

C++ Runtime Crash in Vista build 5381

Reply #29
glad i found this thread. i'm happy enough to use 0.83 & vista.  also the freedb tagger for 0.83 is much better than foo_freedb2 too....

C++ Runtime Crash in Vista build 5381

Reply #30
Sorry to dust off an old thread but I was playing around and it appears that Foobar2000 v0.9.3b3 (maybe even b1 & b2 I dunno I didnt test them) is working for me under Windows Vista, public Beta2 build 5384.

Foobar2000 v0.9.2 would crash any time I tried to access a file, but v0.9.3b3 appears to be working for me with the default configuration.

 

C++ Runtime Crash in Vista build 5381

Reply #31
[deleted]

C++ Runtime Crash in Vista build 5381

Reply #32
Just to throw in my 2 cents, Peter himself has done some fixes to make it works better on vista following some tests myself and other foobar IRC users performed. So far it seems to work rather well for all the components that were compiled since the SDK was updated (most official components).

I think it is admirable that the developer(s) even bothered to fix these issues now. Kudos.

C++ Runtime Crash in Vista build 5381

Reply #33
I found out for myself, that the "typical Vista crash" only happens, when I migrate my old configs to Vista. If I delete the index.dat file in the playlists folder, and let Foobar itself recreate it, I don't get any crash anymore.

Maybe this will help some of you.

I found out for myself, that the "typical Vista crash" only happens, when I migrate my old configs to Vista. If I delete the index.dat file in the playlists folder, and let Foobar itself recreate it, I don't get any crash anymore.

Maybe this will help some of you.

C++ Runtime Crash in Vista build 5381

Reply #34
Foobar doesn't crash for me but I get this error on startup everytime. "Bad Allocation"

Some songs also cause this error but it will then play them fine after displaying it.

Any ideas?

C++ Runtime Crash in Vista build 5381

Reply #35
That means some of your components weren't compiled with newer (Vista-supporting) SDK of foobar. Make sure you have the latest versions of your components. If the problems wont go away, Try removing them one by one to see which is the problematic one and ask the author to recompile it against the latest SDK.

 
SimplePortal 1.0.0 RC1 © 2008-2019