Skip to main content
Topic: CPU Usage in Foobar really excessive (Read 3096 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

CPU Usage in Foobar really excessive

Hey, I was listening to music while playing a game today and noticed choppiness in the game. Confused, because normally it runs great, I closed it and started looking around for the culprit. Foobar was using between 26-35% CPU load on my machine, which is running an Athlon XP 3800+. I turned off all the DSPs (only using the one equalizer) and watched as it hovered between 24 and 36% still.

I googled, didn't find anything immediately apparent - (Damn you metasyntactic variable names) and on the forums the main culprit seems to be trackinfo or DSPs.

I'm using 9.2 and was using 9.1 when I noticed. I'm listening to standard VBR Mp3s, nothing fancy or crazy.

Help me, forums!

CPU Usage in Foobar really excessive

Reply #1
Have the similar problem with 9.1. Ever since the update its been like that

CPU Usage in Foobar really excessive

Reply #2
Drat - I'm using musikCube in the meantime, but I hope there's a fix or idea out soon.

CPU Usage in Foobar really excessive

Reply #3
Hello,

I had the same exact problem and have it narrowed down to one of these three culprits:
albumart (foo_uie_albumart - version 0.164a)
trackinfo panel (foo_uie_trackinfo - version 0.8)
the standard spectrum analyser

*note* the versions are as listed in the components section of preferences (first item on menu)

I removed the panels from my Columns_UI Layout and my CPU usage went down and now is varying between 0-3%.

I'm running version 0.9.2 beta 4.

I'm sorry I'm lazy and don't feel like seeing which plugin it was, but I hope this helps.

EDIT: Sidenote - my first intuition was the DSPs, but that proved wrong.

The culprit is the Spectrum analyser - the larger you make it, the more CPU it uses. I made the window fairly large and watched the CPU usage jump to the 60-70% range

CPU Usage in Foobar really excessive

Reply #4
Hello,

I had the same exact problem and have it narrowed down to one of these three culprits:
albumart (foo_uie_albumart - version 0.164a)
trackinfo panel (foo_uie_trackinfo - version 0.8)
the standard spectrum analyser

*note* the versions are as listed in the components section of preferences (first item on menu)

I removed the panels from my Columns_UI Layout and my CPU usage went down and now is varying between 0-3%.

I'm running version 0.9.2 beta 4.

I'm sorry I'm lazy and don't feel like seeing which plugin it was, but I hope this helps.

EDIT: Sidenote - my first intuition was the DSPs, but that proved wrong.

The culprit is the Spectrum analyser - the larger you make it, the more CPU it uses. I made the window fairly large and watched the CPU usage jump to the 60-70% range


I figuerd that might be it, but I disabled the bloody thing and it was still behaving like this. I'll see about mucking with Columns_UI

CPU Usage in Foobar really excessive

Reply #5

Hello,

I had the same exact problem and have it narrowed down to one of these three culprits:
albumart (foo_uie_albumart - version 0.164a)
trackinfo panel (foo_uie_trackinfo - version 0.8)
the standard spectrum analyser

*note* the versions are as listed in the components section of preferences (first item on menu)

I removed the panels from my Columns_UI Layout and my CPU usage went down and now is varying between 0-3%.

I'm running version 0.9.2 beta 4.

I'm sorry I'm lazy and don't feel like seeing which plugin it was, but I hope this helps.

EDIT: Sidenote - my first intuition was the DSPs, but that proved wrong.

The culprit is the Spectrum analyser - the larger you make it, the more CPU it uses. I made the window fairly large and watched the CPU usage jump to the 60-70% range


I figuerd that might be it, but I disabled the bloody thing and it was still behaving like this. I'll see about mucking with Columns_UI

i am experimenting with trackinfo and they're using cpu, but just columns_UI with album list and columns playlist seem to not use more than 4% cpu

CPU Usage in Foobar really excessive

Reply #6
see this wiki article for tips regarding trackinfo performance.

CPU Usage in Foobar really excessive

Reply #7
see this wiki article for tips regarding trackinfo performance.


Um...I'm not using trackinfo, as noted in the first post, also that guide is immensely vague.

Use the speed test tool? "THE speed test tool?" Which one? There's no link or more info, for all I know I'm supposed to hook up a speedometer.

 

CPU Usage in Foobar really excessive

Reply #8
I tried to narrow it down and thought I managed to get it down to Columns_UI's sidebar, but apparently I was wrong.

Wow, just noticed something while posting this. Default UI uses up a lot too.

 
SimplePortal 1.0.0 RC1 © 2008-2020