Skip to main content
Topic: new asio component (Read 13380 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

new asio component

what is bit format of the new asio component? i saw  the bitdepth options are unavalible when choosing asio output and dither option is avalible. does that mean it is only 16bit?

Amit

new asio component

Reply #1
I have the same question. However since my card only supporst 24bit, I assume the ASIO output is not only 16bit

new asio component

Reply #2
The audio stream is converted (per channel) to the format reported by the driver.

new asio component

Reply #3
Thanks.  Everything works perfectly with my setup.

new asio component

Reply #4
The audio stream is converted (per channel) to the format reported by the driver.


neat .. ASIO makes all sounds sound like they're produced by a synthesizer.. mind telling me why?
(Using Creative X-Fi ExtremeMusic)
it's sort of cute, but i'm not sure if it's what i want to hear all day..
There's an echo thing involved in it, when i listen to sung pieces.. but it also deforms some of the lower/heavier vocals to the point where they crack a bit.
happens with all possible settings, and i don't have any 'odd' settings enabled in my x-fi software bundle, it's configured pretty much only with defaults

new asio component

Reply #5
thanks for the answer .

i have ESI juli@ soundcard. the plugin works only with the asio4all driver and not with the hardware asio driver.it cannot read the channel info when using the esi driver.

new asio component

Reply #6
Hmmmm,

I'm using both M-Audio Delta Dio 2496 (max 24bit, 96Mhz) & Apogee MiniDac (24bit, 192Mhz).

Added both of them fine in the ASIO device editor but when playing a track, the track plays but silently??? Tried all sort of mapping and can't hear the test signal too. Strange.

Moreover, the M-Audio is reported as 32bit while the Apogee is 16bit. Maybe someone can enlighten me on this?

new asio component

Reply #7
Hmmmm,

I'm using both M-Audio Delta Dio 2496 (max 24bit, 96Mhz) & Apogee MiniDac (24bit, 192Mhz).

Added both of them fine in the ASIO device editor but when playing a track, the track plays but silently??? Tried all sort of mapping and can't hear the test signal too. Strange.

Moreover, the M-Audio is reported as 32bit while the Apogee is 16bit. Maybe someone can enlighten me on this?

My M-Audio Revolution 5.1 doesn't work with 0.91's ASIO too (so does someone else's Emu0404).  Same problem as yours, plays silently with no error message.

About the 32-bit thing, my M-Audio Revolution 5.1 is reported as 32bit too, and I've always used 32-bit with it when I had Foobar 0.83 ASIO/Kernel Streaming with no problem.

new asio component

Reply #8
aha, I guess the funny thing is that it's not 32bit floating, which I can at least take it to mean that that is the player's output resolution but 32bit? My card is 24 bit and I can't change?

Why's the Apogee 16bit then?

Oh well. Guess we'll have to wait for later versions of ASIO to work for us.

new asio component

Reply #9
ASIO dll on 0.9.1.b1 works fine! I am using ASIO4ALL and a USB DAC. 

Tom

new asio component

Reply #10
ASIO4ALL is basically WDM Kernel-Streaming through the ASIO API. I would rather use Apogee's low latency drivers, that is if I can get them working haha. Great news for you though.

new asio component

Reply #11
Silent with Emu 1212m too.

new asio component

Reply #12
Where can one find this new ASIO dll?


new asio component

Reply #14

Where can one find this new ASIO dll?



Dito.  Could someone please post the link to the new asio.dll


http://www.foobar2000.org/beta/ and
http://www.foobar2000.org/beta/components.html (just so you won't post a follow-up with a 'i can't find it there', since clicking the totally obvious 'additional components' button was too much of a stretch as well)

anyway, as you might've guessed, not everything seems to be quite working yet.

new asio component

Reply #15
ASIO works fine with my Audiotrak Maya EX5 which is USB card. This card provides the ASIO driver which was made by Steinberg.

new asio component

Reply #16
Ok I think I sort of figured it out. The Apogee MiniDAC is working fine now at 24bit.

Firstly, the bitdept under "format" in the ASIO Virtual Device Editor is the ASIO resolution and not your soundcard bitdepth. Using Apogee's control panel, I can change it to 16, 24 or 32. I figured out the mapping and now the MiniDAC works fine.

M-Audio ASIO still plays silently though.

new asio component

Reply #17
I use the new asio component on my M-Audio FW410 Audio interface,the component can't work.

When foobar 0.9 playback music with ASIO, I only hear the noise

new asio component

Reply #18
I can confirm that the ASIO driver is not working with my Emu 0404, I don't get an error, just no sound.  I have tried all available port mappings.
-Mag

new asio component

Reply #19
The ASIO plug-in on 0.9.1.beta works fine with my Audigy 2 ZS Notebook! It has detected two ASIO devices of the sound card: one 16bit, another 32 bit.

new asio component

Reply #20
Works fine here with Creative Asio, Sound Blaster x-fi, 32 bits x channel.

Thanks,
Rozzo

new asio component

Reply #21
With my Audiotrak (ESI) ProDigy 7.1LT it almost hangs WinXP. The mouse movements becomes jerky and I even can't call Task Manager.

new asio component

Reply #22
with my 1212m, foobar2000 seems not load it, I cant see it in the component list, and I cant select any output device with asio.

however, after I change the name of the .dll into .old. restart foobar2000, foobar2000 told me that foo_out_asio is removed.....

it's kind of strange

  but I'm still happy about the development of the plugin.

Thank you
Dark, black, are my remembrances.
        All around me is dark.
        Dark, like, my soul.
        My soul is sad, she's bleeding.

new asio component

Reply #23
asio output works fine here (rme hdsp9632).



but i found one problem/bug:

- change the buffersize in your asio-driver-panel: sound stops in foobar. this (buffersize changes on the fly) were possible with otachan's asio-plugin for foobar 0.8.x!

new asio component

Reply #24
My Terratec DMX6 fire 24/96 has the same symptom. It plays only silence with the original Terratec ASIO driver.

The ASIO4ALL v.2.6 driver can produce audio with my Terratec card, but the sound is seriously distorded. The combination produces a constant crackling artifact.

I have tried all available configuration options. Foobar 0.83 with ASIO output 0.49 SSE2 (exe version) does not have these problems on this PC.


Win XP / Intel 865PE chipset / P4

 
SimplePortal 1.0.0 RC1 © 2008-2019