Skip to main content

Topic: TTA tagging issue (Read 1062 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • Kraeved
  • [*]
TTA tagging issue
Steps to reproduce:
1. Foobar2000 1.3.14.
2. Foo_Input_TTA 3.3 set to write APEv2 only.
3. Add some TTA-encoded album and try to capitalize some track’s title.

Actual: all tags of edited track are gone until “Tagging-Reload info from file” is pressed.
Expected: changed title is displayed right away.

Here is a screencast worth a thousand words.


  • kode54
  • [*][*][*][*][*]
  • Administrator
Re: TTA tagging issue
Reply #1
Code: [Select]
	if (size == filesize_invalid ||
size == _size) return;
_size = size;

Bug in the decoder: It won't re-read the tags if the file's size hasn't changed.

  • Kraeved
  • [*]
Re: TTA tagging issue
Reply #2
Bug in the decoder: It won't re-read the tags if the file's size hasn't changed.
I am a mere user without skills to alter sources and compile another binary.
Tried to contact TTA developers by e-mail with no luck.
What would you recommend me to do?
Perhaps you could save the day and present us the fixed version as a New Year gift? :3
  • Last Edit: 29 December, 2016, 12:37:32 AM by Kraeved

  • kode54
  • [*][*][*][*][*]
  • Administrator
Re: TTA tagging issue
Reply #3
Happy almost New Year, I've pushed an updated version to the official foobar2000 components repository, update check should find it.

  • Kraeved
  • [*]
Re: TTA tagging issue
Reply #4
I've pushed an updated version to the official foobar2000 components repository
Gratitude knows no bounds, Kode54, God bless you!

  • Kraeved
  • [*]
Re: TTA tagging issue
Reply #5
Another tagging issue popped up, now it is related to adding/removing pictures.
That is Foobar2000 says “attached picture operations not supported for this file format”.
Current workaround is to use 3rd party tagging apps such as MP3Tag or Tag&Rename.
But could we have this ability within Foobar2000, please?

Edit: example of TTA file with front cover attached by CueTools.
  • Last Edit: 05 January, 2017, 03:38:34 AM by Kraeved

  • Kraeved
  • [*]
Re: TTA tagging issue
Reply #6
Hello?

  • kode54
  • [*][*][*][*][*]
  • Administrator
Re: TTA tagging issue
Reply #7
I'll look into it.

  • Kraeved
  • [*]
Re: TTA tagging issue
Reply #8
Meow? :3

  • kode54
  • [*][*][*][*][*]
  • Administrator
Re: TTA tagging issue
Reply #9
Code: [Select]
static const char g_apetag_formats[] = "MPC;MP+;MPP;WV;APE;TAK";
Looks like either I'll have to rip out private code from the foobar2000 mobile project and duplicate it in this component, or ask that Peter add TTA to that extensions list that's part of the standard inputs component that also happens to implement the ID3 and APE tag code.

  • Peter
  • [*][*][*][*][*]
  • Administrator
Re: TTA tagging issue
Reply #10
foobar2000 code changed for the next update as suggested.