Skip to main content
Topic: Unable to play (Read 4615 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Unable to play

I am trying to play a 7.1,24bit,192khz,756kbps wav but foobar is reporting this error.

ERROR (foo_output_std) : The specified format is not supported or cannot be translated.  Use the Capabilities function to determine the supported formats.

Tried same file but with a lower frequency 96khz and played it fine.

Is there a way to solve this ?

Unable to play

Reply #1
I'd guess your soundcard doesn't have 192kHz playback capabilities. Try putting one of the resamplers in your DSP chain (PPHS or SSRC) and set the target sample rate to a sample rate that's actually supported by your soundcard.

(which soundcard do you have, anyway?)
A riddle is a short sword attached to the next 2000 years.

Unable to play

Reply #2
Could you please explain better what I should do.

Currently I have an SB Live soundcard (16bit).

Thanks

Unable to play

Reply #3
In Preferences, go to the Playback -> DSP Manager and make sure that either Resampler (SSRC) or Resampler (PPHS) is in the list of Active DSPs

then go to Playback -> DSP Manager -> Resampler or Playback -> DSP Manager -> Resampler (PPHS) (depending on which one you picked) and set the target sample rate to 48000Hz
A riddle is a short sword attached to the next 2000 years.

Unable to play

Reply #4
In addition to what ssamadhi97 are saying above, you should also make sure that under Preferences > Playback: Output you choose 16bit fixed-point as output format. SB Live! are hardcoded to 16bit 48kHz and for the optimal output quality you can possibly get from foobar2000 with this card you should set it to permanently using one of the resamplers (for which to choose look here) with a target of 48000Hz and 16bit fixed-point with strong ATH noise shaping dithering enabled. The downside of this is that both resampling and dithering will claim a chunk of CPU for a (theoretical) gain in audio quality that you will possibly never perceive. So depending on your CPU and speakers and such you must decide for yourself (you could do a search on ABX testing here on the forums to help you decide).
"ONLY THOSE WHO ATTEMPT THE IMPOSSIBLE WILL ACHIEVE THE ABSURD"
        - Oceania Association of Autonomous Astronauts

Unable to play

Reply #5
Actually I just want to test them on this pc, I would like to play these files on  a DVD/Audio standalone.

Still not sure if they will play.

BTW the settings you provided me are there from defualt exept for deithering.
The error is no longer being reported, the track plays but nothing is heard.

What else can I do?

Unable to play

Reply #6
Quote
Actually I just want to test them on this pc, I would like to play these files on  a DVD/Audio standalone.

Still not sure if they will play.

BTW the settings you provided me are there from defualt exept for deithering.
The error is no longer being reported, the track plays but nothing is heard.

What else can I do?
[{POST_SNAPBACK}][/a]

The important thing here will be to check that you do have one of (and only one  of) the resamplers in your active DSP's chain (left side row) with setting 48000Hz. You might want to put it first (on top) in the chain. Then ofcourse set output to 16bit fixed-point under Playback, witch it is, as you noted, by default. Then check volume settings in foobar, windowsmixer, cable connections and such...   
Well, hmmm.... Also you said it's 7.1. Maybe that's a problem? There is a "Convert 5.1 to stereo" in foobar DSP's. But I haven't seen any "Convert 7.1 to stereo" or "Downmix all channels to stereo" DSP. There is a "Downmix channels to mono", though. You could maybe try it just to see if you get sound???
How it would be with your DVD/Audio standalone I don't know anything about. You could ask in one of the [a href="http://www.hydrogenaudio.org/forums/index.php?showforum=63]hardware[/url] forums.
"ONLY THOSE WHO ATTEMPT THE IMPOSSIBLE WILL ACHIEVE THE ABSURD"
        - Oceania Association of Autonomous Astronauts

Unable to play

Reply #7
Well apparently the original poster tried a 7.1 96kHz file and found it to cause no problems..
A riddle is a short sword attached to the next 2000 years.

Unable to play

Reply #8
Quote
Well apparently the original poster tried a 7.1 96kHz file and found it to cause no problems..
[a href="index.php?act=findpost&pid=251816"][{POST_SNAPBACK}][/a]

Yes, you are right.... well, well, one are not always too observant... 

EDIT: Still, isn't that a bit strange? I had no problems in downsampling a 192kHz 32bit floating-point wav file to 48kHz 16bit fixed-point with fb2k, Resampler (PPHS) enabled. That was only a a stereo file though.... but if it works with a 96kHz file shouldn't it work with a 192kHz too, as the resampler handles it, or do the resampler act different on different samplerates with the same amount of channels???
"ONLY THOSE WHO ATTEMPT THE IMPOSSIBLE WILL ACHIEVE THE ABSURD"
        - Oceania Association of Autonomous Astronauts

Unable to play

Reply #9
Quote
What else can I do?
[a href="index.php?act=findpost&pid=251769"][{POST_SNAPBACK}][/a]

Did you try using the resampler dsp? What happened?

Have you tried using different output methods? (waveOut / DirectSound / Kernel Streaming)
A riddle is a short sword attached to the next 2000 years.

Unable to play

Reply #10
Quote
Did you try using the resampler dsp? What happened?

Have you tried using different output methods? (waveOut / DirectSound / Kernel Streaming)


I've tried the resampler dsb and the file played but with no sound.
Also tried using different output methods  and set my defualt card instead of wav, but stil lno sound.

Unable to play

Reply #11
which drivers do you use?
A riddle is a short sword attached to the next 2000 years.

Unable to play

Reply #12
Which drivers ?

My soundcard has all the latest drivers (sblive1024)98/2000.

Unable to play

Reply #13
Well I have a Live 1024 here as well and I can't reproduce your problem for the life of me. Actually I am completely unable to make playback of 8 channel wavs NOT work.

Sorry, doesn't look like I can help you here..

(for what it's worth, I'm using the default drivers that came with WinXP)
A riddle is a short sword attached to the next 2000 years.

Unable to play

Reply #14
Personally I like the kX Project drivers. Just mentioning it to provide an option. Also works perfectly with kernelstreaming, which is the foobar2000 output component I use.
"ONLY THOSE WHO ATTEMPT THE IMPOSSIBLE WILL ACHIEVE THE ABSURD"
        - Oceania Association of Autonomous Astronauts

Unable to play

Reply #15
Quote
Well I have a Live 1024 here as well and I can't reproduce your problem for the life of me. Actually I am completely unable to make playback of 8 channel wavs NOT work.

Sorry, doesn't look like I can help you here..


I think you haven't got the problem yet, normally the problem with soundcards delivers from frequency responses, if the source is eg. 192khz if there's improper resampling the souncard will decline the source since it can't handle that kind of frequency. On the other hand if you manually try resampling yourself and eventually lowering down the frequency to eg. 96khz the soundcard will accept the source and play. Therfore since foobar2000 gives the option of outputting the source to a set frequency that doesn't work at all.

Yes Dsp works but still not enough to feed the soundcard an appropriate frequency for playback.

Thanks

Unable to play

Reply #16
Regardless of whether the sound card actually supports the sample rate, which it definitely does not in this case, I think the true problem is the fact that pre-XP versions of the Kernel Mixer do not support such high sample rates. Even then, 98/2000 WDM drivers are not likely to support them either, considering the higher level limitations.

The Live! and Audigy cards are limited to 48KHz, so it's probably best to equip your choice of resampler DSPs and lock it at that. I've found that even the latest kmixer has an inaccurate resampler, which results in noticeably incorrect conversion ratios if you really stretch the difference. (For my example, forcing its output up to 192KHz with SSRC/PPHS resampler applied to a sub-11KHz file, then removing the resampler, which results in kmixer resampling taking over. The error results in noticeably incorrect pitch. Even with this bug, I still prefer kmixer for its automatic promotion to hardware-supported rates to accomodate the requested output rate, at least until I or somebody else bothers to implement a similar and more flexible system as a Foobar2000 DSP.)

Unable to play

Reply #17
Well I told that guy to use a resampler to 48kHz already, and he keeps claiming that it STILL doesn't work afterwards. ("I've tried the resampler dsb and the file played but with no sound.")

I wonder whether it's an issue with a pre-XP mixer version not being able to tackle 8 channel audio?
A riddle is a short sword attached to the next 2000 years.

Unable to play

Reply #18
So what can I do do play this audio file with that kind of frequency?

Unable to play

Reply #19
Quote
So what can I do do play this audio file with that kind of frequency?
[a href="index.php?act=findpost&pid=252375"][{POST_SNAPBACK}][/a]

Try reading what's been said already?
Quote
In Preferences, go to the Playback -> DSP Manager and make sure that either Resampler (SSRC) or Resampler (PPHS) is in the list of Active DSPs

then go to Playback -> DSP Manager -> Resampler or Playback -> DSP Manager -> Resampler (PPHS) (depending on which one you picked) and set the target sample rate to 48000Hz
[a href="index.php?act=findpost&pid=251672"][{POST_SNAPBACK}][/a]
"ONLY THOSE WHO ATTEMPT THE IMPOSSIBLE WILL ACHIEVE THE ABSURD"
        - Oceania Association of Autonomous Astronauts

 
SimplePortal 1.0.0 RC1 © 2008-2019