Skip to main content
Topic: Columns UI (Read 3743111 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: Columns UI

Reply #7275
I am unable to reproduce into NG a frame behaviour I had in CP.
Apparently all the settings are the same.
I checked and the padding in the same too.

This is what I had in CP


And this is what I get in NG


Thanks

Re: Columns UI

Reply #7276
I guess you had frame-top and frame-bottom set to the (unselected item) background colour? That should still be possible.
.

Re: Columns UI

Reply #7277
As usual, you were right.

Now my frame style looks right
Code: [Select]
$if(%_isplaying%,
$set_style(frame-top,1,$get(text-play))
$set_style(frame-bottom,1,$get(text-play)),
$set_style(frame-top,1,
$ifequal($mod(%_playlist_number%,2),0,
$get(back-even),$get(back-odd)))
$set_style(frame-bottom,1,
$ifequal($mod(%_playlist_number%,2),0,
$get(back-even),$get(back-odd)))
)

If you know a simpler way, please let me know.

Thanks.

Re: Columns UI

Reply #7278
To get rid of an old track info mod panel (steal the focus) I'm trying to use
an Item Details panel. It's ok but:

- if I put it in "current selection" mode, when I select a playing track the time doesn't count.
- if I put it in "current selection/playing item" I loose the follow cursor behaviour
- in "current selction" mode, if I click on the most part of the UI items (Tagger panel, History, etc)
the panel goes blank and stays like that until I click on a track. The previously selected track
is still shown as selected but the tagging scripts are not applied.
If it's up to you, is it possible to have the Item Details panel keep on showing the last selected track info
until one click on another track, please? And to show the time running even in current selection when selecting the playing item?
And also not to loose the selection so that the scripts can be applied without having to select the track again.

Have a look.
https://vimeo.com/263958930


Thanks.


Re: Columns UI

Reply #7279
I think it should be possible to get the time etc. in there when the playing track is manually selected. I'll have a look at that.

In terms of how the 'current selection' stuff behaves, I'm afraid it's difficult to change as it's managed by the foobar2000 core. (I assume you haven't noticed any difference there in the Default UI.) There is the alternative of using the 'playlist selection' options instead of the 'current selection' ones (though I appreciate that might not do what you want either).
.

Re: Columns UI

Reply #7280
Another annoying thing I noticed is that "item details" panel goes blank
if you click on the tab of another panel placed in a panel stack and you
have to click acaing on the already selected track to see its info.
Old track info mod didn't do that and also "panel stack splitter" doesn't do that
and keeps on showing the track info (both in follow cursor mode).

If it is possible, I ask you to have a look into this matter
and see if this "Item details" panel behaviour can be fixed.

Thanks for taking the time to listen.


Re: Columns UI

Reply #7281
Well track info mod follows the focused playlist item rather than the selection of the focused child window. The closest thing in Items details is the playlist selection mode.
.

Re: Columns UI

Reply #7282
To me, the only lacking thing is a way to hide the "live" playing time
(always tied to the now playing item) when the playing item is not selected
or, even better, a way to know if the selected track is playing or not.

And what about the items panel going blank when you click on another UI element
as I described? Is it unavoidable or intended or fixable?

Thanks.

Re: Columns UI

Reply #7283
I was hoping to create a column to show missing items in the library with a fn similar to foo_uie_panel_splitter like the $findfile fn.

Anything like this possible. Thanks.

Re: Columns UI

Reply #7284
Hi!

What's the state of Columns UI these days? I see lots of commits on github for this year and 2017, but no releases whatsoever. The latest is still from 2016.
Why is this? What is this about?

Re: Columns UI

Reply #7285
I just haven't released a new version yet, but as you may have seen there is a fair amount of changes pending release.

The next version will be 1.0.0 alpha 1. There are a few things I'd like to tidy up before releasing it, and I'd prefer for foobar2000 1.4 to be out of beta.

So you'll have have to wait a bit longer for a new release, but if you're curious enough there are compilation instructions in the repo's readme.
.

Re: Columns UI

Reply #7286
Will you implement logarithmic volume slider? Thanks

 

Re: Columns UI

Reply #7287
Just wondering if there's any known performance issues between CUI's spectrum analyzer and WASAPI playback. The audio is fine, but the spectrum analyser is extremely choppy when outputting to any WASAPI device. I seem to recall there being a fix for this.

Re: Columns UI

Reply #7288
Will you implement logarithmic volume slider? Thanks
Are you referring to the fact that -10 dB isn't halfway at the moment? I can certainly fix that.

Just wondering if there's any known performance issues between CUI's spectrum analyzer and WASAPI playback. The audio is fine, but the spectrum analyser is extremely choppy when outputting to any WASAPI device. I seem to recall there being a fix for this.
I'm not aware of anything, and I didn't observe anything odd from some quick tests locally. Are any other visualisations affected? Does it happen with all tracks? What version of the WASAPI output do you have?
.

Re: Columns UI

Reply #7289
I'm not aware of anything, and I didn't observe anything odd from some quick tests locally. Are any other visualisations affected? Does it happen with all tracks? What version of the WASAPI output do you have?

WASAPI is v3.3
CUI is v0.5.1

Actually, I've just found that the issue seems to occur specifically with WASAPI event mode. Push mode seems to be ok, but push is somewhat unreliable with my hardware. Also, I created a new f2k profile with nothing but CUI and WASAPI, and the analyzer runs perfectly in either event or push mode, so its definitely something in my profile doing it. I'm actually puzzled because I'm not using any other visualizations or DSP's. Now that I know this I'm going to spend some tomorrow and figure it out. I'll let you know what I find out :D

Re: Columns UI

Reply #7290
Are you referring to the fact that -10 dB isn't halfway at the moment? I can certainly fix that.
Actually I was referring to this issue (not opened by me), but yeah, that would be nice if that could be fixed (didn't realize that before :) ). Thank you.

 
SimplePortal 1.0.0 RC1 © 2008-2018