Skip to main content
Topic: Wavpack APEv2 tags in winamp (Read 2162 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Wavpack APEv2 tags in winamp

The wavpack winamp plugin seems to have some problems reading "not-so-common" characters in APEv2 tags (don't know about ID3). So far, it was unable to properly display punctuated characters ( ú -> ú; á -> Ãi). The GodFather tags them perfectly, and foobar2000 reads them perfectly, so the problem is not in the tags themselves.
It'd be nice if bryant or someone else could have a look at this.

Thanks

Btw, the plugin i'm using is "Wavpack Player v2.0 (x86) [in_wv.dll]. I believe this is the latest.

Wavpack APEv2 tags in winamp

Reply #1
Quote
The wavpack winamp plugin seems to have some problems reading "not-so-common" characters in APEv2 tags (don't know about ID3). So far, it was unable to properly display punctuated characters ( ú -> ú; á -> Ãi). The GodFather tags them perfectly, and foobar2000 reads them perfectly, so the problem is not in the tags themselves.
It'd be nice if bryant or someone else could have a look at this.

Thanks

Btw, the plugin i'm using is "Wavpack Player v2.0 (x86) [in_wv.dll]. I believe this is the latest.
[a href="index.php?act=findpost&pid=236682"][{POST_SNAPBACK}][/a]

It seems like Winamp's UTF-8 support is broken. Could be also a conversion bug in the plugin, though.
edit: added that the plugin could be buggy too.
Stupidity is root of all evil.

Wavpack APEv2 tags in winamp

Reply #2
Yes, this is a bug in the plugin and will be fixed in the next release. Thanks for letting me know.

 
SimplePortal 1.0.0 RC1 © 2008-2018