Skip to main content
Topic: link failure with .7 sdk (Read 3782 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

link failure with .7 sdk

I am trying to update my DSP plugin to the new .7 SDK, and I am getting the following when linking :

foobar2000_SDK.lib(service.obj) : error LNK2001: unresolved external symbol "public: virtual void __thiscall foobar2000_client::services_init(bool)" (?services_init@foobar2000_client@@UAEX_N@Z)
foobar2000_SDK.lib(service.obj) : error LNK2001: unresolved external symbol "public: virtual void __thiscall foobar2000_client::set_library_path(char const *,char const *)" (?set_library_path@foobar2000_client@@UAEXPBD0@Z)
foobar2000_SDK.lib(metadb_handle.obj) : error LNK2001: unresolved external symbol __imp__uSortStringCreate
foobar2000_SDK.lib(metadb_handle.obj) : error LNK2001: unresolved external symbol __imp__uSortStringCompare
foobar2000_SDK.lib(metadb_handle.obj) : error LNK2001: unresolved external symbol __imp__uSortStringFree
foobar2000_SDK.lib(console.obj) : error LNK2001: unresolved external symbol "char const * __cdecl core_api::get_my_file_name(void)" (?get_my_file_name@core_api@@YAPBDXZ)
Release/foo_oddcast.dll : fatal error LNK1120: 6 unresolved externals


any ideas as to what I'm missing ?

oddsock

 

link failure with .7 sdk

Reply #1
ok, I found some more info about this from the changelog (should have looked there first I suppose)

anyway, the foobar_client errors were resolved by adding the foobar_client_component.dsp to my project...

the others are apprarently part of the utf8api.dll, which I also then had to add to my project (there is a utf8api.dsp), although utf8api.dll requires pfc.lib, and after adding that to the link of utf8api, I could thus create utf8api.dll, and finally resolve the rest of my symbols...

not entirely sure how I was *supposed* to link all that in, but that's the way I did it, and now have my plugin built again...

oddsock

link failure with .7 sdk

Reply #2
Me too, I think. I get this:

INFO (CORE) : startup time: 551 ms
ERROR (CORE) : Failed to load DLL: foo_abx.dll, reason: Wrong version number; this component appears to have been built with outdated version of foobar2000 SDK and needs to be recompiled with newer version in order to load; please contact author of this component to obtain an updated version of this component.
ERROR (CORE) : Failed to load DLL: foo_albumlist.dll, reason: Wrong version number; this component appears to have been built with outdated version of foobar2000 SDK and needs to be recompiled with newer version in order to load; please contact author of this component to obtain an updated version of this component.
[further flood removed by moderation]

Sorry chaps but I'm totally lost. Help!!


auldyin


EDIT
I don't even know if this is the correct thread......................even more help!!!!!

link failure with .7 sdk

Reply #3
Quote
Me too, I think. I get this:

(...)

1. Please don't spam threads in developer forum with user questions.
2. How about you actually READ messages you've got ? You've simply installed 0.7 over your previous install, that's the problem.

link failure with .7 sdk

Reply #4
Quote
ok, I found some more info about this from the changelog (should have looked there first I suppose)

anyway, the foobar_client errors were resolved by adding the foobar_client_component.dsp to my project...

the others are apprarently part of the utf8api.dll, which I also then had to add to my project (there is a utf8api.dsp), although utf8api.dll requires pfc.lib, and after adding that to the link of utf8api, I could thus create utf8api.dll, and finally resolve the rest of my symbols...

not entirely sure how I was *supposed* to link all that in, but that's the way I did it, and now have my plugin built again...

oddsock

Yes, it is supposed to be that way. There should be a .DSW file included with the SDK, having all dependencies set up properly.

link failure with .7 sdk

Reply #5
Thanks for advice zZzZzZz.

However, being a user, who has no experience of "programming" I must admit that the error messages I got in no way indicated that "I had installed 7 over a previous version".......at least no to me!!

I do apologise for pasting all of the error messages into the thread. That was very very remiss.

auldyin

EDIT
Incidentally, I dont even know what an "SDK" is, and "recompiled with newer version in order to load" is even more of a mystery.

link failure with .7 sdk

Reply #6
Quote
Thanks for advice zZzZzZz.

However, being a user, who has no experience of "programming" I must admit that the error messages I got in no way indicated that "I had installed 7 over a previous version".......at least no to me!!

I do apologise for pasting all of the error messages into the thread. That was very very remiss.

auldyin

EDIT
Incidentally, I dont even know what an "SDK" is, and "recompiled with newer version in order to load" is even more of a mystery.

Hence you are in the wrong sub forum, go over to the help forum or the general forum.  This forum is for people who understand what those words mean....

link failure with .7 sdk

Reply #7
Hey Guys, I made a mistake and apologised twice. What am I supposed to do "bleed"?


Quote
Sorry chaps but I'm totally lost. Help!!


auldyin


EDIT
I don't even know if this is the correct thread......................even more help!!!!!


Quote
I do apologise for pasting all of the error messages into the thread. That was very very remiss.

link failure with .7 sdk

Reply #8
I think this thread can be closed. No point debating anything, and oddsock has already solved his plugin problem.

link failure with .7 sdk

Reply #9
Unfortunately, I have not solved mine.

auldyin

 
SimplePortal 1.0.0 RC1 © 2008-2019