Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: EAC won't detect CD's (Read 487 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

EAC won't detect CD's

Hello.
I have a problem with EAC. It won't for the life of me detect my CD's correctly.

When setting it up, it took around 7 CD's to get the AccurateRip configuration prompt to pop up.
After getting everything setup for some lossless rips, it just won't detect anything.
The first time I put a CD in after the configuration, it loaded me with a billion database prompts that just crashed the program.
This happened everytime it decided to detect my CD.

When inserting a CD, all it does is load a bit, and then give me a "Unknown Artist/Unknown Title" at the top.
I cannot at all get the tracklist thing to show up to rip the CD.
A few times when the database prompt has showed up, I've tried closing them to prevent a crash, however, it simply ended in a spam-fest of a million "violation error" prompts.
I cannot for the life of me get the database prompts to open anymore to take a screenshot, for some reason.

"Maybe it's your CD drive".
I highly doubt it. I've tried with multiple different CD's, and it plays fine and rips fine too with the standard Windows media player.
I've also tried with ASAPI and ASPI, but nothing really seemed to happen.

Currently on Windows 10.

Does anyone else have this problem? Anyone know how to fix it?

Re: EAC won't detect CD's

Reply #1
EAC > EAC Options > General tab > On unknown CDs (check)
automatically access online metadata database (select)
korth

Re: EAC won't detect CD's

Reply #2
EAC > EAC Options > General tab > On unknown CDs (check)
automatically access online metadata database (select)

Unfortunately, I already have those options turned on :/
I guess the problem is that it won't detetect the CD to the point where it will give me a tracklist that I can then rip :P

Re: EAC won't detect CD's

Reply #3
You pics show you're using the CUETools DB Metadata Plugin
Most of the plugins require .NET Framework 3.5 (should've been installed/enabled with EAC installation)
https://www.tenforums.com/tutorials/7247-turn-windows-features-off-windows-10-a.html

I can't tell what version of EAC you're using. Assuming v1.6, try switching the metadata provider to Built-in freedb engine and see if that works.
korth

Re: EAC won't detect CD's

Reply #4
You pics show you're using the CUETools DB Metadata Plugin
Most of the plugins require .NET Framework 3.5 (should've been installed/enabled with EAC)
https://www.tenforums.com/tutorials/7247-turn-windows-features-off-windows-10-a.html

I can't tell what version of EAC you're using. Assuming v1.6, try switching the metadata provider to Built-in freedb engine and see if that works.

Ah, I forgot to mention the version, but yes, it's v1.6.
.NET Framework 3.5 is also installed and turned on in the windows settings tab.

I just tried with freedb, and same results :/
Same goes with the third one, MusicBrainz.

 
SimplePortal 1.0.0 RC1 © 2008-2021