Skip to main content

Notice

If you are using a Hotmail or Outlook email address, please change it now, as Microsoft is rejecting all email from our service outright.
Topic: Multi-value field not seen as such (Read 540 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Multi-value field not seen as such

Checking tag consistency, noted that a number of multi-value fields* are being seen as single value (used $meta_num(field) to check).
* Defined as such in Preferences > Advanced > Display > Properties dialog > Multivalues fields
Selected a number of tracks with the same problem and the same two artists.
- Tried to re-write one track manually (removed ARTIST, then rewritten) - it started to be seen as a multi-value field.
- Tried to update another track with Masstagger (Format "ARTIST" using "%artist%") - it remained single value.

Questions:
1) How to correct a large number of tracks with fields that have this problem using Masstagger?
2) Noted that the manually edited track now displays in Columns_UI with comma instead of semicolon as separator - is there a way to keep the semicolon?



Re: Multi-value field not seen as such

Reply #1
Checking tag consistency, noted that a number of multi-value fields* are being seen as single value (used $meta_num(field) to check).
* Defined as such in Preferences > Advanced > Display > Properties dialog > Multivalues fields
Selected a number of tracks with the same problem and the same two artists.
- Tried to re-write one track manually (removed ARTIST, then rewritten) - it started to be seen as a multi-value field.
- Tried to update another track with Masstagger (Format "ARTIST" using "%artist%") - it remained single value.
Questions:
1) How to correct a large number of tracks with fields that have this problem using Masstagger?
2) Noted that the manually edited track now displays in Columns_UI with comma instead of semicolon as separator - is there a way to keep the semicolon?


Answer to question 1) above required experimentation, but was found.
Using Masstagger, added a command "Split "ARTIST" by ";" separator" - field became multi-value.
Any other method (Copy, Format, Guess) did not work.

Question 2) remains unanswered; will post it in 3r Part Plugins sub-board.

Re: Multi-value field not seen as such

Reply #2
For 2, use $meta_sep() -

Code: [Select]
$meta_sep(artist,'; ')

For 1, no need for masstagger - select tracks > right-click Properties > right-click Artist > Split Values.


 
SimplePortal 1.0.0 RC1 © 2008-2021