Skip to main content

Notice

If you are using a Hotmail or Outlook email address, please change it now, as Microsoft is rejecting all email from our service outright.
Topic: semicolon changes to comma in title column (Read 373 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

semicolon changes to comma in title column

foobar2000 1.6.2
Columns UI 1.6.0

I think an example best illustrates the issue:

TITLE tag:  IV. BourrĂ©e I; II
Columns UI script:  either %title% or $meta(title)
Result in playlist:  IV. BourrĂ©e I, II
That is: ";" character is being displayed as ",".

Afaik, older versions did not present the problem - I often use ";" in titles and never noticed such a change.

Re: semicolon changes to comma in title column

Reply #1
You entered the tag in a field that supports multiple values, and the default separator for multiple values is "; ". You can disable multi-value support for the TITLE tag in Advanced Preferences. The exact path escapes my memory.

Re: semicolon changes to comma in title column

Reply #2
You entered the tag in a field that supports multiple values, and the default separator for multiple values is "; ". You can disable multi-value support for the TITLE tag in Advanced Preferences. The exact path escapes my memory.
That was my first guess, but it seems the cause should be something else, since TITLE is not among my multi-value fields.
Advanced settings are as follows;

Re: semicolon changes to comma in title column

Reply #3
You can remove ; from split values at properties dialog of selected tracks by right click to desired field.
Note that multi value tags won't be split by ; if removed from split values.
foobar2000 plays music

Re: semicolon changes to comma in title column

Reply #4
You can remove ; from split values at properties dialog of selected tracks by right click to desired field.
Note that multi value tags won't be split by ; if removed from split values.
Thanks for the suggestion, but that would not work for me...
Fact is that I rely on ";" for multi-value fields (GENRE, COMPOSER, ARTIST, BAND, CONDUCTOR) and already have a very, very high number of items already tagged using the default separator.

I still really find it strange TITLE to be a hard-coded multi-value field; would swear that multi-value fields were only those defined in the list at Preferences > Advanced > Properties dialog > Multivalue fields

Re: semicolon changes to comma in title column

Reply #5
Well, it's possible to solve my "problem" using $meta_sep().

However, for the sake of better understanding the inner works of foobar2000, I would ask someone knowledgeable to clarify the questions below:

(TITLE below is ID3v2 TIT2)
1) Is the TITLE field multi-value by default?
2) In case (1) above is TRUE: if one defines a list of multi-value fields (Preferences > Advanced > Properties dialog > Multivalue fields) does TITLE continue to be a multi-value field even if it does not appear on the list?
3) In case (1) above is TRUE: is there some way to remove the multi-field property of TITLE globally?

Re: semicolon changes to comma in title column

Reply #6
I guess you are using CUI inline editing in Playlist View? I think that seems to be the issue. (I just tested to confirm - FB 1.6.2 + CUI 1.6.0 + MP3 ID3v2)

It works correctly for me in right-click track > Properties - adding a semi-colon in TITLE does not split the field. In other words the advanced preferences setting works as expected, and TITLE is not multi-value by default.

You could report it in the Columns UI thread.

Re: semicolon changes to comma in title column

Reply #7
I guess you are using CUI inline editing in Playlist View? I think that seems to be the issue. (I just tested to confirm - FB 1.6.2 + CUI 1.6.0 + MP3 ID3v2)

It works correctly for me in right-click track > Properties - adding a semi-colon in TITLE does not split the field. In other words the advanced preferences setting works as expected, and TITLE is not multi-value by default.

You could report it in the Columns UI thread.

Sure: 1.6.2 + CUI 1.6.0
In any case, the semicolon is changed to a comma in all situations...
Will follow your suggestion and post in the Columns UI thread.
Thank you.


Re: semicolon changes to comma in title column

Reply #9
It is indeed a CUI issue, but as far as I tested it, it's not a default behavior. The field is changed to multivalue only once you've run the "split values..." command from the properties dialog context menu. You can restore the single value, though, by removing the tag, saving the changes and then rewriting the tag. If you have too many tracks to do this manually, you can do it with masstagger: copy the title to a temporary field, remove the title, and than format the title tag from the temporary field using the $meta_sep() function. See the attached picture.
I'm late

 
SimplePortal 1.0.0 RC1 © 2008-2020