Skip to main content

Notice

If you are using a Hotmail or Outlook email address, please change it now, as Microsoft is rejecting all email from our service outright.
Topic: Dragonfly cobalt - Foobar doesn't set sampling rate automatically (Read 271 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Dragonfly cobalt - Foobar doesn't set sampling rate automatically

I'm using the Dragonfly Cobalt DAC with Foobar. The problem I am having is that Foobar does not automatically select the sampling rate of the file being played. The Dragonfly LED color should change according the sampling rate of the file being played. When I use Foobar, the color stays with the sampling rate that I have to manually set via the windows setting for the output device (for example, if I set the sample rate to 44 khz via the windows settings, the dragonfly will remain green regardless of the sample rate of the file I am playing on foobar). I tried installing both the WASAPI and ASIO components in Foobar, but this did not change anything. As an experiment, I installed Audirvana on my laptop just to test, and Audirvana does automatically change the sampling rate of the file being played through the Dragonfly. So, clearly the problem is with Foobar. Can anyone help me with this?

Re: Dragonfly cobalt - Foobar doesn't set sampling rate automatically

Reply #1
Just installing WASAPI component isn't enough, you have to select the correct output mode in Preferences / Output after installing it.
I have a Dragonfly myself, everything works as intended.

Re: Dragonfly cobalt - Foobar doesn't set sampling rate automatically

Reply #2
Just installing WASAPI component isn't enough, you have to select the correct output mode in Preferences / Output after installing it.
I have a Dragonfly myself, everything works as intended.

Hi Peter. Can you guide me through how to correctly select the output mode? It says "Output data format will be chosen automatically for the selected device" Above that, the section with the "Output data format" pulldown menu is greyed out and I can't select anything. I'll attach a screenshot.

Re: Dragonfly cobalt - Foobar doesn't set sampling rate automatically

Reply #3
Have you installed the required WASAPI output support 3.3 component?

Re: Dragonfly cobalt - Foobar doesn't set sampling rate automatically

Reply #4
And then change the 'Device' (on screenshot) to WASAPI event / push.

Re: Dragonfly cobalt - Foobar doesn't set sampling rate automatically

Reply #5
And then change the 'Device' (on screenshot) to WASAPI event / push.

Great! I hadn't changed the device to that setting. I just tried and now it works. My Dragonfly changes colour based on the sample rate of the file being played. Thanks for your help!

I have two more questions about these settings:
1) What is the difference between WASAPI event vs. WASAPI push? I tried both of them, and they both work. Is one more appropriate than the other?
2) I've set the output data format to 24 bit (see screenshot). When it was set on 16 bit, foobar gave an error when I tried to play the files. But, when I set it to 24 bit, it plays 16/44 files with the Dragonfly green, and 24/96 files with the Dragonfly light blue. Is it fine to just leave it at 24 bit, even for 16/44 files?

Thanks again!

Re: Dragonfly cobalt - Foobar doesn't set sampling rate automatically

Reply #6
1) Something to do with buffering and how the DAC receives the audio. You can probably google for the technical details. I guess event mode is preferred if it works.

2) You can safely leave it on 24-bit, on the chance you play 24-bit files. I believe playing 16-bit are just padded with zeros, the audio data is unchanged from the DAC perspective. Possibly it has to match the setting in Windows audio device advanced tab.

(But look, I'm no expert, I'm just answering seeing no one else did. Someone can freely correct me if need be... :D )

 
SimplePortal 1.0.0 RC1 © 2008-2020