Skip to main content

Notice

If you are using a Hotmail or Outlook email address, please change it now, as Microsoft is rejecting all email from our service outright.
Topic: Network Drive No Longer Visible with foobar2000 v1.6.2 beta 7 (Read 485 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Network Drive No Longer Visible with foobar2000 v1.6.2 beta 7

Hello All

It appears the foobar2000 v1.6.2 beta 7 is not able to see a network drive letter (NAS) to access the library. The previous versions did not have this issue for me.

Any thoughts on what to do? I've copied the address from Explorer directly into the library path, but an error appears despite being visible in the regular explorer page.

(Windows 10 machine)

dj

Re: Network Drive No Longer Visible with foobar2000 v1.6.2 beta 7

Reply #1
Sounds like either the volume was mounted by an administrator process, or foobar2000 is running elevated. Those can't cross each other to access network shares, even mounted to drive letters.

Re: Network Drive No Longer Visible with foobar2000 v1.6.2 beta 7

Reply #2
I'm not sure what you mean by installed 'elevated'.  Why would that preclude seeing a drive letter?
dj

Re: Network Drive No Longer Visible with foobar2000 v1.6.2 beta 7

Reply #3
Mounted drive share letters are specific to the user that mounts them. Administrator and non-administrator are effectively separate users, even when it's just elevated access from a given account.

 

Re: Network Drive No Longer Visible with foobar2000 v1.6.2 beta 7

Reply #4
Note that the feature is optional and network shares can be linked across elevation status with a simple registry change:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System]
"EnableLinkedConnections"=dword:00000001

Re: Network Drive No Longer Visible with foobar2000 v1.6.2 beta 7

Reply #5
Mounted drive share letters are specific to the user that mounts them. Administrator and nonadministrative are effectively separate users, even when it's just elevated access from a given account.

Thanks for that.

So as a remedy, I've rebooted a few times and on the second attempt, the drive letter became visible again. Perhaps this issue was congruent with another system based (Windows 10) update?
dj

 
SimplePortal 1.0.0 RC1 © 2008-2020