Skip to main content

Notice

If you are using a Hotmail or Outlook email address, please change it now, as Microsoft is rejecting all email from our service outright.
Topic: Strange Pause behavior in 1.62 beta 2 (Read 528 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Strange Pause behavior in 1.62 beta 2

I think this bug might have originated in an earlier build, but it's there in the latest beta.

Pause function stops the audio, but the file position continues to advance as much as 60 seconds, so that choosing Pause or Play restarts playback at the wrong point in the file.

This is on Win 10 Home, Version 2004. Output is WASAPI (event). 

Thanks,
Jim K.

Re: Strange Pause behavior in 1.62 beta 2

Reply #1
Thanks for reporting.
What exact audio device is this?
Do you use fading or not?

Re: Strange Pause behavior in 1.62 beta 2

Reply #2
I'm using the computer's built-in Realtek HD Audio chip, using optical out to a Schiit Modi 3 DAC. I don't use fading. Other players work as expected.


Re: Strange Pause behavior in 1.62 beta 2

Reply #3
Does switching to WASAPI (push) help?

Can you please install foobar2000 v1.5.6 portable with WASAPI output and check if the bug is there or not? Perhaps a Windows update or a driver update triggered it, not new foobar2000. Otherwise, if you could tell me in which exact version it broke I should be able to fix it quickly.

Unfortunately I can't reproduce it with any of my machines/soundcards.

Re: Strange Pause behavior in 1.62 beta 2

Reply #4
Yes, switching to WASAPI (push) eliminates the problem. I'll try 1.5.6 portable to see what happens.

Re: Strange Pause behavior in 1.62 beta 2

Reply #5
WASAPI was not one of the output choices in 1.5.6 portable, but Pause worked as expected using the Realtek option.

Re: Strange Pause behavior in 1.62 beta 2

Reply #6
Thanks for the details.
You need WASAPI Output component for WASAPI entries to show up in output device list. It is not included with the installer, so fresh install of 1.5.6 did not have it.

Re: Strange Pause behavior in 1.62 beta 2

Reply #7
Ok, 1.5.6 now set up with WASAPI component. Same problem with Pause--audio stops but file doesn't. Jriver Media Center 27, using the same WASAPI (event) setting, plays and pauses the same file perfectly.

I assume this is only a problem with my configuration and fb2k, and that MC27 WASAPI implementation is just different than yours. You provided me with a solution, so I don't want to take up more of your time. BTW, my specific audio chip is an Asus Realtek S1220A (8 channel).

Thanks, Peter.

Re: Strange Pause behavior in 1.62 beta 2

Reply #8
Thanks for the details.

This is why I still provide push/event modes - there are machines where either mode doesn't work properly. I hope to get rid of it someday (provide just one setting that works everywhere), but I've been unable to so far.

Re: Strange Pause behavior in 1.62 beta 2

Reply #9
JRiver doesn't give the user a choice--they default to event--but they provide a checkbox that makes push options available for users who know what they're doing.

 
SimplePortal 1.0.0 RC1 © 2008-2020