Skip to main content

Notice

If you are using a Hotmail or Outlook email address, please change it now, as Microsoft is rejecting all email from our service outright.
Topic: Folder Image Problem? (Read 261 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Folder Image Problem?

I'm wondering how to actually show album art on folders, everything I personally have ripped/ ID3 tagged with mp3tag shows the files album art, but i'm trying to get album folders to show up like these in the screenshot (specifically the only 3 with images):

Note:  Adding the cover art as cover.jpg or folder.jpg seems to do nothing.

Re: Folder Image Problem?

Reply #1
Hi ProfessaD

I had this problem (app running on Android 6) and have just found the following solution:

The name to use is Folder.jpg (can also be a lower case f) but you have to clear the image cache for it to be used instantly, as follows:

Once you have added the Folder.jpg to a folder (or added them to several folders), then with the Foobar2000 mobile app running tap on the spanner at the top right, then tap on 'Advanced', scroll down to 'Tweaks' section and tap on 'CLEAR' to clear the image cache. Now step all the way back to the 'Browse' menu then navigate back to the folder list and the folder image should be showing, if not then re-start the app.

There's some things to be aware of before adding the Folder.jpg image, which is that it will over-ride the embedded cover images for the tracks and in the player, so best to use an image the same as the embedded cover (unless you want a different cover) on the tracks and in the player, this means it's not suitable for mixed tracks (different track images) in a folder.

When I was testing and added Folder.jpg, I then deleted it thinking it would all revert back to the embedded track covers, I even cleared the image cache, did a rescan in the 'Media Library' and even restarted Foobar2000 (mobile app), yet still no embedded track covers would show. The only way I could get it to rescan the embedded images was to rename the folder (start-over), so it seems that once it has detected Folder.jpg it stores it's path to link it to the folder it's in. I will find the feature useful for Album folders but will not use it on mixed track folders where I have different images showing for each track.

It would be better if they had used Folder.jpg just for the folder and used Cover.jpg to add a cover to the tracks (i.e for when they're not all embedded), that way an image could be added to the folder without over-riding the embedded images, hopefully a developer will see this suggestion.

Tip: I also found the clear cache feature was useful for correcting image mis-matches i.e. I searched in Albums and saw the wrong cover image on one of the tracks. A further way to resolve these sorts of issues if the mismatched cover is from an embedded image, is to temporarily rename the folder of the tracks containing the image, then clear image cache, do a Media library rescan, see if all is now ok then rename the folder back and rescan again.

Hope the above is helpful.

...John

 

Re: Folder Image Problem?

Reply #2
As for the tip I mentioned at the bottom of the post above about resolving mismatching images, I've just found an easy way to force a complete re-scan and now the errors have all gone. It is to go to the Media Library and turn off the rescan on the folders that have the issues, this then dropped all the tracks, showing 0 tracks, then turn it back on again and it rebuilds the database. Now I'm seeing this correctly then it's easier to browse via the meta tag options (i.e. Artist, Album or Title), whereas there is no search and limited options on the folder browsing.

 
SimplePortal 1.0.0 RC1 © 2008-2020