Skip to main content

Notice

Please be aware that much of the software linked to or mentioned on this forum is niche and therefore infrequently downloaded. Lots of anti-virus scanners and so-called malware detectors like to flag infrequently downloaded software as bad until it is either downloaded enough times, or its developer actually bothers with getting each individual release allow listed by every single AV vendor. You can do many people a great favor when encountering such a "problem" example by submitting them to your AV vendor for examination. For almost everything on this forum, it is a false positive.
Topic: Please do not strip Windows XP support in Foobar 1.6 (Read 1136 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Please do not strip Windows XP support in Foobar 1.6

Dear Mr. Peter Pawlowski,

First: Foobar 2000 is a great music player, imho the best that does exist in 2020. I am a faithful user for many years!

I really would like to see continued support for Windows XP SP3 (which would also allow continued support for Windows 2003)
and it would also allow continued support for the new and still maintained operating system ReactOS, which promises current and future compatibility to the APIs provided by Win2003SP2.

Foobar 2000 (the Windows XP compatible versions) is already running on ReactOS.
By keeping support for Windows XP SP3 in Foobar2000, you would automatically be supported by a real free and open operating system therefore!

Thank you very much for considering this proposal!

Re: Please do not strip Windows XP support in Foobar 1.6

Reply #1
Dear user,

Please do not use FOSS as a justification for continued Windows XP support.
The latest version of foobar2000 is reported to actually work better on Wine than older versions - exactly because it quit using long-deprecated APIs (DirectSound). I would rather spend time on improving Wine compatibility than on Windows XP, because more people may actually use it - now or in the future.

Other than that, foobar2000 v1.5 series is still maintained - if you find and report bugs in it, a new update will be posted.
foobar2000 v1.5 was tested and verified working on a Pentium 2 PC running Windows XP. While it's certainly fun to do, I cannot keep this up forever.

Re: Please do not strip Windows XP support in Foobar 1.6

Reply #2
More reasons to not support WinXP:
- Supporting WinXP limits the features that can be used in the application (a lot of features are available only on Win7+).
- WinXP support often requires additional hacks.
- WinXP reached EOL a long time ago.
- WinXP share (according to Google) is less than 0.5% (compared to Win8.1 at ~5% and Win7 at ~20%).

[EDIT]
Quote
foobar2000 v1.5 was tested and verified working on a Pentium 2 PC
@Peter , wow, where are you even getting such ancient stuff (esp. in proper working condition)? :D

Re: Please do not strip Windows XP support in Foobar 1.6

Reply #3
Dear Mr. Peter Pawlowski,

thank you for having read my message and considering my argumentation.
Ofc I can not force you and I do understand. My request was based on the observation what happened to other formerly good FOSS SW, when they stripped Windows XP support. It often leads to unnecessary forks evolving, take Mozilla Firefox as a prominent expample, which recently declined and fell off into many forks, like Arctic Fox, PaleMoon, New Moon, Basilisk, Mypal, Seamonkey, etc.
Unnecessary forking steals power and skilled developers from such projects, that could otherwise progress more quickly and in unity.

Saying I could still use Foobar2000 1.5 is technically correct, but since I am a SW dev myself, I know that this will help for a very limited time just and sooner or later such "legacy branches" will inevitably get abandoned. As the effort to groom two diverging codebases is immense.

Nevertheless, I am happy, that you read my arguments at least and I don't want to start any flamewar here.
I just read the changelog, saw the fact that XP support is to be stripped and hoped, that mentioning that there are still loyal foobar-XP users and other usecases for XP-support out there, that would really appreciate continued support, might have helped to reconsider your decision. That's all.

Thanks again. I did what was in my limited power. There is no grudge on my side.
Thanks for having provided what I always perceived as an excellent piece of SW.

Re: Please do not strip Windows XP support in Foobar 1.6

Reply #4
Windows XP has been End of Life since April 2014. It is irresponsible to continue using outdated software and expecting developers to continue to support it. It is unfortunate that some institutions refuse (either due to unwillingness or inability) to migrate to updated and supported versions, but that does not shift the onus to developers.

Re: Please do not strip Windows XP support in Foobar 1.6

Reply #5
By keeping support for Windows XP SP3 in Foobar2000, you would automatically be supported by a real free and open operating system therefore!

If you're a ReactOS developer:

by implementing Windows 7 APIs, you would automatically be supported by a great audio player, foobar2000!

Re: Please do not strip Windows XP support in Foobar 1.6

Reply #6
Support for Windows XP is not *dropped*.
Old versions that work on Windows XP will be provided for downloading indefinitely.
At least one more 1.5.x will be made with current bugfixes backported (current pending: Matroska alter gain crash, AAC remove-tags, ZIP memory leak, HTTP/FTP relative paths in M3U).
If there are other bugfixes that I forgot about in the 1.6 change log, pointing them out is welcome.

Re: Please do not strip Windows XP support in Foobar 1.6

Reply #7
What about win98 support? :)  I would like to use foobar on a virtual 98 machine though ....

Re: Please do not strip Windows XP support in Foobar 1.6

Reply #8
Then install 0.8.3 from somewhere. And find plugins for that version too, lol.

 
SimplePortal 1.0.0 RC1 © 2008-2021