Skip to main content

Notice

If you are using a Hotmail or Outlook email address, please change it now, as Microsoft is rejecting all email from our service outright.
Topic: Bug: Cover art not showing (Read 379 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Bug: Cover art not showing

I have a flac album with cover art that shows up fine on foobar2000 for Mac. After I transfer it to to the iOS app, the art is not showing up. There doesn't seem to be any errors in the logs. If needed for debgging purposes, I can provide the cover art file (jpg) and the flac.

Separately, I also have a multi disc album that has separate cover art per disc. The app is only showing one cover art picture for all the discs.

Re: Bug: Cover art not showing

Reply #1
Any update on these issues?

For issue 1, I attached a sample jpg to help reproduce.
For issue 2, it should be easy to reproduce if you have one album with tracks that have different cover art.

Let me know if there is any way I can help.

Re: Bug: Cover art not showing

Reply #2
I encountered this bug.

In my case, if the audio file has no "album" meta tag, cover doesn't show even though it's embedded.

Re: Bug: Cover art not showing

Reply #3
Another album art issue, on Android, maybe related, maybe not:
All my music is on a NAS, that is accessible from foobar2000/windows as well as - through ftp - from android foobar mobile.
(eventually also through WAN/IP address from outside, but now as local LAN ftp).
Many albums that are shown with album art in foobar2000 do not show the album art in mobile when browsing the indexed files (so genre/artist etc).  But curiously enough when I browse the ftp folder structure they do show up, also when playing the tracks. So something happens during indexing, but I just cannot figure out why some album art shows up and some not. Most art is contained in folder.jpg files in the directory of the album. 
I hope one of the developers can shed light on this, and how album art is processed during indexing, with/without embedded art and external (jpg/png) files.  Are some files rejected in mobile? Is the link to the art not preserved properly in the index? There are no Show errors after indexing, no useful console information either.
 
Thanks!
Pete
 

Re: Bug: Cover art not showing

Reply #4
Ok, I removed all embedded art from the flac files (using foobar2000), and now it is ok, with the art from the folder.jpg displayed. There seems to be a problem with mobile extracting the image from the flac wrapper.

 
SimplePortal 1.0.0 RC1 © 2008-2021