Skip to main content
Topic: No audio on Linux ALSA HDMI (Read 195 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

No audio on Linux ALSA HDMI

Hello,
I got an Ubuntu Linux box, which is using ALSA as audio output device and HDMI speakers.
The thing worked the first time I tried, but after that I obtain no sound.
I can see the lights in the mixer going up and down, but no audio.
What can I do?
Thank you
Roberto

Re: No audio on Linux ALSA HDMI

Reply #1
Ok,
I got more info and a partial success. I fired this command:
Code: [Select]
$ inxi -SMA
...
Audio:     Card-1 NVIDIA Device 10fa driver: snd_hda_intel Sound: ALSA v: k4.15.0-112-generic
           Card-2 Intel Cannon Lake PCH cAVS driver: snd_hda_intel
           Card-3 Logitech B525 HD Webcam driver: USB Audio

which told me that Audio Card-1 is the ...NVIDIA GPU. Which makes sense, since it's defined as default audio output in the system preferences.
Then I connected a pair of earbuds to the frontal headphone port of my PC, selected them as output and then I was able to hear drum sounds.

The fact is that I did an
Code: [Select]
apt upgrade
after installing hydrogen and it installed some NVIDIA upgrades; so that may have mess things up with the HDMI output (the rest of the audio output is fine, though).

Roberto

Re: No audio on Linux ALSA HDMI

Reply #2
I think I nailed it!
Under Tools - Preferences - Audio System I saw that the default Audio Device was hw:0

I fired up this command (sorry, it's in Italian):

Code: [Select]
$ aplay -l
**** Lista di PLAYBACK dispositivi hardware ****
scheda 0: PCH [HDA Intel PCH], dispositivo 0: ALC887-VD Analog [ALC887-VD Analog]
  Sottoperiferiche: 1/1
  Sottoperiferica #0: subdevice #0
scheda 0: PCH [HDA Intel PCH], dispositivo 1: ALC887-VD Digital [ALC887-VD Digital]
  Sottoperiferiche: 0/1
  Sottoperiferica #0: subdevice #0
scheda 2: NVidia [HDA NVidia], dispositivo 3: HDMI 0 [HDMI 0]
  Sottoperiferiche: 1/1
  Sottoperiferica #0: subdevice #0
scheda 2: NVidia [HDA NVidia], dispositivo 7: HDMI 1 [HDMI 1]
  Sottoperiferiche: 1/1
  Sottoperiferica #0: subdevice #0
scheda 2: NVidia [HDA NVidia], dispositivo 8: HDMI 2 [HDMI 2]
  Sottoperiferiche: 1/1
  Sottoperiferica #0: subdevice #0

which tells me that HDMI 0 is device 3. So I changed the upper setting to hw:3 and now the output is via HDMI to my monitor.

Roberto

 
SimplePortal 1.0.0 RC1 © 2008-2020