Skip to main content
Topic: Foobar's shuffle option always plays the same songs (Read 304 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Foobar's shuffle option always plays the same songs

I have a large playlist, about 1800 songs. I put it on shuffle and I always get the same songs/artists, with some variations here and there. Not quite randomised. What can I do?

Re: Foobar's shuffle option always plays the same songs

Reply #1
There's a random option. Random and shuffle are two different things, however if you hold down Shift while clicking on the Playback menu, you'll find a Reshuffle menu item. It can also be added to the GUI as a button.

Re: Foobar's shuffle option always plays the same songs

Reply #2
Hi there,

Yes, Shuffle order stays the same unless you manually use the 'Reshuffle' option - see the FAQ.

For me the trouble is that it 'Reshuffles' the track order on every restart. So if you restart foobar often, you might end up hearing a track you heard yesterday, even with big playlists.

I figure there are two ways around that -

1) Randomize the entire playlist with Edit > Sort > Randomize and set Playback > Order to 'Default'. Much the same as the internal shuffle, except you can see the track order, and pick-up where you left off with no repeats after restarts.

2) Keep order on 'Shuffle (tracks)' and use Skip Tracks to auto-skip recently played tracks, with the help of Playback Statistics field %last_played%. So use a skip query like this -

Code: [Select]
%last_played% DURING LAST 5 DAYS

(Adjusted for how long it takes you to get through the playlist)

Basically either of these methods, would play through the entire playlist without repeating a song across restarts. (Not necessarily what you were asking, I know)

On the other hand, it would do exactly that normally if you are leaving foobar open for the duration. In which case, you can only 'Reshuffle' / 'Randomize'. There is a Preferences > Advanced option to 'Reshuffle on manual track selection' (double-click) which you could try, but that would not stop recently played repeats (and might even increase the chances)

Cheers

Re: Foobar's shuffle option always plays the same songs

Reply #3
Hi there,

Yes, Shuffle order stays the same unless you manually use the 'Reshuffle' option - see the FAQ.

For me the trouble is that it 'Reshuffles' the track order on every restart. So if you restart foobar often, you might end up hearing a track you heard yesterday, even with big playlists.

I have one huge playlist, which is maybe why I've never noticed, but what's the logic behind reshuffling each time fb2k starts?

Another option could be to remove a track from a playlist once it's been played, so even if fb2k does reshuffle, you shouldn't hear a repeated song until the playlist is empty. I'm pretty sure Playlist Attributes can be configured to do that for individual playlists, or for any playlist.

 

Re: Foobar's shuffle option always plays the same songs

Reply #4
Thanks anamorphic, I'll try the randomise option and if that doesn't work, the other methods you mentioned.

 
SimplePortal 1.0.0 RC1 © 2008-2020